MATE menu keyboard shortcut doesn't work

Bug #898184 reported by Juri Lelli
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Linux Mint
Fix Released

Bug Description

Linux Mint 12 (64bit) with the MATE desktop environment.
If you hit <Control>Super_L nothing happens even if this key-stroke should open the menu.
I've tried to modify the shortcut, but nothing changes. No way to open the Menu with the keyboard.
Happens always.

Revision history for this message
Vojtěch Procházka (v.proch) wrote :

The same happens on Linux Mint 12 32bit.

Revision history for this message
Kimiko Koopman (kimiko) wrote :

I'm not entirely sure, but this might be a duplicate of bug #891424.

Revision history for this message
Stefano Karapetsas (stefano-karapetsas) wrote :

The issue is solved in mate-settings-daemon 1.1.0-4 (currently in trixed repository).

Changed in linuxmint:
status: New → Fix Committed
Changed in linuxmint:
status: Fix Committed → Confirmed
Revision history for this message
Peter M. Clausen (pclausen) wrote :

Changed status -> Confirmed

I have this issue on mate-settings-daemon 1.2.0-1 in Linux Mint LMDE 201204 64-bit on virtual box installation. Changing shortcut to something else, e.g. "<Control>e" did not make the menu pop up.

Is there any other place to change this setting? Would it not make sense to move this setting to Preference -> Keyboard ShortCuts ?

Other than that - really nice distro; I'm even considering making it my main working environment... :-)

Revision history for this message
Swed (sweduv-ghost) wrote :

Same on mate-settings-daemon 1.2.0-4

Revision history for this message
R (thirdparty) wrote :

Still an issue under LMDE 13. This is a total dealbreaker for MATE usage.

Revision history for this message
Tim Abell (tim-abell) wrote :

Same here. Running from the console shows:

tim@lappy ~ $ mintmenu
*********** Keybind Driver Load Failure **************
Error Report : No module named deskbar.core.keybinder
Opacity is: 98
Setting opacity to: 0.98
__init__ took 202.504 ms
Binding to Hot Key: Super_L
** WARNING ** - Menu Hotkey Binding Error
Error Report :
global name 'bind_key' is not defined
/usr/lib/linuxmint/mintMenu/ Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed

I tried installing python-keybinder: Installed: 0.2.2-3, but to no effect.

I was warned some things would be broken in LMDE! :-) Hopefully this info will help out.

Revision history for this message
J. Albert (j.albert) wrote :

@tim-abell: You almost had it...

1. Install python-keybinder (sudo apt-get install python-keybinder)
2. Apply the attached patch to (sudo patch /usr/lib/linuxmint/mintMenu/
3. Log out and back in
4. Press <Control>Super_L
5. :-)

Explanation: As a comment in suggests, the developer tried to avoid unnecessary dependencies (python-keybinder was part of deskbar-applet and didn't exist as a standalone package back then) and therefore placed the keybinder code directly into the mintMenu folder. Later, it somehow got removed and the maintainers forgot to fix the code and also to add the new "python-keybinder"-dependency to the package info.

Revision history for this message
Andrew Sorensen (andrew-localcoast) wrote :

I am experiencing the same issue with Mate and mintMenu on Ubuntu 12.04. Installing the package python-keybinder and the patch in comment #8 solves this issue.

Revision history for this message
caribriz (caribriz) wrote :

I also had a problem with trying to use Super_L keyboard shortcut for mintMenu in Linux Mint 13 xfce.
J.Albert's post #8 with patch also worked for me.
Thank you very much J.Albert!!!!!

Revision history for this message
alelondon (alelondon) wrote :

patch in #8 working great in LMDE fully updated to 2012-12-27
can somone commit this patch,PLEASE?

Changed in linuxmint:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers