The Linux Mint Distribution

WnckletFactory::ShowDesktopApplet

Reported by scarfaces on 2011-05-16
170
This bug affects 37 people
Affects Status Importance Assigned to Milestone
Linux Mint
Undecided
Unassigned

Bug Description

After upgrading to Katya RC, started getting error messages in Gnome during some startups, caused by panel being unable to load some of the normal desktop applets sometimes (trash, clock, network manager).

-------

The panel encountered a problem while loading "WnckletFactory::ShowDesktopApplet".

Do you want to delete the applet from your configuration?

Don't Delete | Delete

------

john williams (johnwillyums) wrote :

After installing Katya RC and running it successfully a number of times I got an error message at startup saying that the clock/date applet would not load.
I think I got a "skip" option but I'm not sure. Anyway I clicked it to continue.
Now the Time&Date applet configuration choice still appears in Control Panel but is greyed out and does not respond.
The clock applet no longer appears in the bottom bar.

Any ideas? Thanks, John Williams

Big D (douglas-crowder) wrote :

I have same behavior at times. In Katya RC it was frequent. It is less frequent in the released version but still occurs. I reported it as Bug 788427 which was tagged as a duplicate of this one. Let me know if I can help test any fixes.

Miccheli (mice272) wrote :

Similar problems here too and same problems seen on forums also. I freshly installed the Mint 11 and right from the start the clock won't show and indicator applet fails to load every now and then. Some suggestions were about compiling kernel again, which seems to be difficult.

Arno Teigseth (arnotixe) wrote :

yep I installed katya on my machine and I don't want to abandon gnome, but this should be fixed. This is my first 64-bit machine and it's also the first time I've ever had this kind of panel problem.

The apps fail to load (seems to be at random). I've also had apps fail at load running the Live CD on 64-bit systems. Doesn't look too good as a "welcome to try me out" screen...

Me too would like to help out hunting down & smoking out this bug.

Bob (bob88) wrote :

I'm also seeing this on Mint 11 on a Dell Latitude E4300 after a fresh install.

Pretty much the same symptoms as above, didn't have an issue on 10.

Victor (vstadnichenko) wrote :

I have the same panel problem every other time:
1. The Panel encountered a problem while loading "IndicatorAppletFactory::IndicatorApplet" Do you want to delete the applet from your configuration?
2. The Panel encountered a problem while loading "ClockAppletFactory::ClockApplet" Do you want to delete the applet from your configuration?
3. The Panel encountered a problem while loading "MultiLoadAppletFactory::MultiLoadApplet" Do you want to delete the applet from your configuration?
4. The Panel encountered a problem while loading "WnckletFactory::WindowListApplet" Do you want to delete the applet from your configuration?

As a workaround I use to reboot the system a few times, and usually the 2nd or 3rd time it starts OK. My guess is there is race conditions.

Anthony Mangeri (stallion442) wrote :

I've just installed Mint 11 64-Bit on ASUS notebook U52F and at boot-up am having same problems with menu bar applets failing every other or every third boot-up. It wasn't an immediate problem for me. I booted-up several times shortly after my initial installation after adding BURG boot-loader and tweaking it with a companion program to change boot order and boot options. (Grub Customizer - which is also works for making changes to BURG) (I'm dual booting with Windows 7 64-Bit). I then added a splash screen (plymouth-theme-mint-logo) since Mint 11 is without one. For me it's comforting to see some activity then just a blank black screen during the boot sequence. It was after adding the boot screen that I first noticed the applet loading problems. It may be a coincidence but not sure. I don't think what I added should interfere but I'm still learning linux and only understand what I've read and learned from others. For me its mostly the "WnckletFactory::ShowDesktopApplet" the fails to load, but this last boot-up another from "WnckletFactory" has added to applets failing to load. Have only had Mint 11 on my PC for a little more than a day, so will find out if problem escalates with time. Hope a fix is found soon. It doesn't bother me too much, but if problem grows and I can't perform normal functions, then I'll start to frown at Mint 11. So far I like it. I've used Mint 8 in past on another computer and so hoping to see good improvements in 11.

William Stone (woot-will) wrote :

I just received this error myself. I installed Linux Mint 11 three days ago, and this is the first time I have seen the error. It appeared right after the desktop loaded, and I noticed that I am not seeing any applications across the bar on the bottom of the screen. However, my clock and calendar is functioning just fine. I noticed others mentioning it was greyed out, but that is not the case for me.

This is a 64-bit machine that I dual boot with Windows 7.

Johannes (kakemphaton) wrote :

Very annoying bug, affecting a lot of people - see Mint forums thread:
http://forums.linuxmint.com/viewtopic.php?f=55&t=73643&start=0

setcho (setcho) wrote :

I've had this problem since Mint 11 RC 32bit was released. I've tried all the suggestions in a number of threads to fix it and so far nothing has worked. Personally I see errors with the clock and the "WnckletFactory::ShowDesktopApplet"

Overall I am disappointed with Mint 11 as Mint 10 never gave me a single problem, in fact it was so reliable my use of Linux overtook my use of Windows and I haven't gone back to windows since. I'll be moving on to a different distro until this is fixed.

Artem Nagornyi (anahorny) wrote :

This is a bug from Ubuntu, look here: https://bugs.launchpad.net/ubuntu/+source/gnome-panel/+bug/716714
It was also independently reported to Gnome bugzilla, it seems to be a race condition problem: https://bugzilla.gnome.org/show_bug.cgi?id=637219#c6

Paul (paulsantman) wrote :

This bug also affects me sadly enough. Running Linux Mint 11 64-bit on my Thinkpad X220, with 4 gig ram.

Almost each session one of the applets disappears with given error message. Really annoying, as I sometimes do not know the state of the battery (battery applet disappears), network connection (network applet disappears) or even the time (time applet disappears).

Have done re-install of Linux Mint 11, but didn't help. Would love t see this bug fixed, because it really makes the operating system quite unusable (e.g. the laptop shuts down because i didn't have any idea on its battery status).

Suffering also from a similar problem. on two installs..

"The panel encountered a problem while loading "WnckletFactory::WindowListApplet"."

Nikhil Sinha (nikhildotnet) wrote :

Affected Operating System Version - LinuxMint 11 (32 bit and 64 bit)

Steps to Reproduce - When LinuxMint Desktop is loaded, error message appears - 'The Panel encountered a problem while loading "IndicatorAppletFactory::IndicatorApplet" Do you want to delete the applet from your configuration?'.

This is show stopper for users and should a high priority bug.

Changed in linuxmint:
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.