The Linux Mint Distribution

LMDE XFCE can't connect to pppoe using network manager

Reported by Igor Tarasov on 2011-03-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux Mint
Undecided
Clement Lefebvre
ppp (Debian)
Invalid
Undecided
Unassigned

Bug Description

Using LMDE XFCE 201104 i386. Created new PPPoE connection, trying to connect and getting error. The log says:

Mar 25 20:22:30 mint pppd[2887]: Plugin /usr/lib/pppd/2.4.5/nm-pppd-plugin.so is for pppd version 2.4.5, this is 2.4.4
Mar 25 20:22:30 mint NetworkManager[2117]: <warn> pppd pid 2887 exited with error: pppd options error

Versions mismatch make it fail any time whatever options you use.

Ubuntu-based distros work well with PPPoE.

Changed in linuxmint:
milestone: none → lmde-201104
Changed in linuxmint:
importance: Undecided → High
assignee: nobody → Clement Lefebvre (clementlefebvre)
status: New → Triaged

TiGR: Can you confirm the versions of ppp and network-manager-pptp installed on your system?

Changed in linuxmint:
status: Triaged → New
Changed in ppp (Debian):
status: New → Invalid
Igor Tarasov (tarasov-igor) wrote :

Why did you mark bug as Invalid? Here are versions:

mint@mint ~ $ apt-cache show ppp
Package: ppp
...
Architecture: i386
Version: 2.4.5-4
Depends: libc6 (>= 2.7), libpam0g (>= 0.99.7.1), libpcap0.8 (>= 0.9.8), libpam-modules, libpam-runtime, procps
Breaks: network-manager (<= 0.8.0.999-1), network-manager-pptp (<= 0.8.0.999-1), pppdcapiplugin (<= 1:3.9.20060704+dfsg.1-1)
...
mint@mint ~ $ apt-cache show network-manager-pptp
Package: network-manager-pptp
...
Architecture: i386
Version: 0.8.1-1
Depends: libc6 (>= 2.3.6-6~), libdbus-1-3 (>= 1.0.2), libdbus-glib-1-2 (>= 0.78), libglib2.0-0 (>= 2.16.0), libnm-glib-vpn1 (>= 0.7.999), libnm-glib2 (>= 0.7.999), libnm-util1 (>= 0.7.0), pptp-linux, ppp (>= 2.4.5), ppp (<< 2.4.6)

See for yourself. ppp version is 2.4.4, nm-pptp requires ppp >= 2.4.5, and network-manager packages are thus broken.

It is a live session of linuxmint-debian-201104-rc-i386.iso. I have not updated anything, since I could not connect to network.

Igor Tarasov (tarasov-igor) wrote :

I've copied wrong data about ppp.

There is one optional package, with version 2.4.5. It is not installed. The one that is installed is this:

Package: ppp
Status: install ok installed
Priority: optional
Section: admin
Installed-Size: 900
Maintainer: Marco d'Itri <email address hidden>
Architecture: i386
Version: 2.4.4rel-10.1
Replaces: ppp-pam, ppp-udeb
Depends: libc6 (>= 2.7-1), libpam0g (>= 0.99.7.1), libpcap0.8 (>= 0.9.3-1), libpam-modules, libpam-runtime (>= 0.76-13.1), netbase, procps

Thanks. You simply have the wrong version of ppp, or the wrong ISO?

The correct filename for the ISO should be: linuxmint-debian-201104-xfce-rc-i386.iso
It's MD5 is: 308e3aa7a0f9763667f21b408d1af0fe
It comes with ppp version 2.4.5-5

Changed in linuxmint:
status: New → Invalid
importance: High → Undecided
Igor Tarasov (tarasov-igor) wrote :

I have this exact ISO with this exact hash. And it holds ppp 2.4.4. As I said, dpkg somehow knows about 2.4.5 package, but it is not installed.

Hi TiGR, can you paste the content of the following commands:

"apt version ppp"

"apt show ppp"

"apt search ppp"

"cat /etc/linuxmint/info"

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers