headphone jack doesn't work properly on Lenovo thinkpad EDGE

Bug #723317 reported by letian on 2011-02-22
This bug report is a duplicate of:  Bug #691016: Quirk needed for ThinkPad Edge 13". Edit Remove
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux Mint
Incomplete
Undecided
Unassigned
openSUSE
New
Undecided
Unassigned
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

1) Linux Mint 10 (Julia), laptop: Lenovo Thinkpad EDGE 13'
2) I plug in my headphones into the headphone jack on my laptop
3) The laptop speakers are not muted, headphones do not work.
4) Speakers should be muted, sound should come from my headphones
5) The problem didn't happen first when I added "options snd-hda-intel model=olpc-xo-1_5" string to /etc/modprobe.d/alsa-base.conf file and restarted, but now it occurred again, and there is nothing I can do to fix it. This is a known issue with thinkpad laptops in opensuse and ubuntu, and it is not fixed!!! Editing alsa-base.conf doesn't help!!!

letian (tianeast) wrote :

I insist that this issue should be fixed, I changed a distro for Linux Mint, hoping that this issue is resolved in Mint(Ubuntu), but it is not true. Editing alsa-base.conf doesn't help in opensuse or in Mint, changing setup via gnome-alsamixer doesn't help either! This is a bug, and it should be fixed.

What I tried:
opensuse and Mint, both:
editing .conf files - adding this string "options snd-hda-intel model=olpc-xo-1_5" - result: worked only once
editing .conf files - adding this string "options snd-hda-intel model=ideapad" - result: didn't work
editing .conf files - adding this string "options snd-hda-intel model=thikpad" - result: didn't work

opensuse:
manual config of audio-card via yast - result: works only for one session, sometimes

Mint:
manual config of audio-card - result: no result

summary: - headphone jack doesn't work properly
+ headphone jack doesn't work properly on Lenovo thinkpad EDGE
description: updated
Ikey Doherty (ikey) wrote :

Hi, thank you for reporting this issue!

Maybe I've missed it but I couldn't see your
audio hardware from the information you've
provided. Could you please post the output
of inxi -xA ?

Thanks!

Changed in linuxmint:
status: New → Incomplete
letian (tianeast) wrote :

Hi there, this is my " inxi -xA" output:
Audio: Card-1 ATI RS780 Azalia controller driver HDA Intel BusID: 01:05.1
           Card-2 ATI SBx00 Azalia (Intel HDA)driver HDA Intel BusID: 00:14.2
           Sound: Advanced Linux Sound Architecture Version 1.0.23

I've reinstalled Linux mint 10, I didn't change or edit any files, and my headphones do work fine. Speakers are muted, headphones work. But I still think that this issue should be fixed properly.

affects: ubuntu → alsa-driver (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers