LMDE 201012 32-bit live-session not working for everybody

Bug #694177 reported by Peter Hohensasser on 2010-12-24
50
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Linux Mint
Fix Released
Critical
Clement Lefebvre

Bug Description

A couple of people, including me, only get a black screen when trying to boot of the new lmde 32 bit iso. THis problem has occured on nvidia, ati and intel cards. With xforcevesa I was able to boot into a console and grab a xorg.0.log.

Can't make much sense of it myself but "(II) Primary Device is: PCI 01@00:00:0
(EE) VESA: Kernel modesetting driver in use, refusing to load
(WW) Falling back to old probe method for vesa
(EE) No devices detected.

Fatal server error:
no screens found"

does look fishy.

There is also a forum thread about this at http://forums.linuxmint.com/viewtopic.php?f=141&t=62437

Justin Krehel (jkrehel) wrote :

Hi Peter

Thank you very much for reporting this. I am working on seeing what the issue is here. One thing you can try is starting in compatibility mode and also pass nomodeset as a boot option. For my nvidia card it would not boot until I had done that. I had crashes in Nouveau which was tainting the kernel. Also if you could attach a dmesg it would be helpful. That was how I was able to spot the Nouveau crash.

Please test and let me know the results. I'd like to see if nomodeset can help others.

Thanks!

Changed in linuxmint:
status: New → Confirmed
Lewdsquirrel (lewdsquirrel) wrote :

Hi,
same problem here. Tried the live LMDE 201012 32-bit on two different computers, one with NVIDIA graphic and the other with ATI graphic. Black screen on both computers. So this is not just a NVIDIA problem.
Also tried the "nomodeset" fix, no luck. Using Ctrl-Alt-F2 the error message is "no screens found".
The previous LMDE DVD (201009) works just fine with these two computers.
Using Mint flavors since 3 years, never had this problem before...

My 2 cents.

thanks for the quick answer justin.

I tried what you suggested but the result was the same as with xforcevesa alone (no gdm/X - console reachable)

Here's the dmesg output:

(oh and btw: i know it's probably visible in the attachments anyway but I have an ati card. just saying that because according to the forum there has been progress for nvidia users)

Justin Krehel (jkrehel) wrote :

Attaching my own dmesg for reference, notable right around 32s mark.

Changed in linuxmint:
importance: Undecided → Critical
assignee: nobody → Clement Lefebvre (clementlefebvre)
Ian Mossop (ian-mossop95) wrote :

Hi,

Similar things to report for me also. Trying LMDE 201012 version on a laptop which has successfully run the original LMDE version. This is a Dell Latitude D600 with ATI Radeon 9000 graphics (lousy card for Linux I know, but it has worked OK before).
I get the black screen as described above. Tried compatibility mode and nomodeset boot parameter, all to no avail. Have verified that the DVD is OK.

Justin Krehel (jkrehel) wrote :

nomodeset needs to be passed right after xforcevesa in the grub entry menu. Posting it at the end as far as I know does not work.

Trevor (tadcock-gmail) wrote :

Cannot add anything helpfful in the technican details but wish to emphasise that many, if not all, 32-bit version users cannot use the latest Live Disk as must have been intended. This surely a big blow to the Mint brand unless it can be corrected before the various reviewers get to hear of the fault. Great material for a headline.

Trevor (tadcock-gmail) wrote :

I cannot add anything very useful to the technical details but wish to emphasize that virtually nobody can get the 32-bit version Live DVD to load and work. Something surely needs doing to effect a reissue before any more damage is sustained by th Mint brand. As far as I can tell, reviewers have not realised yet.

Lewdsquirrel (lewdsquirrel) wrote :

Following up on this issue:
I followed the instructions of Justin K (nomodeset passed right after xforcevesa):
The fix works for the machine with Nvidia, desktop loaded and displayed correctly.
Still no luck with the machine with ATI: black screen...

Justin Krehel (jkrehel) wrote :

Lewdsquirrel:

In an ATI environment, try passing (after xforcevesa) radeon.modeset=0 and see if that fixes it -- I got that to boot up on my ATI laptop. Looks like ATI's are rejecting the nomodeset flag (something I was unaware of but learned).

To all: I managed to break open the iso and make some ugly hacks to get booting on my boxes. Long and short of it I had to blacklist nouveau and turn of modesetting for radeon. This hacked up iso boots but resolution is pretty terrible (especially on nvidia).

At this point it is not my iso to distribute (i don't have upload rights to the repositories and the like, nor can I represent Mint with regards to official releases), and I'd like to find a better solution (update kernel maybe?). I am issuing out my iso to a handful of people to test and report back some results, since I don't want yet another problematic iso being leaked.

Thank you all for your patience. I need to contact clem at this point.

Lewdsquirrel (lewdsquirrel) wrote :

Justin,
I can confirm that your fix (radeon.modeset=0) is working with the machine with ATI graphic.
Thanks for your help.
Now, one last question:
Will we also have to manually modify the GRUB once the system is installed on these machines (with Nvidia or ATI graphic)?

salsalha (salsalha) wrote :

i'v an old Nvidia, and nomodeset thing works for me... thanks to the IRC people... i thik this would be in the main page...

Greetings

Ian Mossop (ian-mossop95) wrote :

Just to confirm that for me with ati graphics, adding "xforcevesa radeon.modeset=0" to the boot string does get the live DVD to boot successfully.
Don't think I'll install with this DVD yet though. From the Linux Mint Blog, it appears there is a respun iso on the way - think I'll wait for that.

Hi there,

Just to confirm that there is a respin on the way. However you don't need to wait for it... here are the changes in the respin:

- xserver-xorg-video-geode removed (this caused problems on some Intel chipsets)
- nouveau.modeset=0 added to both normal and compatibility boot modes
- radeon.modeset=0 added to both normal and compatibility boot modes

These changes make LMDE 32-bit bootable on most machines without adding kernel arguments. Of course if you know which kernel argument you're missing, you don't need to wait for 201101, you can simply add that argument to 201012. This will result in the live session booting successfully, and post-install you won't need to modify your grub settings.

Changed in linuxmint:
status: Confirmed → Fix Released

Hey CLem,
thanks for taking care of this
Does that mean that post-install kms will also be disabled or that it just doesn't cause problems anymore?

Ian Mossop (ian-mossop95) wrote :

Hello Clem,

Thanks for your reply. I'll try out the install ASAP.

Lewdsquirrel (lewdsquirrel) wrote :

Hi,
I just downloaded version 201101 from a mirror.
It boots perfectly (normal boot) for the machine with the ATI graphic but I still have a black screen (normal boot) with the machine with Nvidia graphic...

Dave Kiss (simpilot89) wrote :

I downloaded 201101 as well and still having the same black screen in both normal boot and compatibility modes. I have an Nvidia graphics card GeForce 7600GS.

Dave Kiss (simpilot89) wrote :

Please disregard my previous post. I checked the forum and the download mirrors and saw that the 201101 iso was pulled and no official announcement was made of the new iso release. I will wait until there is an official announcement of the new iso before downloading further iso's.

My apologies for any inconvenience. Thanks Clem and the team and happy new year!

hey everyone,

1. Thank you for fixing this - I'm really happy with my fresh install now and I don't think I'll have to make another one for years to come :)

2. Just wanted to say that according to the forum, some people still seem to have this problem (without having downloaded the iso prematurely as it seems) http://forums.linuxmint.com/viewtopic.php?f=141&t=63200
Doesn't seem to be very common anymore though and might be unrelated - just thought I'd mention it

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers