multimedia plays fast-forward without any sound

Bug #662554 reported by Koen on 2010-10-18
34
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Linux Mint
High
Divya Shettar

Bug Description

hi.

i have installed linuxmint(gnome) a while back. and first is goes alright.

but a couple of days ago, multimedia suddenly played for to fast ( 1,5 times the normal speed ), even youtube vids, did have this issue. also banshee and rhythmbox.
after purging and reinstalling everything with gestreamer in it it worked fine... untill the next reboot....

so i decided to give linuxmintdebian a try, installed yesterday, did the updates, and now, the next day, the very same problem arises. this time youtube and other web-apps are not affected.

I had the same problem with Mint 10 (Julia) Live DVD. Today I tested it with Debian Mint (LMDE) live DVD, and the problem didn't show.
Some info from inxi -F, if this helps any:

Kernel 2.6.32-5-686 i686 (32 bit)
Distro Linux Mint Debian Edition
Graphics:
Card Intel 82865G Integrated Graphics Controller
X.Org 1.7.7
Res: 1024x768@85.0hz

Best regards,
Emerson

Ikey Doherty (ikey) wrote :

Hi, thank you for taking the time to report this issue!

Unfortunately I'm unable to see what the actual error or
issue is using the provided statement. Please could you
provide the following:
 * Details of the distribution you are using
  (e.g. Linux Mint 10 Main Edition 64-bit)
 * Details of the exact error (including any supporting
  evidence, i.e. logs/screenshots)
 * Version numbers of relevant software
  (e.g. apt-cache policy PACKAGENAME)
 * What you *expected* to happen
 * What *actually* happened
 * Steps to reproduce this issue/error

Thank you for taking the time to contribute to the Linux
Mint project, your time and effort is appreciated as it
helps to make the distribution better for all its users.

Changed in linuxmint:
status: New → Incomplete
Daniel Peterson (texlend) wrote :

My Firefox is playing YouTube in FF also.

 It started yesterday and I have even tried setting up an alias account in Firefox but it still does it.

 I tried to upgrade to FF 4.0 with no success.

Screen shots do not capture this.

Please advise as this is a deal breaker for Linux Mint and I really liked it so far..

Daniel Peterson (texlend) wrote :

Sorry, it is Mint 10, Julia, 64 bit.

Does anyone have any ideas on this?

Daniel Peterson (texlend) wrote :

It is all video not just Youtube. Should I reinstall or does the disk have a repair feature like windows?

Daniel Peterson (texlend) wrote :

The video audio still plays even after Youtube is closed. Do I need to change to a different Linux OS?

Vikki Roemer (compgrokker) wrote :

Problems with youtube videos (if it's just issues with online videos, but watching, say, a dvd is fine) are generally due to adobe putting out terrible flash plugins for linux, especially 64bit. Not much we can do, except keep complaining to adobe.

As for the offline video issues, I'm personally stumped by that, and don't have the means to test it.

Try the following: System>Preferences>Sound>Output Then select "Internal Audio Analog Stereo Stereo"

Apparently it's a sound issue, the video not managing to sync with the audio, causing it to play too fast. Check your pulse audio settings, try to switch to ALSA, check which upgrades if any might have impacted ALSA or Pulse Audio.

Changed in linuxmint:
status: Incomplete → Confirmed
assignee: nobody → Clement Lefebvre (clementlefebvre)
milestone: none → katya-rc1
importance: Undecided → High
Daniel Peterson (texlend) wrote :

It did happen after an upgrade. How do you reverse it? Is there a system restore setting?

Daniel Peterson (texlend) wrote :

I had to reinstall Linux Mint. Everything was working perfect until today. it is doing it again!

I had run bleachbit and installed antivirus clamtk. I heard if I run all updates it will be Mint 11.

This is starting to remind me of Windows...

Daniel Peterson (texlend) wrote :

Update.

 I ran bleachbit on root and it seems to have cleared it up. I also emptied cache and cookies in Firefox. Hope this helps.

tom (dont-use-no-reply) wrote :

I had a similar problem with Mint 13.
My issue was the audio source.
In System->Preferences->Sound Preferences --- Hardware Tab
I have two audio devices:
  1) Built in audio
  2) RS880 HDMI

I tried both until "test speakers" produced audio.

Then go to the output tab.

The same 2 audio devices were there, but the incorrect one was selected.

As soon as I changed it to the one that worked for the speaker test, the audio from youtube worked and it played at normal speed.

Adam (itsadamspeaking) wrote :

I just created an account to post my solution. I had the same bug in Chrome only (did not occur in Firefox) and a simple "killall pulseaudio" was all that was required to stop the odd behavior. Note that in my situation, the audio did play at the same rate as video, but it was sped up roughly 2x.

Nolan C (forgetfulfellow) wrote :

Just pitching in to confirm that the above solution by Adam (itsadamspeaking) fixed my 2x audio + video problem on Linux Mint Cinnamon x64. I just entered the 'killall pulseaudio' in my terminal and everything was fixed instantly.

chemicalfan (mike-lumsden) wrote :

Does this bug apply to any of the currently supported releases (i.e. Maya, Nadia, Olivia, or Petra)? If not, this bug should be closed.

chemicalfan (mike-lumsden) wrote :

So is this an outstanding bug in pulseaudio? Has it been patched in Mint 13 already?

tags: added: audio pulseaudio
habtey (habtey9) wrote :

I had the same problem here. Every video online fast forward. Even from XBMC . I have HP Pavilion DV7-4197CL NoteBook Intel Core i7 720QM (1.60GHz) 6GB Memory 1TB HDD ATI Mobility Radeon HD 5650 17.3" . My easy fix that work for me was, by creating new account. Easily done by going administration- user and group-add. Log out and that works like a charm. Peace

Changed in linuxmint:
assignee: Clement Lefebvre (clementlefebvre) → Divya Shettar (shettar-divya)
megha (megha-magi07) on 2015-11-20
Changed in linuxmint:
assignee: Divya Shettar (shettar-divya) → nobody
assignee: nobody → megha (megha-magi07)
assignee: megha (megha-magi07) → nobody
Changed in linuxmint:
assignee: nobody → Divya Shettar (shettar-divya)
Ciprian Tomoiaga (cipri.tom) wrote :

I also have this problem now. Here's how I debugged and solved it.

TL;DR: rm -rf ~/.config/pulse; reboot
----------------------------------------------------

I think it is related to some wrong configuration of PulseAudio. My system has always been working fine (from Mint 13 to Mint 17.2 which I am running now). Before the problem appeared I tried to get the sound to play through the HDMI cable, so I changed the Output Device to one of the 3 HDMI listed. It didn't work and then I restarted (to use Windows :( ). When I booted back in LM, I experienced the described problem: all audio is fast-forwarded and no sound can be heard (I tried youtube in Firefox and Chrome and Spotify).

I tried Audacious, with no success. Then in Audacious I went to Output > Audio Settings > Audio and changed the Output plug-in to ALSA Output. This only worked after I changed the Settings of ALSA Output to use pulse as a Mixer device. The default mixer device does not work, which indicates me that somehow the default setting was saved to be the NVidia HDMI (from my previous tinkering, I guess).

So I googled on how to reset the pulseaudio settings. I just removed the configuration folder (rm -rf ~/.config/pulse) and rebooted. All is fine now.

Ste (orochi-pocket) wrote :

Can you break it deliberately?

I'm suggesting you upload your working config/pulse file, break it as you did before, then upload the broken config/pulse file.

Symb932 (massdm) wrote :

I've noticed this issue even in a plain Debian Jessie install on my laptop. Sound doesn't works even as system alerts and so. Videos plays fast forward inside browsers (in sites youtube's like) and even on resident software as VLC. The same happens with LinuxMINT17.3 when loaded in 'compatible mode'. When MINT is loaded as 'normal mode' all works ok even sounds and videos. Some drivers/modules missed in plain Debian and MINT 'compatible mode'?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers