Installer fails on fakeraid / dmraid hardware

Bug #644742 reported by aknagi on 2010-09-21
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linux Mint
Low
Clement Lefebvre

Bug Description

Mint 9 / AMD64 / Gnome.

Issue 1
======
The installer can not complete installation of Mint 9 on fakeraid / dmraid system on AMD motherboard set to raid 1. After running through the installer right to the end the error given reports that partitioning failed, but no clear reason is given.

Issue 2 (Very Probably Related To Issue 1)
======
As another issue which is probably (but not proven to be) related, partitioning manually with gparted from the installer fails. To recreate this:

1) Run mint amd64 installer CD and boot into Gnome.
2) Don't use the installer yet, as partitioning will fail (maybe for the same reason?)
3) gksu gparted /dev/mapper/pdc_caafahgcei # <-- this is my fakeraid logical device.
4) make a partition and apply

Why Does it Fails
==============
The errors given by GParted clearly show the problem.
GParted expects first partition of /dev/pdc_caafahgcei to be called /dev/mapper/pdc_caafahgcei1, but "ls /dev/mapper/" shows that it is called /dev/mapper/pdc_caafahgceip1 (note the 'p' before the '1').

After discussing this with the author of dmraid, it seems that this is likely due the dmraid being called thus by the installer:
dmraid ... -Pp ...

Workaround To Both Issues
======================
Running "dmraid -tay -d -vvv" reloads dmraid, which makes new devices /dev/mapper/pdc_caafahgcei1, /dev/mapper/pdc_caafahgcei2 etc which gparted can then see. As a bonus, it is then possible to run the installer, which will now find the hard drives so it can install the OS.

I attach the details of my correspondence with the author of dmraid.

Thank you for you efforts,
Andrew Nagi

aknagi (andrew-nagi) wrote :
Thomas Jackowski (mint-bugs) wrote :

Hi,

I ran into the same bug in Mint 10. So it is still existent...

Bye, Thomas

Justin Krehel (jkrehel) wrote :

Thank you for the extremely detailed bug report! We appreciate the time you have taken and put into this report. I have milestoned this for the next upcoming release.

Thanks kindly for helping to improve Linux Mint, your time and efforts are greatly appreciated.

Cheers,

- Justin

Changed in linuxmint:
status: New → Confirmed
status: Confirmed → In Progress
assignee: nobody → Clement Lefebvre (clementlefebvre)
importance: Undecided → Low
milestone: none → katya-rc1
Don Fletcher (fotofletcher) wrote :

I just ran into this problem in the Linux Mint 11 RC.

My data drives are on a RAID 5 I was impressed that the LIVE CD was able to see them, but the installer was failing. I came across a forum post on ubuntu about nodmraid option at boot, and tried it, and the install went without a hitch.

I'm a little surprised that a bug of this nature has gone on this long.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers