LMDE fstab continuously wrong

Bug #636417 reported by Erick Brunzell on 2010-09-12
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Linux Mint
Fix Released
Medium
Ikey Doherty

Bug Description

I noticed this mentioned twice at the forums:

http://forums.linuxmint.com/viewtopic.php?f=143&t=54647&start=40

And I had the same thing happen, in all three case the "/" and Swap device designations and UUID's are identical:

# / was on /dev/sda1 during installation
UUID=39dce7bc-28c6-4d48-a3e1-b2d48712856e / ext3 errors=remount-ro 0 1
# swap was on /dev/sda5 during installation
UUID=f5355ad1-6de9-497b-a8d4-e2abe7336d4d none swap sw 0 0

The only reason mine booted at all post-install was because of this being generated at the bottom:

proc /proc proc nodev,noexec,nosuid 0 0
/dev/sda15 / ext4 rw,errors=remount-ro 0 0

This is my corrected fstab:

# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# / is on /dev/sda15
UUID=22eefad4-870e-4191-87c9-57f4e756411d / ext3 errors=remount-ro 0 1
# swap is on /dev/sda9
UUID=80627269-1ccd-4774-b4ea-a5ef8824ffaa none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto 0 0
#/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
#proc /proc proc nodev,noexec,nosuid 0 0
#/dev/sda15 / ext4 rw,errors=remount-ro 0 0

Ikey Doherty (ikey) wrote :

Erick Brunzell: Thanks for reporting this!
Apologies for your fstab issue, I've seen other reports of your bug on the LinuxMint blog
and forums. Clem should be able to fix this.
Marking this is a high priority as it affects installations badly.

Changed in linuxmint:
assignee: nobody → Clement Lefebvre (clementlefebvre)
importance: Undecided → High
status: New → Confirmed
Erick Brunzell (lbsolost) wrote :

I'd guess that LMDE is installing using Clem's original info (device id's and UUID's), but somehow creating that additional:

proc /proc proc nodev,noexec,nosuid 0 0
/dev/sda15 / ext4 rw,errors=remount-ro 0 0

So it does boot afterwards :^)

Of course SWAP doesn't mount, and this obviously needs to be fixed, but I love Mint and especially this new LMDE project and I'd be glad to do any testing requested ;^)

randomizer (randomizer) wrote :

My /etc/fstab had swap assigned to the same partition as /home, and yet I never specified swap anywhere. It didn't seem to cause any issues, and I corrected it when I noticed the problem.

Ikey Doherty (ikey) wrote :

I've actually just isolated the error. The /etc/fstab contained on the ISO filesystem
is "dirty", i.e. contains entries where it shouldnt. The fstab file should only contain
the header, i.e. the comments.

Clem will have to truncate the fstab in a future spin, the only possible fix right now
would be to make the installer completely overwrite the /etc/fstab file as opposed
to appending to it. This would still require however that the user updates the
live-installer package while on the livedvd. This is not a convenient fix.

Erick Brunzell (lbsolost) wrote :

Excellent. Upon seeing that my device designations and UUID's perfectly matched those in two threads on the forums I was sure you'd be able to locate the problem.

Do you think this is worthy of mention in the Announcements:
http://forums.linuxmint.com/viewforum.php?f=143&sid=93f47aaef2091a83aa5d7ecf5450fc3e

Whenever I encounter a problem with fstab I begin by running "sudo blkid -c /dev/null" (in a maximized Terminal for improved readability) to obtain the correct UUID's. Then correct the UUID's in both /etc/fstab and /etc/initramfs-tools/conf.d/resume, and then run "sudo update-initramfs -u".

And in this case I also had to comment out the lines at the bottom:
#proc /proc proc nodev,noexec,nosuid 0 0
#/dev/sda15 / ext4 rw,errors=remount-ro 0 0

I'm not that great at giving directions though, sometimes I even confuse myself :^(

I prefer using UUID's because I'm constantly mucking about removing and adding partitions so occasionally I end up with changed device designations, but for most users a simpler option might be commenting out the two faulty lines and just adding swap with a device designation in both /etc/fstab and /etc/initramfs-tools/conf.d/resume.

ghysmodos (ghysmodos) wrote :

@Ikey
Could you provide us a howto on how the user updates the fstab file in a live session? I have not enough knowledge to edit my fstab file, but if this could be fixed would just be great.

ghysmodos (ghysmodos) wrote :

Thanks to some hours of reading tons about fstab and how to edit, i've been able to fix it by myself.
This
http://www.tuxfiles.org/linuxhelp/fstab.html
helped me a lot, though I used UUID's as suggested elsewhere to be the better solution.

John Wardlaw (dr4dpet+reg) wrote :

I corrected the entry in my /etc/fstab following the instructions in this post
http://forums.linuxmint.com/viewtopic.php?f=141&t=54927&p=321249#p314699
Then did most of what Erick stated in post #5 above, but stopped short of commenting out the proc line because the file contained two and I wanted to ask which should be commented out. The two lines are
proc /proc proc defaults 0 0
proc /proc proc nodev,noexec,nosuid 0 0

I noted that in LM9 Gnome 32, the second proc line is what is present in that fstab. So, which if either must be commented out?

Just a quick reminder: THis still occurs with the new 201012 isos (only tested 64bit because I had other issues with the 32 bit one)

Andy C. (ndc) wrote :

Might this bug be related?
https://bugs.launchpad.net/linuxmint/+bug/705136
(installer writes wrong options to fstab for xfs partitions)

Ikey Doherty (ikey) wrote :

ghysmodos: Apologies for my absence. In answer to your request, I'm afraid there is no
way of fixing this bug on the live session, it has to be corrected in the installation.
@Andy: This bug is an ISO filesystem issue, not an installer issue, but thank you for
pointing the other bug out to me.

This will be fixed in a future release of LMDE.
I am dropping the severity of this bug as after some extensive investigation
I see that the only ill effect suffered is one of swap not being automatically
configured, however on a 240MB RAM machine I was still able to boot and
rectify the issue with ease and to no loss.

Changed in linuxmint:
assignee: Clement Lefebvre (clementlefebvre) → Ikey Doherty (ikey)
importance: High → Medium
milestone: none → lmde-upcoming
Changed in linuxmint:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers