install error by wubi in 9.0rc

Bug #576166 reported by panquanyi on 2010-05-06
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linux Mint
Fix Released
Medium
Clement Lefebvre

Bug Description

05-05 17:04 ERROR TaskList: Invalid tag data. Check len(d)=1, (ord(d) & 128)==128. Received->(
)
Traceback (most recent call last):
  File "\lib\wubi\backends\common\tasklist.py", line 197, in __call__
  File "\lib\wubi\backends\common\backend.py", line 378, in get_metalink
  File "\lib\wubi\backends\common\backend.py", line 244, in check_metalink
  File "\lib\wubi\backends\common\signature.py", line 42, in verify_gpg_signature
  File "\lib\openpgp\sap\api.py", line 1190, in verify_str
  File "\lib\openpgp\sap\list.py", line 712, in list_as_signed
  File "\lib\openpgp\sap\list.py", line 618, in list_pkts
  File "\lib\openpgp\sap\pkt\Packet.py", line 67, in __init__
  File "\lib\openpgp\sap\pkt\Packet.py", line 110, in fill
PGPFormatError: Invalid tag data. Check len(d)=1, (ord(d) & 128)==128. Received->(
)

Hi,

It looks like mint4win is trying to download the ISO from elsewhere (which it shouldn't) and it fails on checking the signature (which it should since they're dummy ones).

- Is this the i386 or amd64 ISO?
- Can you verify the MD5 of the ISO file?
- Can you boot the computer on the CD and perform an "integrity check"?

Changed in linuxmint:
status: New → Incomplete
assignee: nobody → Clement Lefebvre (clementlefebvre)
milestone: none → isadora-stable
importance: Undecided → Medium

Hello,
 thanks for your reply.
 the ISO file MD5 is correct.
 the mint4win is really trying to download the ISO from somewhere,
 so,I install it offline and succeed.
 the reason might be that mint4win fail to download the right file,so parse it wrongly.

  ------------------ 原始邮件 ------------------
  发件人: "Clement Lefebvre"<email address hidden>;
 发送时间: 2010年5月6日(星期四) 下午5:51
 收件人: "panquanyi"<email address hidden>;

 主题: [Bug 576166] Re: install error by wubi in 9.0rc

Hi,

It looks like mint4win is trying to download the ISO from elsewhere
(which it shouldn't) and it fails on checking the signature (which it
should since they're dummy ones).

- Is this the i386 or amd64 ISO?
- Can you verify the MD5 of the ISO file?
- Can you boot the computer on the CD and perform an "integrity check"?

** Changed in: linuxmint
       Status: New => Incomplete

** Changed in: linuxmint
     Assignee: (unassigned) => Clement Lefebvre (clementlefebvre)

** Changed in: linuxmint
    Milestone: None => isadora-stable

** Changed in: linuxmint
   Importance: Undecided => Medium

--
install error by wubi in 9.0rc
https://bugs.launchpad.net/bugs/576166
You received this bug notification because you are a direct subscriber
of the bug.

Status in The Linux Mint Distribution: Incomplete

Bug description:
05-05 17:04 ERROR TaskList: Invalid tag data. Check len(d)=1, (ord(d) & 128)==128. Received->(
)
Traceback (most recent call last):
  File "\lib\wubi\backends\common\tasklist.py", line 197, in __call__
  File "\lib\wubi\backends\common\backend.py", line 378, in get_metalink
  File "\lib\wubi\backends\common\backend.py", line 244, in check_metalink
  File "\lib\wubi\backends\common\signature.py", line 42, in verify_gpg_signature
  File "\lib\openpgp\sap\api.py", line 1190, in verify_str
  File "\lib\openpgp\sap\list.py", line 712, in list_as_signed
  File "\lib\openpgp\sap\list.py", line 618, in list_pkts
  File "\lib\openpgp\sap\pkt\Packet.py", line 67, in __init__
  File "\lib\openpgp\sap\pkt\Packet.py", line 110, in fill
PGPFormatError: Invalid tag data. Check len(d)=1, (ord(d) & 128)==128 Received->(
)

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/linuxmint/+bug/576166/+subscribe

panquanyi (panquanyi) wrote :

Sorry, can you say that again... if you disconnect Windows from the Internet then Mint4Win installs correctly? If you're connected to the Internet, then it tries to download the metalink and fails with the above error message? Is that statement right?

panquanyi (panquanyi) wrote :

yes,
I notice this phenomenon also in other ubuntu edition ,if I shutdown the internet connection, wubi will install ubuntu or linuxmint correctly,but if windows is online,the wubi installer try to download something which can not be download correctly due to different countries.I wonder why wubi will download something from internet ?why not install the system firstly,then after user's login ,then do update.

------------------ 原始邮件 ------------------
发件人: "Clement Lefebvre"<email address hidden>;
发送时间: 2010年5月9日(星期天) 晚上6:10
收件人: "panquanyi"<email address hidden>;

主题: [Bug 576166] Re: install error by wubi in 9.0rc

 Sorry, can you say that again... if you disconnect Windows from the
Internet then Mint4Win installs correctly? If you're connected to the
Internet, then it tries to download the metalink and fails with the
above error message? Is that statement right?

--
install error by wubi in 9.0rc
https://bugs.launchpad.net/bugs/576166
You received this bug notification because you are a direct subscriber
of the bug.

Status in The Linux Mint Distribution: Incomplete

Bug description:
05-05 17:04 ERROR TaskList: Invalid tag data. Check len(d)=1, (ord(d) & 128)==128. Received->(
)
Traceback (most recent call last):
  File "\lib\wubi\backends\common\tasklist.py", line 197, in __call__
  File "\lib\wubi\backends\common\backend.py", line 378, in get_metalink
  File "\lib\wubi\backends\common\backend.py", line 244, in check_metalink
  File "\lib\wubi\backends\common\signature.py", line 42, in verify_gpg_signature
  File "\lib\openpgp\sap\api.py", line 1190, in verify_str
  File "\lib\openpgp\sap\list.py", line 712, in list_as_signed
  File "\lib\openpgp\sap\list.py", line 618, in list_pkts
  File "\lib\openpgp\sap\pkt\Packet.py", line 67, in __init__
  File "\lib\openpgp\sap\pkt\Packet.py", line 110, in fill
PGPFormatError: Invalid tag data. Check len(d)=1, (ord(d) & 128)==128 Received->(
)

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/linuxmint/+bug/576166/+subscribe

Changed in linuxmint:
status: Incomplete → Confirmed

I think I found out what the problem was:

- The autorun file specifies the option --skipmd5check. This option skips the GPG check which is responsible for the error mentioned in this bug report.
- "Exploring the content of the CD" and launching mint4win.exe directly without this option can result in the error shown above.

Can you try to right click on the CD Rom drive and select "Install or run program". See if this works.

Confirmed, I can reproduce the fault by running mint4win.exe directly without the option --skipmd5check, workaround is to use the autorun or to run "mint4win.exe --skipmd5check".

This was fixed in Mint 9 stable.

Changed in linuxmint:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments