evince does not display EPS file

Bug #552990 reported by Wojciech Beldycki on 2010-04-01
50
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Evince
Unknown
Medium
Linux Mint
Invalid
Undecided
Unassigned
libspectre (Ubuntu)
Low
Unassigned

Bug Description

Mint 8 main.
Evince does not display encapsulated postscript files (.EPS) however when trying to preview the file for printing from within evince the content is displayed properly and can be printed to PDF or to the printer.
The same file can be viewed without any problem in Gimp after Gimp's conversion from postscript.
Evince version: 2.28.1
Gimp version: 2.6.7
Attached:
An example of the file in .eps: example.eps

Wojciech Beldycki (voytek) wrote :
Changed in linuxmint:
status: New → Triaged
Pedro Villavicencio (pedro) wrote :

I'm getting an error here:

undefined -21
undefined -21

** (evince:25346): WARNING **: Error rendering thumbnail
undefined -21
undefined -21
undefined -21
undefined -21

** (evince:25346): WARNING **: Error rendering thumbnail

Changed in evince (Ubuntu):
importance: Undecided → Low
madbiologist (me-again) wrote :

Getting the same error here with evince 2.30.0-0ubuntu1 and poppler 0.12.4-0ubuntu4.

Marking as confirmed.

Changed in evince (Ubuntu):
status: New → Confirmed

The bug is still here on ubuntu lucid beta 2

Victor Vargas (kamus) wrote :

This issue could be a regresion of this bug 24978

Victor Vargas (kamus) wrote :

This issue was sent to Gnome Developers, Thanks.

Changed in evince (Ubuntu):
status: Confirmed → Triaged
Changed in evince:
status: Unknown → New
Victor Vargas (kamus) wrote :

looks like this issue it's same as bug 479674 related to libspectre library and not evince package.

Changed in evince:
status: New → Invalid
Changed in linuxmint:
status: Triaged → Invalid
Victor Vargas (kamus) wrote :

According to upstream report this issue was fixed in git repositories.

affects: evince (Ubuntu) → libspectre (Ubuntu)
Victor Vargas (kamus) wrote :

You can track any news at https://bugs.freedesktop.org/show_bug.cgi?id=27830 , Thanks!

madbiologist (me-again) wrote :

This is fixed in Ubuntu 10.10 "Maverick Meerkat" alpha 2, updated to the latest Ubuntu packages.

Uname: Linux 2.6.35-6-generic i686
Packages: evince 2.30.3-1ubuntu2
                  poppler 0.14.1-0ubuntu1

Changed in libspectre (Ubuntu):
status: Triaged → Fix Released
sam tygier (samtygier) wrote :

just checked in maverick in testdrive.

https://bugs.launchpad.net/linuxmint/+bug/552990/+attachment/1260301/+files/example.eps does not render. it just waits, and evince shows a loading message.

my file https://bugs.launchpad.net/ubuntu/+source/evince/+bug/615939/+attachment/1483832/+files/out.eps renders properly (was broken in lucid)

Timmy Shih Jun Yee (shijun) wrote :

I also checked in Maverick, and example.eps loads fine in Evince.

Changed in evince:
importance: Unknown → Medium
status: Invalid → Unknown
Nicola (nicola-gatti90) wrote :

I'm running LinuxMint 15 Olivia XFCE with Evince 3.6.1-1ubuntu3 and ghostiscript 9.07~dfsg2-0ubuntu3.1
Evince is not able to open any eps file. When I launch it on terminal I get the following error message:

undefined -21
(evince:2919): EvinceDocument-CRITICAL **: ev_document_misc_pixbuf_from_surface: assertion `surface' failed

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.