karmic ppa function doesn't work properly in helena

Bug #484040 reported by Old Marcus on 2009-11-17
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Linux Mint
Fix Released
Low
Clement Lefebvre

Bug Description

When adding software sources with the Software Sources tool in Helena, you can add a ppa repository simply by entering:

ppa:example-repository

However, this doesn't work in Helena as it takes the name of the distrubution for the section of the repository it points to, so instead of:

http://ppa.launchpad.net/amsn-daily/ppa/ubuntu karmic main

you get:

http://ppa.launchpad.net/amsn-daily/ppa/ubuntu helena main

Of course, these repositories don't have a helena section, so when apt tried to find them, it can't.

I don't think that's a bug. Implicitly the tool should assume you're talking about the distribution you're using and not the underlying base. The shortcut you're using and the assumption that this should trigger a completion for Ubuntu should only be true when using Ubuntu.

You should add: http://ppa.launchpad.net/amsn-daily/ppa/ubuntu karmic main

If you use a shortcut and you don't define the components, then it's fair to say that the tool should use the default ones for our distribution, and these are "helena main".

Changed in linuxmint:
status: New → Invalid
Old Marcus (old-marc) wrote :

I see what you're saying, but I still think it counts as a bug, since it will not work properly for helena, and as more people find out about the shortuct, they will attempt to use it and find it doesn't work properly. Is there no way to hard wire it to point to karmic instead of helena?

I understand your point but that would be the same if we registered a bug on Ubuntu because clicking on a mint application in the software portal didn't trigger its installation. I think we'll agree to disagree on this one, I find the behaviour of the software properties tool coherent. That shortcut is Ubuntu-specific.

Clement, while I understand completely, on a more pragmatic level users are going to use the PPA shortcuts far, far more for Ubuntu than Linux Mint. The PPA shortcuts are extremely useful for newer users. Considering Linux Mint's emphasis on ease of use I feel you should maybe reconsider this decision.

Excellent work on the latest release by the way.

Martyn Ranyard (ranyardm) wrote :

I'd add my voice to this one, add-apt-repository also has this shortcoming. I too agree that something should be done about it.

The release page says "This is Linux Mint 8, codename Helena, based and compatible with Ubuntu 9.10 Karmic Koala and its repositories." This is becoming less and less true with every release, and if we can't fix this then at least for the next release we need a MintRepo tool that will add ppa's from the base ubuntu release as well as the base mint release (why there would be a separate build for any mint release is beyond me, if we're "maintaining compatibility" anyway)

Please clem, rethink this one, it's the first thing a lot of people do, add ppas, and first impressions count. I personally love helena btw, and I will cope, but I'm techie :-)

Ok, I'll see what I can do.

Changed in linuxmint:
status: Invalid → Confirmed
assignee: nobody → Clement Lefebvre (clementlefebvre)
importance: Undecided → Low

Fixed in version 0.75.4-1mint2.

Changed in linuxmint:
status: Confirmed → Fix Released
Old Marcus (old-marc) wrote :

Thanks clem, much appreciated. :-)

Martyn Ranyard (ranyardm) wrote :

Fantastic, thanks clem. Fix confirmed to work with add-apt-repository here :-)

Shaglok (shaglok) wrote :

Are you sure it is completely fixed?
When I try to add Chromium PPA (via sudo add-apt-repository ppa:chromium-daily
), I get this error:

  File "/usr/bin/add-apt-repository", line 28, in <module>
    sp = SoftwareProperties(options)
  File "/usr/lib/python2.6/dist-packages/softwareproperties/SoftwareProperties.py", line 90, in __init__
    self.reload_sourceslist()
  File "/usr/lib/python2.6/dist-packages/softwareproperties/SoftwareProperties.py", line 536, in reload_sourceslist
    self.distro.get_sources(self.sourceslist)
  File "/usr/lib/python2.6/dist-packages/aptsources/distro.py", line 90, in get_sources
    raise NoDistroTemplateException("Error: could not find a "
aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template

Philip Morrell (emorrp1) wrote :

Shaglok: as the page (https://launchpad.net/~chromium-daily/+archive/ppa) explains, the command is "sudo add-apt-repository ppa:chromium-daily/ppa". This is because a single "user" can now have multiple repos, and they don't have to be called "ppa", so the syntax is ppa:user/repo

Darkbook (darkbook4008) wrote :

$ sudo software-properties-gtk
Traceback (most recent call last):
  File "/usr/bin/software-properties-gtk", line 110, in <module>
    app = SoftwarePropertiesGtk(datadir=data_dir, options=options, file=file)
  File "/usr/lib/python2.6/dist-packages/softwareproperties/gtk/SoftwarePropertiesGtk.py", line 87, in __init__
    SoftwareProperties.__init__(self, options=options, datadir=datadir)
  File "/usr/lib/python2.6/dist-packages/softwareproperties/SoftwareProperties.py", line 90, in __init__
    self.reload_sourceslist()
  File "/usr/lib/python2.6/dist-packages/softwareproperties/SoftwareProperties.py", line 536, in reload_sourceslist
    self.distro.get_sources(self.sourceslist)
  File "/usr/lib/python2.6/dist-packages/aptsources/distro.py", line 90, in get_sources
    raise NoDistroTemplateException("Error: could not find a "
aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template

Darkbook (darkbook4008) wrote :

I have installed the version 0.75.4-1mint2 of python-software-properties and software-properties-gtk

Hi,

The template for Linux Mint comes as part of mintupdate, make sure it's installed. If it it isn't software-properties-gtk won't work (as you can see in the error message it complains about a missing distribution template).

The path for this template is:

/usr/share/python-apt/templates/LinuxMint.info

If you believe software-properties-gtk should run without the template or at least graphically complain about it missing, please file a bug on software-properties-gtk.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers