[mintInstall][kde] launched web browser (e.g. visit link) does not have system theme

Bug #427010 reported by Philip Morrell on 2009-09-09
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linux Mint
Low
Clement Lefebvre

Bug Description

to reproduce: Menu > Software Manager > Visit, observe that firefox is launched without proper theming and that the process's user is the correct one, not root. Note also that launching firefox normally works fine (including launching from the console)

Essentially this boils down to running this command, which also exhibits the same behaviour: kdesudo -u $USER firefox

Now this could well be a kdesudo bug (since gksudo in Mint Main works fine), or possibly mintInstall's use of it, or possibly the KDE CE's lack of system theming, I don't know, but if it's possible to fix within mintInstall, then we could push a simple update to the users.

Confirmed on Mint 7 Gloria KDE CE, with mintInstall 6.3.7.1
http://forums.linuxmint.com/viewtopic.php?f=130&t=32605

Chris DeAngelis (ccubedd) wrote :

The reason for this is that Software Manager is ran as Root, you are forced to enter a password when starting.

therefore any child processes will be launched as root.

I believe this is a bug, as it is not intended, nor recommended to launch firefox as root.

if there were weblinks in Gparted or Synaptic Package Manager they may exhibit the same behaviour.

Reproduce:

sudo libreoffice

open writer, and type in http://www.duckduckgo.com click it and it will try to launch firefox as root.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers