Aptitude losing larger strings on output

Bug #38889 reported by UbuPetr on 2006-04-09
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux Mint
Medium
Unassigned
aptitude
Fix Released
Unknown
aptitude (Ubuntu)
Medium
Unassigned

Bug Description

If we do this command "aptitude search '~i'" for list all installed packages, aptitude print this list to standard output.

Something like this:
ii mc-4.1.1-ubuntu This is Midnight Commander.
ii linux-image-2.6.16-ubuntu-generic-k8 This is a linux kernel.
ii screen-1.0 This is VT-100 terminal.

But if we redirect output to file "> file.txt" or piped "| less" or grepped "| grep linux-image" aptitude loose some strings!

Something like this:
ii mc-4.1.1-ubuntu This is Midnight Commander.
ii linux-image-2.6 This is a linux kernel.
ii screen-1.0 This is VT-100 terminal.

And now we do not know what exact version of linux-image is installed. Aptitude loosing only larger strings. Possible solution is use program "screen" in large window and list in screen history, but we can not still use pipe or grep.

PS: "dpkg --get-selections" working well and do not loosing larger strings and we can use pipe or grap also without problems. Is it possible fix aptitude and is this fix in planning?

Adam Niedling (krychek) wrote :

I'm using Intrepid now and the output of aptitude search '~i' looks like this:

i yelp - Help browser for GNOME 2
i zenity - Display graphical dialog boxes from shell
i zip - Archiver for .zip files
i zlib1g - compression library - runtime
i A zlib1g-dev - compression library - development

I tried to pipe it and it gave the same output.

Changed in aptitude:
status: New → Invalid
Philip Morrell (emorrp1) on 2009-07-18
Changed in linuxmint:
importance: Undecided → Medium
status: New → Confirmed
Philip Morrell (emorrp1) wrote :

This is still a problem in Jaunty (reported from Linux Mint Gloria, which is based on Jaunty). Steps to reproduce:

1) make the terminal more than the default 80 chars wide
2) compare the output of the following commands:
aptitude search firefox
aptitude search firefox | less
aptitude search firefox | grep trunk

Philip Morrell (emorrp1) on 2009-08-20
Changed in aptitude (Ubuntu):
status: Invalid → New
Boniek (boniek12p) wrote :

karmic confirmed

Changed in aptitude (Ubuntu):
status: New → Confirmed
summary: - Aptitude loosing larger strings on output
+ Aptitude losing larger strings on output
Changed in aptitude:
status: Unknown → New
chemicalfan (mike-lumsden) wrote :

Is this still a valid bug? Does it affect any of the currently supported released (Maya, Nadia, Petra)?

Changed in aptitude:
status: New → Confirmed
Changed in aptitude:
status: Confirmed → Fix Committed
Changed in aptitude:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.