Ethernet related issue in Linux Mint 18.x(and Lubuntu 16.04 and Peppermint 8)

Bug #1730043 reported by RJ on 2017-11-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux Mint
New
Undecided
Unassigned
Peppermint
Undecided
Unassigned

Bug Description

I am currently dual booting Linux Mint 18.2 XFCE (32bit) along with windows XP. I have a broadband connection over ethernet (using pppoe). I set it up in Mint by creating a new DSL connection and entering my username and password.

What happens:I cannot open certain websites in all the browsers that I have tried so far-opera, firefox, chromium and midori-while some websites keep loading for a long time and don't work well. Firefox often gets stuck at 'Performing a TLS handshake' while sometimes it fails to load the page and says 'connection timed out'. All the other browsers also behave in a similar way.
Moreover, running a speedtest using curl also fails with the error 'timed out'(see attached image).
Also, this issue does not occur in windows XP and in live sessions of Linux Mint 17.3 Xfce and Debian 9. The connection was set up in the same way in Mint 17.3 and Debian 9.1 as in Mint 18.1(as well as 18.2 and 18.0) but I have no issues connecting to any website in Mint 17.3 and Debian 9.1...
This issue also occurs in a live session of Mint 18.x Xfce. I have also tried booting a live image of Mint 18.1 Mate as well as Peppermint 8 with the same results.
Some of the websites which don't load well/at all include quora,microsoft,bleepingcomputer and vodafone.

What should happen: All websites should load well as they do in the above mentioned operating systems.

How often does this happen: Always (This has been going on since 30th May this year when I first installed mint 18; I did not report it that time as I thought it was just something wrong with my setup but after discussion with some members of Bleepingcomputer's Linux support forum as well as the official Mint support channel it seems like this might be an issue with Mint 18.x itself.)

Here are my specs:
System: Host: ABHAY1 Kernel: 4.4.0-53-generic i686 (32 bit gcc: 5.4.0)
           Desktop: Xfce 4.12.3 (Gtk 2.24.28) Distro: Linux Mint 18.1 Serena
Machine: System: Hewlett-Packard product: HP Compaq nx6110 (PC416AV) v: F.14
           Mobo: Hewlett-Packard model: 3088 v: KBC Version 39.2A
           Bios: Hewlett-Packard v: 68DTD Ver. F.14 date: 07/27/2006
CPU: Single core Intel Pentium M (-UP-) cache: 2048 KB
           flags: (nx pae sse sse2) bmips: 3192 speed: 1600 MHz (max)
Graphics: Card: Intel Mobile 915GM/GMS/910GML Express Graphics Controller
           bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1024x768@60.00hz
           GLX Renderer: Mesa DRI Intel 915GM x86/MMX/SSE2
           GLX Version: 1.4 Mesa 11.2.0 Direct Rendering: Yes
Audio: Card Intel 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller
           driver: snd_intel8x0 ports: 2100 2200 bus-ID: 00:1e.2
           Sound: Advanced Linux Sound Architecture v: k4.4.0-53-generic
Network: Card-1: Intel PRO/Wireless 2200BG [Calexico2] Network Connection
           driver: ipw2200 v: 1.2.2kmprq bus-ID: 02:04.0
           IF: wlp2s4 state: down mac: <filter>
           Card-2: Broadcom BCM4401-B0 100Base-TX
           driver: b44 v: 2.0 bus-ID: 02:0e.0
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives: HDD Total Size: 40.0GB (70.6% used)
           ID-1: /dev/sda model: TOSHIBA_MK4032GA size: 40.0GB
Partition: ID-1: / size: 11G used: 5.7G (56%) fs: ext4 dev: /dev/sda3
           ID-2: swap-1 size: 1.02GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 63.0C mobo: 49.0C
           Fan Speeds (in rpm): cpu: N/A
Info: Processes: 169 Uptime: 6 min Memory: 691.4/2005.9MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35

What have I tried: changing the DNS and using google dns,refreshing firefox, running firefox in safe mode, deleting the firefox profile and creating a new one, applying all updates, reinstalling the OS, downgrading to 18.1 followed by 18.0, installing newer kernels, disabling ipv6, disabling proxy(I don't recall using a proxy ever) with no success.

EDIT: Some other websites which keep loading forever are symantec, nokia and even distrowatch. Moreover, I can't even login to launchpad as the login/authentication screen keeps loading forever(when I click on the 'Yes, log me in' button, I am not redirected to launchpad) and finally fails with 'secure connection failed'(have a look at the second image).

EDIT 2 : Have tried a live session of lubuntu 16.04 LTS and this problem exists there as well.

Update: I have tried booting into a live session of Mint 18.3 Mate(Beta) and this issue affects it too.

Update #2: Tried Mint 18.3 xfce...Same problem again.

Thanks!
RJ

RJ (mintuserrj) wrote :
RJ (mintuserrj) on 2017-11-04
description: updated
RJ (mintuserrj) wrote :
RJ (mintuserrj) on 2017-11-07
description: updated
tags: added: mint
RJ (mintuserrj) on 2017-11-07
summary: - Ethernet related issue in Linux Mint 18.x
+ Ethernet related issue in Linux Mint 18.x and Peppermint 8
RJ (mintuserrj) on 2017-11-07
summary: - Ethernet related issue in Linux Mint 18.x and Peppermint 8
+ Ethernet related issue in Linux Mint 18.x
RJ (mintuserrj) on 2017-11-07
description: updated
summary: - Ethernet related issue in Linux Mint 18.x
+ Ethernet related issue in Linux Mint 18.x(and Lubuntu 16.04 and
+ Peppermint 8)
RJ (mintuserrj) on 2017-11-11
description: updated
RJ (mintuserrj) on 2017-11-15
tags: added: latest
removed: mint
tags: added: mint
removed: latest
description: updated
RJ (mintuserrj) wrote :
RJ (mintuserrj) wrote :
RJ (mintuserrj) wrote :
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers