ifdown unknown interface net-tools is broken

Bug #1674137 reported by Roger Lawhorn
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux Mint
New
Undecided
Unassigned
net-tools (Ubuntu)
New
Undecided
Unassigned

Bug Description

System: Host: GT70-2PE Kernel: 4.5.4-040504-generic x86_64 (64 bit gcc: 5.3.1)
           Desktop: Cinnamon 3.2.7 (Gtk 3.18.9) Distro: Linux Mint 18.1 Serena
Network: Card-1: Qualcomm Atheros Killer E220x Gigabit Ethernet Controller
           driver: alx port: d000 bus-ID: 03:00.0
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full
           Card-2: Qualcomm Atheros AR9462 Wireless Network Adapter driver: ath9k bus-ID: 04:00.0
           IF: wlp4s0 state: up

After mint 18.1 upgrade had various issues.
After quite a few updates I started having issues with ifdown command.

I use a script with qemu to setup a bridge (br0) with tap0 and the default wired connection enp3s0. The script began giving off unknown interface errors.
Testing showed that the ifdown command changed behavior after the updates and now does this.
The behavior is not limited to scripting.
I changed the code from using ifdown to ifconfig enp3s0 down.
This fails also within the script but with no error.
It, however, works from a terminal just fine.
I switched to using the ip command i.e. ip link set enp3s0 down.
Same result, the interface does not go down, but no error.
After the script is run and windows 7 boots in qemu I have to open a terminal and run the commands manually:
>ifconfig enp3s0 down
>ifconfig enp3s0 0.0.0.0 promisc up

Then all is well.
These commands will not run from within a script.
The script is run as such:
>sudo ./up.sh tap0

It creates br0 and tap0 and adds enp3s0 and tap0 to the bridge.

The fact that ifdown no longer recognizes any interfaces seems to point to a change in net-tools that has broken something.

Roger Lawhorn (rll-m)
description: updated
summary: - ifdown unknown interface
+ ifdown unknown interface net-tools is broken
Revision history for this message
Roger Lawhorn (rll-m) wrote :

UPDATE:
To reverify, ifdown command fails always. net-tools is broken after the update.

I have done extensive testing on my scripts adding Y/N questions to verify that each command succeeded. They do.
Therefore, the ip and ifconfig commands do succeed inside of scripts (but not ifdown). I was incorrect about that.

What really happens:
At the point where the bridge is made and tap0 and enp3s0 are added to it the ipaddr of enp3s0 goes from 0.0.0.0 back to 192.168.1.130 thus breaking the bridge.
Both tap0 and enp3s0 must be 0.0.0.0. promiscuous mode, and up inside the bridge br0 to work properly.

I am digging deeper on why this happens.
As a temp fix I reset enp3s0 to the correct settings a 2nd time after the bridge is made.

Also, after the bridge is removed enp3s0 never performs dhcp to regain its original ipaddr.
That is also an issue.

Revision history for this message
Roger Lawhorn (rll-m) wrote :

UPDATE:
Rewrote my scripts to set enp3s0 AFTER the bridge creation and deletion.
Issue with that part over.

ifdown still broken.
Unknown if script issue is related, but those scripts worked fine before the updates.
Perhaps more than one update changed how things work.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers