LM-18-kde-64bit: ERIC (Python-IDE) not installable

Bug #1656433 reported by GM on 2017-01-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux Mint
Fix Released
Undecided
Unassigned

Bug Description

VERSION:
Linux Mint 18 "Sarah" - KDE (64-bit)

PROBLEM:
Python-IDE "eric" can not be installed:

...
The following packages have unmet dependencies:
 eric : Depends: python3-pyqt5.qsci but it is not going to be installed
... (full output: see below)

repairing (Synaptics): no success
apt install -f : no errors, no success
aptitude install eric: no success

The problem exists ONLY in "Mint 18 KDE". Eric is installs without problems on Ubuntu 16.04, Kubuntu 16.04 and "Mint 18 Cinnamon". (Tested on fresh installed virtual machines)

how to reproduce: make a fresh install, run "apt update && apt dist-upgrade", run "apt install eric"

------------------------
apt install eric
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 eric : Depends: python3-pyqt5.qsci but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

------------------------
apt-cache policy eric
eric:
  Installed: (none)
  Candidate: 6.0.8-1
  Version table:
     6.0.8-1 500
        500 http://gd.tuwien.ac.at/opsys/linux/ubuntu/archive xenial/universe amd64 Packages
        500 http://gd.tuwien.ac.at/opsys/linux/ubuntu/archive xenial/universe i386 Packages

------------------------
apt-cache policy python3-pyqt5.qsci
python3-pyqt5.qsci:
  Installed: (none)
  Candidate: 2.9.1+dfsg-4build1
  Version table:
     2.9.1+dfsg-4build1 500
        500 http://gd.tuwien.ac.at/opsys/linux/ubuntu/archive xenial/universe amd64 Packages

------------------------

GM (gogo555) wrote :

I think this is the tree of dependencies that makes the problem:

-----------------------------------
pc051 ~ $ aptitude why-not python3-pyqt5.qsci
Unable to find a reason to remove python3-pyqt5.qsci.

pc051 ~ $ aptitude why-not libqt5scintilla2-12v5
i libqt5core5a Breaks libqt5scintilla2-12v5 (< 2.9.2+dfsg-2~)

pc051 ~ $ aptitude why libqt5core5a
i plasma-integration Depends libqt5core5a (>= 5.6.0~beta)
-----------------------------------

GM (gogo555) wrote :

bug persists in Linux Mint 18.1 “Serena” KDE

Þór Sigurðsson (the.thor) wrote :

Verified that this bug affects Mint 18.1 "Serena" KDE.

This bug ALSO affects sqlitebrowser.

The following packages have unmet dependencies:
 libqt5core5a : Breaks: libqt5scintilla2-12v5 (< 2.9.2+dfsg-2~) but 2.9.1+dfsg-4build1 is to be installed.

GM (gogo555) wrote :

now ... this bug affects KDE-neon too (which was not the case in a virtual-machine installation ~ one month ago)

slowly I'm running low on KDE-operating systems where eric can be installed...

GHPS (ghps) wrote :

I had the same problem with OpenSCAD and Kubuntu 16.04 LTS. The upgrade to Qt 5.6.1 deleted libqt5scintilla2-12v5 (2.9.1) since it broke Qt5.6 - and removed OpenSCAD with it.

I solved the problem with newer versions of libqt5scintilla2-12v5 and libqt5scintilla2-l10n (2.9.3). Since they haven't come upon us the official way, we have to download them directly [1]. After download install both packages with

sudo dpkg --install libqt5scintilla2-12v5_2.9.3+dfsg-3_amd64.deb libqt5scintilla2-l10n_2.9.3+dfsg-3_all.deb

With libqt5scintilla2 present OpenSCAD works fine - and chances are good that Eric will too.

GHPS

[1]: https://www.ubuntuupdates.org/package/core/yakkety/universe/base/libqt5scintilla2-12v5
https://www.ubuntuupdates.org/package/core/yakkety/universe/base/libqt5scintilla2-l10n

GM (gogo555) wrote :

thx a lot GHPS! - problem is resolved.
after upgrading libqt5scintilla2-l10n and libqt5scintilla2-12v5 the distro's version of 'eric' installed without problems. The latest release of 'eric' (17.03) installed without problems too.

I'll inform the developers of 'eric' to add this information on their homepage.

GHPS (ghps) wrote :

> after upgrading libqt5scintilla2-l10n and libqt5scintilla2-12v5 the distro's
> version of 'eric' installed without problems.

Great - then we can close this bug report.

Just for the record: The following programs depend on libqt5scintilla2 and a probably
affected by the problem described above:
- Eric (Python IDE)
- OpenSCAD
- Sonic-PI
- SQlitebrowser
- parts of the PyQt5 bindings

Changed in linuxmint:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers