[18.1 CINNAMON] Black screen; desktop never appears when logging in

Bug #1653160 reported by firesteelbug on 2016-12-29
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Linux Mint
Undecided
Unassigned

Bug Description

This report regards Mint 18.1 Cinnamon, 64-bit edition. The laptop is a Lenovo M30-70 with an Intel i5-4210U and Intel IGP (HD4400 I believe).

When trying to log in, after the username/pw dialog has disappeared, a fresh installation of Cinnamon refuses to load the desktop environment. Instead the computer gets stuck at a black screen with only the mouse pointer visible. CPU usage goes very high (and drive usage, too, it seems), and nothing happens for minutes until sometimes the desktop background picture shows up.

It seems as if Cinnamon gets stuck in some CPU-intensive deadlock that freezes the machine and never wants to finish loading the desktop environment. From about 30 restarts across 3-4 fresh installations I only managed to reach the desktop *once*, unless I boot in compatibility mode with full snail-like software rendering. The installation disc however always runs perfectly fine every single boot, in perfect GPU acceleration without compatibility mode.

summary: - [18.1 CINNAMON] Desktop refuses to appear after login
+ [18.1 CINNAMON] Black screen; desktop never appears when logging in
Wolfgang (wolfgang16) on 2017-01-02
Changed in linuxmint:
status: New → Confirmed
Wolfgang (wolfgang16) wrote :

This bug can be reproduced on a Intel NUC D34010WYK with an i3-4010U CPU (integrated HD4400)

I could not find any working kernel, at least the following ones do NOT work:

4.4.0-57
4.4.0-53
4.4.0-21
4.8.0-32

When the black screen appears, you can press ctrl+alt+F1 to get a command line. There you can login with you username and password. I did this and had linux running. After one minute or so it said that the cinnamon process is out of memory and was killed.

Output from "systemctl status" shows (among other) 0 units failed.

Wolfgang (wolfgang16) wrote :

To clarify my comment above:
After command-line login, linux runs ONLY with a command line, Cinnamon desktop does NEVER appear!

Wolfgang (wolfgang16) wrote :

Found something in syslog:

Dec 31 16:56:42 hilmar-desktop kernel: [ 222.330691] Out of memory: Kill process 1903 (cinnamon) score 926 or sacrifice child
Dec 31 16:56:42 hilmar-desktop kernel: [ 222.332600] Killed process 1903 (cinnamon) total-vm:8799916kB, anon-rss:3581228kB, file-rss:0kB, shmem-rss:0kB

NeV3rKilL (nev3rkill) wrote :

I Can confirm the bug. I did a fresh installation, eveything worked well. I updated the system (kernel included) and I got the black screen with the pointer.

I do have the option to autologin. If I open a tty (F1) and type startx sometimes works, sometimes not. I can kill Xorg from another tty and trying to launch with startx since eventually works. (ussually no more than 3 trys).

I installed the mate metapackage and now i´m autologin to mate without problems.

Xorg log seemed without errors.

Laptop is a Acer Aspire intel i3 with intel's integrated card.

NeV3rKilL (nev3rkill) wrote :

I forgot, mint did something weird with the permisions of gconf folder from the $HOME, and root was the owned instead of $USER.

I chown the folder and all the files inside it, didn't solve the issue.

Jarkko Korpi (jarkko-korpi-t) wrote :

I have the same issue with mint 18.1 KDE. Everything works, if I don't upgrade 4.4.66-87 kernel. If I do it hangs at desktop, no input from keyboard or mouse.

All kernels I have tried dont work, only the default one. Also grub menu is garbled. If I add nomodeset on the default kernel it hangs too with black screen.

David Love (dlove118) wrote :

I am having the same issue intermittently with Mint 18.1 Cinnamon on a Lenovo T500. I can log into the terminal and reboot but cannot get cinnamon to reactivate unless i force a reboot.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers