xfce - screen turns black after power off/power on

Bug #1615286 reported by Dhakir
50
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Linux Mint
New
Undecided
Unassigned
Xfce4 Settings
New
Undecided
Unassigned
xfce4-settings (Ubuntu)
Fix Released
Undecided
Unassigned
Xenial
Confirmed
Undecided
Unassigned
Bionic
Fix Released
Undecided
Unassigned

Bug Description

Just installed Linux Mint 18 with XFCE (reformatted the partition, but recopied some files from ~/.config); previously using Linux Mint 17 with KDE and no related issues. I am using mdm. I have an i3 with Intel HD Graphics 4400, and a standard LCD monitor connected via HDMI to my desktop PC.

If I turn my display off, due to any of the following:

- Configuring "Blank after X minutes" in Power Manager and waiting for X minutes;
- Physically pressing the "power off" button on my monitor;
- Suspending and then resuming my session;

Then, when turning the screen back on, it does not work anymore: everything is black, and after a few seconds the monitor reports "no signal".

Keyboard and mouse still work, I can toggle the Num lock light on the keyboard, for instance, and switch via Ctrl+Alt+F1 to a terminal. If I do so and run "xrand -d :0.0 --auto" (as recommended in one forum for an user having similar issues), I get "xrandr: Configure crtc 0 failed". If I try the exact same command before turning the screen off (also using a Ctrl+Alt+F1 terminal, for instance), I get no message, but because the screen is already on, nothing happens.

I tried looking at dmesg and /var/log/syslog to find relevant error messages, but nothing seems immediate to me. I can try using other display managers or anything else that can help debug the issue.

Tags: display
Revision history for this message
Michael Coote (cootemj) wrote :

I"m running xfce through Xubuntu 16.04 and this same problem starting showing up for me about a month ago. My display is a tv connected through hdmi. When I log in using a Unity desktop, rather than xfce/xubuntu, I don't have this problem.

Revision history for this message
Dhakir (dhakir) wrote :

"Using a Unity desktop", you mean, with a different display manager?

I installed Xubuntu 16.04 on my laptop and there I had an issue with xflocker and mouse pointer disappearing (already reported by someone), so they suggested changing the display manager. I installed gdm and use it instead, and the problem was solved. So I tried installing gdm in my Linux Mint and setting it as default, but then on reboot I did not have a graphical session anymore. I then tried installing lightdm, and once again, some weird error and I couldn't login. startx still worked though, so I found out about mdm, which for some reason was not installed (though I thought it was being used), so installed it, then ran mdmsetup, configured the most basic GTK login window, and was finally able to boot with a graphical environment by default. I didn't report it as a bug because it's hard to reproduce. So I'm a bit afraid of trying it again, but I will do it nevertheless.

Revision history for this message
Dhakir (dhakir) wrote :

I did several further tests, but unfortunately I won't be able to continue (I have to use my computer, so I'll need to install a new distro). I hope this information will nevertheless be useful for Linux Mint developers.

- After installing lightdm (apt install lightdm) and switching to it as default dm, I tried rebooting but there were some error messages on boot: "Failed to start Light Display Manager".

/var/log/lightdm/lightdm.log conained mentions to "Failed to find session configuration default". Googling about it led me to some AskUbuntu answers suggesting changes in /etc/lightdm/lightdm.conf. Such file did not exist, and only an empty /etc/lightdm/lightdm.conf.d existed. I tried "apt install lightdm-gtk-greeter", and after that I rebooted. I was then able to actually see something resembling LightDM's login screen, though it still gave an X error after trying to login. Apparently it was related to an already existing X session.

Then I tried once again installing gdm (apt install gdm) and setting "gdm3" as default desktop manager. After rebooting, it got in some sort of loop (screen refreshing several times) but never actually got to the login screen. I then uninstalled gdm, forced a reinstall of mdm, and booted again. I was back to the mdm login screen, but after trying to login, I only had a black screen.

Having completely botched my Linux Mint, I decided to try a fresh Xubuntu 16.04.1 install. I still had the display off issue, so I tried again installing gdm, and this time it worked better. Still had an error message but otherwise I could use Xfce fine.

I then noticed that even on Xubuntu's live CD, the display problem was present. So I installed a Debian 8 XFCE live CD this time, and now I can finally turn off my monitor and turn it back again, without issue. I'll probably have other issues, but at least there exists one working configuration for XFCE where I can turn back on my monitor.

SUMMARY OF MY FINDINGS:

- The display off/on issue is NOT related to Linux Mint or mdm at all, since it also happens in Xubuntu;

- However, there are some serious stability issues related to installing other desktop managers in Linux Mint, probably due to mdm, since they were not present in Xubuntu 16.04. For instance, I don't know why it is possible to install lightdm and configure it without having any greeters, which seems to be somewhat useless since LightDM always fails in that case (and then mdm seems to take over and still give a graphical desktop). But the most troubling issue is that installing gdm leads to some reboot loops and a worse configuration than doing it on a Xubuntu.

- The display bug must be Ubuntu-specific, or Debian somehow managed to fix it since. Because I don't have more time to test other things, I'm moving to Debian for now. However, since the issue is visible even on a live CD (Xubuntu or Linux Mint), I could quickly test other versions to see if it is present, and gather debug logs, if that would be useful.

Revision history for this message
aar pawl (apawl) wrote :

I have the same problem with Linux Mint 18 XFCE. I just built a new HTPC and basically whenever I turn off the TV and turn the TV back on, the desktop will not return. However, I can bring up a tty. To get the desktop back I need to shh in and either restart mdm or use xrandr to reset the display mode. I could not get this to work so installed Linux Mint 18 MATE. Everything works fine with MATE.

The same display issue occurs when running LM 18 XFCE straight off of the install USB, so it's not some setting I changed.

My saga has been detailed here: https://forums.linuxmint.com/viewtopic.php?f=57&t=235376

Revision history for this message
Bela Lubkin (filbo) wrote :
Download full text (4.5 KiB)

I'm having the same problem on Xubuntu 16.04 with lightdm & xfce4.

Video board is "NVIDIA Corporation GK107 [NVS 510] [10de:0ffd] [10de:0967]", with 3 monitors connected via DisplayPort.

The monitors are on a single power strip. When I leave for the day I lock the X session (ctrl-alt-L), then turn off the power strip.

Next day I noticed that X has tried to dump core about 400,000 times (seen in /var/log/apport). /var/log/Xorg.1.log.old ends with:

[942209.134] (EE) NVIDIA(0): Failed to assign any connected display devices to X screen 0.
[942209.134] (EE) NVIDIA(0): Set AllowEmptyInitialConfiguration if you want the server
[942209.134] (EE) NVIDIA(0): to start anyway
[942209.135] (EE) NVIDIA(0): Failing initialization of X screen 0
[942209.136] (EE) Screen(s) found, but none have a usable configuration.
[942209.136] (EE)
Fatal server error:
[942209.136] (EE) no screens found(EE)

/var/log/Xorg.1.log is normal -- it represents the 400001st attempt, which succeeded because I had turned the screens back on.

So I created /usr/share/X11/xorg.conf.d/10-nvidia-no-monitor.conf with:

Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    Option "AllowEmptyInitialConfiguration" "True"
EndSection

and Xorg :1 no longer dumps core -- now it just comes up blank. :(

So now I can power my screens back on, flip to ctrl-alt-F1, login on the text screen, kill the dysfunctional :1 server, a new one starts up successfully, then I can unlock and return to my :0 session. Is this an improvement? Maybe -- I don't like the idea of the system churning along trying to dump core 5 times a second, all night or weekend long...

But wait, how does this relate?

Well, if I *don't* lock, just turn the monitors off, then my Xorg :0 session hangs. Turning the monitors back on, they're just black; after a few seconds they flash "entering power-save mode".

/var/log/Xorg.0 shows that before power-off, each of the monitors was "connected", like:

[942221.128] (--) NVIDIA(GPU-0): DELL P2715Q (DFP-4): connected
[942221.128] (--) NVIDIA(GPU-0): DELL P2715Q (DFP-4): Internal DisplayPort
[942221.128] (--) NVIDIA(GPU-0): DELL P2715Q (DFP-4): 960.0 MHz maximum pixel clock

When I power them off, this becomes:

[946263.004] (--) NVIDIA(GPU-0): DFP-4: disconnected
[946263.004] (--) NVIDIA(GPU-0): DFP-4: Internal DisplayPort
[946263.004] (--) NVIDIA(GPU-0): DFP-4: 960.0 MHz maximum pixel clock

-- repeated several times over about 1/4 second; then:

[946263.279] (II) NVIDIA(0): Setting mode "NULL"
[946263.408] (II) NVIDIA(0): Setting mode "NULL"

(which I think represents what it's done to 2 of the 3 monitors); then, after I power them back on,

[946313.566] (--) NVIDIA(GPU-0): DELL P2715Q (DFP-4): connected
[946313.566] (--) NVIDIA(GPU-0): DELL P2715Q (DFP-4): Internal DisplayPort
[946313.566] (--) NVIDIA(GPU-0): DELL P2715Q (DFP-4): 960.0 MHz maximum pixel clock
[946313.566] (--) NVIDIA(GPU-0):
[946313.566] (--) NVIDIA(GPU-0): DFP-5: disconnected
[946313.566] (--) NVIDIA(GPU-0): DFP-5: Internal DisplayPort
[946313.566] (--) NVIDIA(GPU-0): DFP-5: 960.0 MHz maximum pixel clock
[946313.566] (--) NVIDIA(GPU-...

Read more...

Revision history for this message
Toan (tpham3783) wrote :

I recently upgraded my monitor to 2K and this issue started to show up. With my old 1080p monitor using VGA input (as oppose to DP with the new monitor) this issue never showed up. Hopefully, someone would be able to figure this problem out because I really do not want to go back to gnome-desktop over something stupid like this!

thanks,

TP

Revision history for this message
Toan (tpham3783) wrote :

I just want to inform everyone that this bug is fixed in xfce4-settings version 4.12.1

If you download the new xfsettingsd executable and then extract to /usr/bin, it should resolve this issue.

** I actually compiled the package xfce4-settings-4.12.1 because I could not find the executable anywhere.

good luck

Revision history for this message
Toan (tpham3783) wrote :

For those who are cannot compile the code, you can download the executable here:

https://toanpham.com/xfsettingsd

then extract it to /usr/bin

You may have to logout then log back in or reboot your PC for the fix to work!

Revision history for this message
Francis Thérien (frtherien) wrote :

I am also experiencing this bug on a fresh Sylvia install, pc connected to a tv via HDMI. Power cycling the TV, or even switching the input (eg to my Chromecast) and coming back to the PC input, would result in no input.

Following @Toan's comments, I have installed the xfce4-settings .deb package downloaded from Ubuntu Artful repo, currently at 4.12.1, and that appears to fix the issue.

https://packages.ubuntu.com/artful/xfce4-settings

Hopefully this version will get updated in Xenial/Syvia.

TJ (tj)
Changed in xfce4-settings (Ubuntu):
status: New → Confirmed
Revision history for this message
Tom Reynolds (tomreyn) wrote :

This also affects my XUbuntu 16.04.5 x86_64 system. When waking the monitor from sleep, all I get is a blank screen. Switching between TTYs does not help to restore the session or graphical output, only restarting the desktop manager helps (but this means loosing the session).

I have since installed artful's xfce4-settings (I'm aware it's EOL), and this improves the situation a lot for me. When I now wake the monitor from sleep, I get a stuck mouse pointer on an otherwise all black screen when I should get to see the login prompt. However, switching to TTY1 and back to TTY7 will bring up the gdm3 (the desktop manager I have chosen to use) login prompt, and logging in there brings me back to my previous Xubuntu session, which I can then continue.

TJ (tj)
Changed in xfce4-settings (Ubuntu):
assignee: nobody → TJ (tj)
Sean Davis (bluesabre)
Changed in xfce4-settings (Ubuntu Bionic):
status: New → Fix Released
TJ (tj)
Changed in xfce4-settings (Ubuntu):
assignee: TJ (tj) → nobody
Changed in xfce4-settings (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfce4-settings (Ubuntu Xenial):
status: New → Confirmed
Revision history for this message
Ben Fenner (benfenner) wrote :

I've just started experiencing this bug.
I'm on Linux Mint 20.1 and anything that turns the monitor off now (something I have been doing often for months with power saving and manually turning it off myself) will cause the monitor to never get video signal from the video card again until a reboot is performed.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers