Realtek RTL8723BE Bluetooth driver

Bug #1542426 reported by mtsec on 2016-02-05
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linux Mint
Fix Released
Undecided
Unassigned

Bug Description

Device: Realtek RTL8723BE

1) Linux Mint 17.3, kernel 3.19.0-32-generic
2) The Bluetooth tray applet seems working, and so is Blueman, but when scanning for devices, no devices can be found, neither can the Mint machine itself be found by other devices.
3) The Bluetooth functionality can't seem to scan for other devices.
4) The ability to pair devices over Bluetooth, either audio, data transfer or images/video.
5) The problem always occurs.

Extra info:

The proposed solution in the article below didn't work at my machine (both the GIT-make and the PPA solution).
https://askubuntu.com/questions/607339/rtl8723be-bluetooth-does-not-work
https://sites.google.com/site/easylinuxtipsproject/reserve-7

The Realtek RTL8723BE Wifi driver is present in Linux Mint 17.3, but is buggy. There is a fix though:
echo "options rtl8723be fwlps=N ips=N" | sudo tee /etc/modprobe.d/rtl8723be.conf

When fixing the Bluetooth driver, please fix this Wifi driver issue as well.

Thank you!

mtsec (j-mint) wrote :
Download full text (3.7 KiB)

Extra info: lspci -nnk | grep -iA2 net; lsusb; rfkill list all; uname -a; dmesg | egrep -i 'blue|firm'

01:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
 Subsystem: Realtek Semiconductor Co., Ltd. Device [10ec:8739]
 Kernel driver in use: rtl8723be
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 1bcf:2b8f Sunplus Innovation Technology Inc.
Bus 001 Device 005: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 004: ID 0bda:b739 Realtek Semiconductor Corp.
Bus 001 Device 002: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
1: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: no
4: hci0: Bluetooth
 Soft blocked: no
 Hard blocked: no
Linux Inspiron-15-3552 3.19.0-32-generic #37~14.04.1-Ubuntu SMP Thu Oct 22 09:41:40 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
[ 0.163222] [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored
[ 2.526796] usb 1-2.1: Product: Bluetooth Radio
[ 4.773898] Bluetooth: Core ver 2.20
[ 4.773993] Bluetooth: HCI device and connection manager initialized
[ 4.774006] Bluetooth: HCI socket layer initialized
[ 4.774148] Bluetooth: L2CAP socket layer initialized
[ 4.774163] Bluetooth: SCO socket layer initialized
[ 5.508781] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 5.508788] Bluetooth: BNEP filters: protocol multicast
[ 5.508799] Bluetooth: BNEP socket layer initialized
[ 5.546559] Bluetooth: RFCOMM TTY layer initialized
[ 5.546576] Bluetooth: RFCOMM socket layer initialized
[ 5.546589] Bluetooth: RFCOMM ver 1.11
[ 5.617977] Using firmware rtlwifi/rtl8723befw.bin
[ 5.903074] Modules linked in: snd_hda_intel dell_laptop snd_hda_controller dcdbas i8k intel_rapl intel_powerclamp arc4 snd_hda_codec snd_hwdep coretemp rtl8723be(OE) rfcomm btcoexist(OE) bnep kvm_intel rtl_pci(OE) rtlwifi(OE) snd_pcm kvm crct10dif_pclmul crc32_pclmul ghash_clmulni_intel mac80211 cfg80211 dm_multipath scsi_dh aesni_intel uvcvideo snd_seq_midi videobuf2_vmalloc videobuf2_memops aes_x86_64 binfmt_misc lrw gf128mul glue_helper ablk_helper snd_seq_midi_event cryptd videobuf2_core v4l2_common videodev media rtsx_usb_ms memstick snd_rawmidi nls_iso8859_1 joydev serio_raw btusb(OE) bluetooth snd_seq snd_seq_device shpchp lpc_ich snd_timer snd i915_bpo pinctrl_cherryview i2c_designware_platform intel_ips i2c_designware_core mei_txe dell_rbtn drm_kms_helper soundcore mei drm iosf_mbi i2c_algo_bit mac_hid parport_pc ppdev lp parport dm_mirror dm_region_hash dm_log rtsx_usb_sdmmc rtsx_usb psmouse wmi video ahci sdhci_acpi sdhci libahci
[ 1405.095542] Modules linked in: ctr ccm dell_wmi sparse_keymap snd_hda_codec_hdmi dell_led snd_hda_codec_realtek snd_hda_codec_generic snd_hda_intel dell_laptop snd_hda_controller dcdbas i8k intel_rapl intel_powerclamp arc4 snd_hda_codec snd_hwdep coretemp rtl8723be(OE) rfcomm btcoexist(OE) bnep kvm_intel rtl_pci(OE) rtlwifi(OE) snd_pcm kvm crct10dif_pclmul crc32_pclmul ghash_clmulni_intel mac80211 cfg80211 dm_multipath scsi_dh aesni_intel uvcvideo snd_seq_midi videobuf2_vma...

Read more...

mtsec (j-mint) wrote :

This issue is fixed with Linux Mint 18.

Changed in linuxmint:
status: New → Fix Released
Roonaldo_7 (rajesh1986) wrote :

The problem is still persistent in linux mint 18

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1616535

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers