External mic not being used in combo port

Bug #1359803 reported by Mohammed Irfan on 2014-08-21
78
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Linux Mint
Medium
Unassigned

Bug Description

I'm using Ubuntu 14.04 on my Asus 1015E that only has a combo audio port which accepts smartphone type "headsets" (3.5mm TRRS headphones with mic on the same wire).

Ubuntu does not deactivate the built-in mic when I connect my headset. It doesn't even use the headset mic and instead keeps picking up audio signal from the integrated microphone (that's on my laptop bezel).

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: linux-image-3.13.0-32-generic 3.13.0-32.57
ProcVersionSignature: Ubuntu 3.13.0-32.57-generic 3.13.11.4
Uname: Linux 3.13.0-32-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.3
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: power-inside 4651 F.... pulseaudio
Date: Thu Aug 21 20:24:20 2014
HibernationDevice: RESUME=UUID=d0a4bd33-50b7-419e-80da-efc7ad5b1247
InstallationDate: Installed on 2013-11-08 (286 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
MachineType: ASUSTeK COMPUTER INC. 1015E
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-32-generic root=UUID=0323822b-7902-4f91-bf79-2a91c47d7df5 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-32-generic N/A
 linux-backports-modules-3.13.0-32-generic N/A
 linux-firmware 1.127.5
SourcePackage: linux
UpgradeStatus: Upgraded to trusty on 2014-04-18 (124 days ago)
dmi.bios.date: 03/15/2013
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1015E.303
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: 1015E
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1015E.303:bd03/15/2013:svnASUSTeKCOMPUTERINC.:pn1015E:pvr1.0:rvnASUSTeKCOMPUTERINC.:rn1015E:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.name: 1015E
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.

Mohammed Irfan (powerinside) wrote :
description: updated

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Did this issue occur in a previous version of Ubuntu, or is this a new issue?

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.17 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.17-rc1-utopic/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Mohammed Irfan (powerinside) wrote :

Thank you for the reply.

Upstream kernel 3.17-rc1 did it! (general amd64)

tags: added: kernel-fixed-upstream
fabianbur (fabianbur) wrote :

It's the same with the same machine

Changed in linux (Ubuntu):
assignee: nobody → fabianbur (fabianbur)
status: Incomplete → Opinion
status: Opinion → Confirmed
fabianbur (fabianbur) on 2014-08-23
Changed in linux (Ubuntu):
assignee: fabianbur (fabianbur) → nobody
fabianbur (fabianbur) on 2014-09-05
Changed in linux (Ubuntu):
assignee: nobody → fabianbur (fabianbur)
assignee: fabianbur (fabianbur) → nobody
João Marques (jahp94h) wrote :

My laptop is Acer Aspire E1-572G, and i have the same problem. Im using Razer Kraken Pro headsets and its as if the headset microphone didnt exist, its essentialy used as headphones.
The Sound settings show Microphone(built-in audio) and Analog Input(built-in audio), both recording the same thing, and nothing changes when the headset is plugged in.
I have windows-ubuntu dual boot, and the headset works well on windowsI. I can acess both internal and external microphone, and it changes automaticly for most applications.

Following some answers on the web i tried adding options to /etc/modprobe.d/alsa-base.conf, but it didnt work.
I used the options described on this answer:
http://askubuntu.com/questions/75828/external-microphone-not-working?rq=1

João Marques (jahp94h) wrote :

After all i was able to get it working with kernel 3.17-rc1. It does make noise as soon as i start/stop talking though.

I didn't noticed it before because if i plug it normaly, it wouldn't work. I have to go straight in, and then slowly pull it out until it picks up the external microphone, after that i can push it back in again. Its likely to be just an isolated case of bad connection.

What i did in kernel 3.17-rc1 doesnt work in my current kernel (14.04 kernel 3.14). So it did make a diference.

thanks

Denilson Sá (denilsonsa) wrote :

I have the same issue.

Asus X450CA laptop with a single TRRS jack. External headphones work correctly, but the external microphone does not work at all. Only the built-in microphone (that hole next to the webcam) is detected. This has been happening since 13.10 (the first Ubuntu I installed on this laptop, which was brand-new at that time).

alsamixer shows: Master, Headphone, Speaker, PCM, Mic Boost, Mic Boost, S/PDIF, Capture, Auto-Mute Mode, Digital.

Interesting that it shows two "Mic Boost" sliders, but there is no option to switch to the external microphone. The only recording device is called "Capture".

alsa-info.sh output:
http://www.alsa-project.org/db/?f=3fca8420153cf1b5424b490cf0d58f65224c27c1

Kernel release: 3.19.0-16-generic

 0 [PCH ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7e10000 irq 32

00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)

Codec: Realtek ALC270

Other bug reports from other people:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1366639
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1382642
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/212378
https://askubuntu.com/questions/75828/external-microphone-not-working

Denilson Sá (denilsonsa) wrote :

I found a solution:

1. Install "alsa-tools-gui" package.
2. Run hdajackretask.
3. Check ☑ Show unconnected pins.
4. At pin 0x18, check ☑ Override and select Microphone from the list.
5. Click "Apply now" to test if it works.
6. Click "Install boot override" to make it definitive.

In my case, it was pin 0x18. I don't know if the pin is different for other laptops.

See also a screencast of this solution: https://youtu.be/yx33W-c4Cmg

fabianbur (fabianbur) wrote :

This is the ultimate solution to suggest ubuntu include in future versions. It works for the specific model of the bug Asus 1015E, I've tried and I guess for other models of notebooks and laptops. No need of foreign configurations, only edit this file:

Edit:

 /etc/modprobe.d/alsa-base.conf

add

options snd_hda_intel model=laptop-dmic

Changed in linux (Ubuntu):
assignee: nobody → fabianbur (fabianbur)
status: Confirmed → In Progress
Xavier (rxaviers) wrote :

It doesn't work for me. Macbook Pro Early 2015 using iPhone earphones. alsa-info.sh output:
http://www.alsa-project.org/db/?f=a501c61487346e167aeb034a9ff0b7b0e8a81555

I've also tried using hdajackretask as explained by Denilson, but it didn't work for me.

virgosun (hdefendme) wrote :

me too Asus X451CA Realtek ALC270. Ubuntu 16.04

virgosun (hdefendme) wrote :

I confirm @fabianbur work around solve the issue

Zaki (zakimano) wrote :

Same issue, fabianbur's fix didn't work for me.

Lenovo Ideapad 305 15IBD
Windows 7 and Ubuntu 16.04 dual boot.

This day that I'm posting this is the first time I've encountered this issue, and it's really annoying. Was working fine until now, the only thing I've modified and could have triggered this to happen, was enabling the echo-cancellation in PulseAudio, as seen here: https://askubuntu.com/questions/18958/realtime-noise-removal-with-pulseaudio

Otherwise I have the same experience as Denilson Sá (denilsonsa) above, alsamixer works fine, but only 'Capture' and 'Internal mic boost' comes up as input, regardless of jack plugged in or not.

+1 to issue
Asus K56CB

Ubuntu 16.04
root@anb:~# uname -a
Linux anb 4.4.0-21-generic #37-Ubuntu SMP Mon Apr 18 18:33:37 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
dpkg -l |grep -i "alsa\|sound"
https://pastebin.com/4r5N34JA

Asus N550JV, Ubuntu 16.05 with kernel 4.4.0-71, same bug. Tried the workaround but it sadly did not help.

Linux bigdataacer 4.4.0-71-generic #92-Ubuntu SMP Fri Mar 24 12:59:01 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

I have the problem. Acer Aspire E15 4 pole combo jack.
Ubuntu 16.04.2

The sound control only show the internal mic (which works badly) and I want to use the external mic. (I have a 4 pole jack adapter).

Vyacheslav (slavustm) wrote :

Experiencing same problem on Debian Jessie on Lenovo G40-30. After assigning pin 0x18 to microphone acpi_listen prints that microphone is plugged in but pavucontrol still shows mic as unplugged. Also trying to boost appeared after pin assignment microphone in alsamixer makes large increasing noise so I think overriding that pin is not a part of solution for me. Fabianbur's solution didn't work too.

Joel Clay (joelerz) wrote :

I am experiencing this problem as well on Ubuntu 17.04 with a fresh install. Audio out works fine, but the audio in is reported as "Unplugged"

Gloschtla (gloschtla) wrote :

I have the same problem with Linux on my ASUS 1001PXD
...earlier with Ubuntu 14.04 installed, and now still with Linux Mint 18.

The above suggested solution with hdajackretask even destroyed my audio settings: Now there is only Dummy output, and no input devices at all. How to reset this?

affects: linux (Ubuntu) → linuxmint
Changed in linuxmint:
assignee: fabianbur (fabianbur) → Gloschtla (gloschtla)
Gloschtla (gloschtla) on 2017-08-27
Changed in linuxmint:
assignee: Gloschtla (gloschtla) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers