Live Disc Install Wizard Options to Replace Previous Mint Installation Reformats Entire Drive

Bug #1325786 reported by Barry Rueger on 2014-06-03
66
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Linux Mint
Fix Released
Critical
mr.kreb

Bug Description

I'm adding this because it seems that the complaint re Mint 16 went unrrepaired.
https://bugs.launchpad.net/bugs/1256601

I just installed Mint 17 Cinnamon from USB, using the update instructions on the Mint website.

Like the previous reporter:

I downloaded and burned the 64 bit Cinnamon version of the Mint 17 to USB, booted it, and double-clicked the "Install Mint" icon on the desktop. The installation wizard detected the previous installation and provided me with the option to "Replace Linux Mint 16 Petra (16) with Linux Mint 17" and warned me that this would delete all of my Linux Mint 16 programs, data, etc . I considered whether I ought to recreate the partition scheme myself, but as it seemed to have been smart enough to detect the previous installation, it seemed reasonable to let it do its thing. 30 minutes or so later, it turned out that instead of overwriting just the previous / partition, it had reformatted the entire disk, destroying all of my data partitions as well.

Sweet Jesus - this is one NASTY default option! I just inadvertantly lost three BIG partitions full of things that actually matter because I assumed that Mint 17 would just install over the PARTITION containing Mint 16. I honestly did not know or even suspect that it would delete all other partitions in one fell swoop.

I hope to hell that TestDisk can recover this mess! I did boot into the new install once, and then realized that the other partiitons had been nuked.

This is SERIOUSLY a BAD, BAD thing.

FOLKS! I've installed Mint many times. If this caught me unawares it is VERY DANGEROUS.

1): Mint 17 Cinnamon downloaded today.
2) See above
3) Mint 17 formatted the entire hard drive, deleting several partitions containing data.
4) Expected Mint 17 to overwrite THE PARTITION containing Mint 16
5) Apparently always.

It does what it says. When it said "all you data" you assumed it didn't mean that.

With that said, I had a conversation with somebody about this already, and I really agree on the fact that this is utterly confusing. To novice users the warning is explicit enough. To advanced users, there's obviously missing information as to what this option does to existing partitions and whether or not it deletes the entire OS (i.e. everything that's mounted via /target/etc/fstab) or simply the root partition itself.

We'll look into fixing that for the next release. In the meantime we'll update the release notes to let people know.

Barry Rueger (barry-rueger) wrote :

Hi Clement - I'd like to assist the team working on this. I'm hardly a beginner but I've always found the Mint installer confusing at that point.

If it's aimed at beginner users (or ordinary people) the installer is pretty much flawless except for this one real weakness.

If they're installing from scratch to a new hard drive, or installing to create a dual boot setup (such as with Windows) the two options are probably fine - Mint will set up and partition the drive in a fine fashion with no further input.

If, though, they're trying to upgrade versions they'll get that far and (if lucky) be stumped about which to choose to do an upgrade of the OS. If they choose option A they'll get two versions of the OS on their drive. This might not hurt them, but it's probably not what they want or need.

If they choose option B they lose all of their data.

If they can figure out that neither of those are what they want they wind up being dropped headfirst into the whole drive partitioning process - not something that average users can or should try to do.

Heck, even I feel vaguely uncomfortable with it, and I've done it more times than I can recall.

I don't code, and don't know how complex it would be, but what's really needed is way to separate users doing an INSTALL from users doing an UPGRADE, and give them appropriate options.

This is important. Mint is recommended to an awful lot of new Linux users, and overall it's a very, very easy switch. If those new users find themselves stopped dead part way through the install, not sure what to do, or worse if they nuke their whole drive, they'll never come back.

Adding this to the Release notes is good, but at a minimum I'd suggest some kind of incremental update to the Installer that adds some REALLY explicit language saying "This will delete ALL partitions and ALL data from the ENTIRE hard drive."

That's just a few more characters (maybe some boldface tags) to catch them at the specific spot where damage happens. Better to do that than to tell them after the fact "You should have read the Release Notes."

Part of the reason why this is needed is the sheer size of modern drives. It's almost impossible to buy a drive under 1 terabyte. This greatly increases the likelihood that people won't backup, so they need protection when doing installs and upgrades.

And even if they do backup (Say using Mint Backup) the backup will be large enough that placing it on another partition is the obvious choice - not everyone has a second hard drive kicking around.

I doubt that most people will manage to store even a MintBackup to a USB stick, and can't think that CDR or DVD-R are even remotely an option anymore.

Thanks, I agree with you and we'll get it done but not in a hurry. Even putting technical debt aside, the risk of breaking something and the huge amount of resources needed to re-release, we'd have to properly localize the message. This is something we'll address in the next release.

Vlad Orlov (monsta) wrote :

Barry, did you have those now-lost partitions mounted in fstab in your previous Mint installation?

ComPlot (lawimutuma) wrote :

OK. This is actually a problem. Last I lost ALL my data upgrading from Mint 15 using that option.

There is nothing in the warning or the process flow that could have prepared me for the loss of close to 1 TB of data, etc.

I genuinely expected the installer to UPDATE the Mint only. So optimistic was I that I thought my /home partition would be spared - It's usually shared by Mint and Open Suse.

If not in the wording of the warning - (honestly, if you tell me that am gonna lose Linux Mint 15 data, I expect to lose Linux Mint 15 data ONLY), then at least introduce a summary step which tells me that, "hey, this is what's gonna happen. You click that freaking button, we wipe your disk. Feeling lucky?"

Vlad Orlov (monsta) on 2014-06-09
Changed in linuxmint:
status: New → Confirmed

This was fixed in Git.

After reviewing the Ubiquity code it turns out this "Replace $OS with Linux Mint" is nothing else than an option to use the entire drive. The wording is extremely misleading and so the option was renamed appropriately to "Erase disk and install Linux Mint".

This fix was released in time for the Xfce edition and the bug never affected the KDE edition. As it stands this issue is still present in the Cinnamon and MATE editions and so it will be covered by added information in the release notes until either the release of 17.1 or a respin of the affected ISOs.

Changed in linuxmint:
status: Confirmed → Fix Released

The release notes and release announcements for the Cinnamon and MATE editions were edited to mention this issue.

Here's the fix, in case derivatives or upstream follow this report: https://github.com/linuxmint/ubiquity/commit/8bfc98e60cc80cefe7986774f3740a5b0530e364

Changed in linuxmint:
importance: Undecided → Critical
assignee: nobody → Clement Lefebvre (clementlefebvre)
M (planktonicme) wrote :

It happened once, But this Mint 7 deserve nothing , but questions to answer. Did I downloaded a fake ISO with 1.2GB. Seems to me, as it said the message was vague during installation, did the OS provider just took my entire hard disk that was years dowloads, my favourite things. I shouldn't have switch from OpenSuss or ubuntu, but I thought, What if ......~
Ya, I was stoned. When it happened. But, that doesn't mean even a novice like me is not that fool. I guess, this thing put a dent on its creators.

Barry Rueger (barry-rueger) wrote :

Thanks Clement (and everyone involved.) Two weeks on I'm still spending far too much time recovering and/or recreating lost files. Many things are simply gone forever as the time to scan for them with PhotoRec would be too much.

It's good to see this taken seriously - and it encourages me to continue to file bug reports.

Hi,

I'm sorry. Afaik this bug was introduced in Ubuntu 13.10 and it affected Ubuntu 13.10, Mint 16, Ubuntu 14.04 and Mint 17 (MATE and Cinnamon editions). We got a bug report on Mint 16 and the Ubuntu guys got one on 13.10, but it went under the radar and it's only now after getting feedback from the stable 17 that we're able to identify this issue and fix it.

I wish we could have done that immediately with Mint 16 or that we could have done that during the RC process, but it's only after 17 stable that it happened. Ubiquity is upstream from us, and is partly also upstream from Ubuntu (it uses a lot of components coming from Debian.. d-i, partman etc.). The nature of the bug was also misleading for developers because it was easy to attribute this to a user mistake or an opinion/interpretation.

You can see for instance in the upstream bug that this didn't really catch Ubuntu's attention as a proper bug yet. And you can see also at the beginning of this report that my first reaction was to tell the OP he had assumed too much.

It's really hard for distributions the size of Mint or Ubuntu to be aware of every single bug report we get, and even more so to validate them, identify their cause, reproduce them and get to the stage where the fault gets to the right developer and action is taken. Sometimes there's one particular bit of info in one piece of feedback we get that rings out of all of that, or someone who gets out of the crowd and manages to reach out to us directly and show us exactly what we need to see to put that above every other concern. We get that often. When it relates to something critical, like here, it feels both great (because we can fix it) and frightening (when we discover what was there).

Between the release of the MATE/Cinnamon editions and the release of the Xfce edition, time has passed. Many bugs were fixed during the first RC, but we're still learning. Xfce comes with this issue fixed, it also comes with fixes for corrupted APT sources in the event where / isn't formatted, it comes with better support for Wine/Steam games, out of the box deps for Skype etc etc.. we're always improving. Some bugs are quick to identify, others like this one are deceiving and span across multiple releases.

The LTS strategy means we won't accept new features into the installer for at least 2 more years, which reduces the chances of regressions like this one. As you can see there's a delay, whether the features come from upstream, or from our own team, between the moment the code change creates a regression and the moment we realize it and fix it. The absence of changes is a very positive thing in terms of stability.

I'm very sorry some of you lost data and I hope you're able to recover it. The label was indeed misleading and it didn't indicate the installer would wipe the drive. I'm sure Ubuntu will come to the same conclusion. I hope you'll accept our apologies for letting that through our nets and please rest assured we're taking it very seriously.

RCR (teukros) wrote :

This just cost me several days. So what's the timeline for a fix?

We're starting working on these respins as soon as the KDE and Xfce editions are out (which should both hopefully be out this week). This bug is already fixed in the Xfce edition, and it never impacted the KDE one.

Also, since the initial release, numerous important fixes were applied to Qiana. The new ISOs won't just fix this bug but a couple of other important issues. Although this won't be a proper "release", all new ISOs will need to go through QA again. There's 10 of them also so it might take some time.

Don't take this as an ETA, this is just an estimation, but I'd like to have all of this done by the end of June, a week from now.

This is critical enough to break the cycle and warrant respins so nobody gets affected by it anymore. It's worth noting that since the 14th of June, thanks to the poor people who already lost data as the result of this awful bug, this is documented in the release notes for others not to experience the same tragedy. I'm very well aware this isn't enough, and we'll get respins out asap, but now more than ever I'd like to stress the importance of the release notes.

This is still pretty critical, but since the 14th it only affects people who don't read the release notes.

Hopefully once the ISOs are respinned it won't affect anybody at all any more.

As a newbie, I appreciate the warning. One more thing that would be helpful for people like me is a simple statement of what the steps the user should take if he/she wants to upgrade the LM OS, leaving the other partitions intact. That may be obvious to more experienced users, but it's not obvious to me. Thanks.

The new ISOs were announced and officially replaced the previous ones today.

mr.kreb (sebaskreb) on 2014-06-30
Changed in linuxmint:
assignee: Clement Lefebvre (clementlefebvre) → mr.kreb (sebaskreb)
Phillip Pether (roofox) wrote :

I would like to know why Linux Mint doesn't have Reinstall or Upgrade options for the installer like Ubuntu does? I would of thought for all modern Linux OS's of today could make that possible to do so without losing any of the data stored on the hard drive. What's the reason behind not having those options available to Mint?

Rick Dempsey (rickdempsey415) wrote :

This happened to me as well. Went to reinstall mint 17, picked the second option to replace the original mint 17 install and wham...lost my XP, partitions, everything. This didn't happen with Ubuntu, and, atm not very pleased. Have another XP machine so I'll be sure not to repeat the same error

Patrick (preilly2) wrote :

I consider myself lucky to have avoided this disaster. It presumably helped that I dual-boot Mint and W7. When I upgrade I always choose the 'Something else' option during installation, which lets me manually specify the partitions where I want the boot loader and OS installed. I copy my personal data to a storage partition. I do have to set everything up again the way I want it each time I install a new Mint, but I've gotten used to it and it doesn't take long. It's good to start with a clean system, too.

ben santillan (ben-santillan) wrote :

Patrick (preilly2):

I want to update my Linux Mint to 17 and I have a dual boot laptop with W8.

If I choose the "Something else" option, does this mean the install won't erase my whole hard drive?

I've been using Mint since 13, but I'm not an expert at this. Would appreciate any help you can give.

Thanks.

mutamba (mmbembe) wrote :

Hi people,

I want to report another problem with LMDE 201403.
Please DO NOT INSTALL IT if you have partitioned drive with data and/or another OS!

The stupid installation process guides you to the step where you have to choose the way of installation - "automatic" when MintInstall detects your drive or "manual, for advanced users" ...

I have read regarding deleting of all partitions, first I selected "manual option", sda for grub install and got error "first mount" - very nice- there is no option to manually mount as in previous version of LMDE (first time installed LMDE due to installation problems of normal Mint version, no one after Mint7 leave your data/partitions untouched).
Well, after next click the installation process stopped...
GParted shows all my partition, still...
Restart the installation with "automatic" option but stopped at "Mint detected empty drive"... back button and checked my partitions with GParted- a single unused/empty partition remained...

OK I said, not my lucky night, once I have 2 OS I will abort the LMDE installation...
Reboot my laptop and.... surprise, MBR was destroyed by super-stable-easy MintInstall...

Boot with recovery disk - no valid partition, Acronix does not show any partitioned disk- just my empty HDD...

Thanks to HirenBoot CD which give my data a chance by scanning for existing partition and recovered all my NTFS stored data.
Reboot- Windows UP, my data safe.

I would like to ask developers why is so hard to keep users data safe?
Why the installation process is so dangerous, even for upgrade?
This problem you have for long time, Mint7 was last safe one, LMDE I use for several years has the same problem "with automatic" now the manual installation also is defective.

I will keep my MintInstall for few days waiting for answer/hint/how to... or something else, if not I think with all regrets my experience with Mint (and Ubuntu) is approach to the end.

Sorry Mint, you are getting old even not being young- just kid&retired.

Sharath (dr-sharathp) wrote :

I felt it was necessary to post my experience with this bug as well. I was dual booting with Windows 7 and Ubuntu. I decided to move to Linux Mint 17 and the installer correctly detected Ubuntu but said nothing about Windows. Therefore, I wrongly (& now regretfully) assumed that Mint would wipe only Ubuntu and install itself in that partition. I was shocked after a while to discover that my entire disk had been wiped and all my data was gone including expensive purchased software licenses in Windows. Thankfully I had only recently backed up all of my important data and what I did lose was not irreplaceable. I am not new to the Linux environment by any means but I am no expert either. I completely agree with the original bug report - that while I am partly to be blamed, the installer should have warned me more forcefully as to what it was actually going to do and it should also have detected Windows. It is only common sense to assume that another OS won't be completely wiped that easily.

 That said, I am not complaining here. Just relating my experience so that something good will come out of it. I am loving Qiana and I just made a donation as well.

anthony jones (m-hazton) wrote :

 I had the same problem Lost XP and a load of data,being a newbie am i to take it if i use the same instalation disk on anouther
PC the same will happen ? ..... if so what is a safe way of dual booting ?

Hi,

Just to make things clear:

- Information about this was added to the release notes.
- This bug was fixed.
- New ISO images were released to the public with the new installer.
- Links on linuxmint.com and in the announcements, download page, etc.. were updated to point to the newer ISOs.
- Torrents were updated.

If you're using the MATE or Cinnamon edition, your ISO filename should contain the letters "v2". If that's not the case you're using the original ISOs.

If you're using the KDE or Xfce edition, the fix is already included in them (these editions were released after this bug was fixed).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers