LMDE 201403 fsck.xfs doesnt exist so new install doesnt boot

Bug #1322164 reported by LuisEscobar on 2014-05-22
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linux Mint
Fix Released
Undecided
Unassigned

Bug Description

When you install a fresh LMDE 201403 (cinnamon or mate) using xfs as your file system type you wont be able to boot because fsck.xfs doesnt exist.,

When booting, the last parameters at /etc/fstab for the / file system are set (by default) to 1 1 so it will try to perform a check at boot time using fsck. But, because fsck.xfs to check xfs file systems is not present, it will never be able to perform the check and the system wont boot. The screen will be black. Pressing esc at boot time you realize about messages and finally the error.

The solution or workaround until a fsck.xfs is provided at install time is to boot again with the live usb, mount the partition and set last options at /etc/fstab for the / file system to 0 0 The system will boot normally without performing any check on your / file system.

After booting you can perform

# apt-get install xfsprogs

so fsck.xfs is installed

then vi /etc/fstab and restore 1 1 as your / file system options

problem workarounded

description: updated
description: updated
description: updated
description: updated
Vlad Orlov (monsta) on 2014-05-23
tags: added: lmde
Vlad Orlov (monsta) wrote :

I can confirm this. Attaching a screenshot from a virtual machine.

Changed in linuxmint:
status: New → Confirmed
LuisEscobar (escobarl666) wrote :

Looks like the problem comes from Debian.
I have installed Debian Wheezy and the same problem occurs. Also the same workaround works.

 I have just reported the same problem on Debian.

Fixed for upcoming LMDE 2 Betsy.

Changed in linuxmint:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments