network-manager-vpnc not offering cisco connection in mint 16 cinnamon

Bug #1254054 reported by Tom Fallon on 2013-11-22
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Linux Mint
Undecided
Unassigned

Bug Description

I am running Lint 16 Petra RC Cinnamon 64-bit on Lenovo T520 laptop with all updates applied.

I've installed network-manager-vpnc which in previous versions of Mint was all that was needed to setup a Cisco Compatible VPN connection. When I click on Network applet on the panel then Network Settings then the + symbol to add a new connection the only option I am offered is:

Interface: VPN

Click Create button and only option offered is:

Point-to-Point Tunnelling Protocol (PPTP)
or
Import a saved connection

I would expect to see as a dropdown choice (and in the past it was the default option offered) for Cisco Compatible VPN (vpnc)

vpnc was already installed, I believe that comes with Mint. I manually installed network-manager-vpnc. I have also tried removing and reinstalling both vpnc and network-manager-vpnc with no change.

Versions installed are:

Setting up vpnc (0.5.3r512-2ubuntu1)
Setting up network-manager-vpnc (0.9.8.2-1ubuntu1)

regards, Tom

Tom Fallon (kiweegie) wrote :

I have installed Ubuntu 13.10 64bit in a Virtualbox VM and after installing network-manager-vpnc it alllows me to add cisco compatible vpn connection so this looks to be a bug in Mint and/or Cinnamon.

Uxinn (steinarms) wrote :

:~$ cat /etc/issue
Linux Mint 16 Petra \n \l

I tried installing all network manager plugins :
sudo apt-get install network-manager-gnome network-manager-pptp network-manager-pptp-gnome network-manager-iodine network-manager-iodine-gnome network-manager-openconnect network-manager-openconnect-gnome network-manager-openvpn network-manager-openvpn-gnome network-manager-strongswan network-manager-vpnc network-manager-vpnc-gnome

Then I opened network settings, clicked the + and it offered me to create VPN for all of the above.
I installed Mint 16 RC..

Resolved ?

Tom Fallon (kiweegie) wrote :

Hey Steinarms - indeed, works for me, many thanks

Is there any reason why all of these should be needed with Mint 16 when under Ubuntu 13.10 they are not required (just for Cisco Compatible client) and indeed under earlier versions of Mint they were not either?

That is not meant to come across as ungrateful for the solution by the way, just curious why all of these would be needed.

I did try adding network-manager-vpnc-gnome and the openconnect client too previously based on another users suggestion but that still showed nothing. Would be curious to know which of these addons actually kicks the cisco compatible client into showing. Or if perhaps under mint cinnamon 16 they are *all* required in order to show any.

Options I now see are (in order):

Cisco AnyConnect Compatible VPN (openconnect)
Cisco Compatible VPN (vpnc)
IPsec/IKEv2 (strongswan)
Iodine DNS Tunnel
OpenVPN

cheers, Kiweegie

Russell (russelljbrennan) wrote :

You only had to install the gnome component, ie network-manager-vpnc-gnome and it would have worked.

Changed in linuxmint:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers