Laptop suspends on "lid close" even though setting shows "do nothing"

Bug #1243383 reported by Fox F on 2013-10-22
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Linux Mint
Undecided
Unassigned

Bug Description

- Version: Petra (installed Olivia, then replaced raring with saucy/olivia with petra in sources)
- In settings, for both AC and battery, configure "do nothing" for "When the lid is closed" in power options
- Close lid, and the device suspends.

Fox F (m-fox) wrote :

I am on Cinnamon.

Laptop: Lenovo Thinkpad D510

Other bugs that might be related:
https://bugs.launchpad.net/linuxmint/+bug/1190116 -
https://bugs.launchpad.net/linuxmint/+bug/1019516

Felix Haller (felixhaller) wrote :

Same here:

* Lenovo Thinkpad X220i Tablet
* Cinnamon 2.0 (via PPA) on Xubuntu 13.10 64bit

If I close the lid, the notebook is going to sleep, no matter what is set in the settings (I also tested with "do nothing" for both, battery and AC). after waking up, there is no password prompt (although it's selected in settings)

BUT, if i select "suspend" from SystemMenu or press the sleep button on my keyboard the system goes to sleep and does ask for password when waking up. That's the correct behaviour.

I guess the lid-closing action may bypass the screensaver/power settings of cinnamon (?)

If you need any further data, I will provide as much as I can.

Felix Haller (felixhaller) wrote :

Here I found a (workaround?)-solution:

http://www.linuxmintusers.de/index.php?PHPSESSID=ae47571e196b624a3109c83c69d26183&topic=15178.msg179264#msg179264

edit the file /etc/systemd/login.conf and uncomment/modify the following two lines:

HandleLidSwitch=ignore
LidSwitchIgnoreInhibited=no

Now in my case the settings in cinnamon are no longer ignored.

Roland Lohner (loczaj) wrote :

Hi Felix!

Thanks for your comment.
In my case LinuxMint suspended on lid close even if it was not set in power settings.
Your solution worked, now suspend on lid close behaves as configured.

Thank you!
Roland

Bob DeLima (bdelima) wrote :

This is still not working for me. Please advise.

Bob DeLima (bdelima) wrote :

I'm on a Thinkpad T430. Tried various remedies on the net but no matter what I do, the laptop suspends on lid close. This is a major inconvenience when using a second large monitor. System worked perfectly with Mint 15, but after upgrade to 16, I have this issue.

chemicalfan (mike-lumsden) wrote :

This method of upgrade isn't officially supported (http://community.linuxmint.com/tutorial/view/2 & http://community.linuxmint.com/tutorial/view/62), not sure if this would be better off posted on the forum, as I don't see how a fix would be implemented in the existing Petra packages

Changed in linuxmint:
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers