Desktop launchers launch applications in xterm instead of x-terminal-emulator

Bug #1238964 reported by Peter Berry on 2013-10-11
44
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Linux Mint
Fix Released
Undecided
Unassigned

Bug Description

Version: Mint 14, MATE 64-bit

When you create a launcher on the desktop and set its type to "Application in Terminal", the terminal it runs the application in should be x-terminal-emulator, which by default is set to mate-terminal. However, it actually ignores x-terminal-emulator and uses xterm instead.

A potential workaround (which I haven't tried) would be to uninstall xterm and add a symlink at /usr/bin/xterm to /usr/bin/x-terminal-emulator. Unfortunately this breaks the dependencies of the Debian package for Steam, which depends on xterm | gnome-terminal | konsole.

Sneetsher (sneetsher) wrote :

mate-terminal does not have a xterm wrapper, try install gnome-terminal which has one. See https://askubuntu.com/questions/419641/panel-apps-try-to-launch-in-xterm-even-though-it-isnt-installed/

Peter Berry (pwberry) wrote :

Actually, it apparently does have one, or at least did have one: https://github.com/mate-desktop/mate-terminal/issues/9

Changed in linuxmint:
status: New → Confirmed
Sneetsher (sneetsher) wrote :

I could confirm that Mint 16 contains mate-terminal.wrapper. thank you Peter.

For earlier releases:

    - mate-terminal.wrapper could be downloaded from source repository of mate-terminal, set it up using update-alternatives.

    - just install other alternative desktops terminal which have a wrapper like gnome-terminal, xfce4-terminal,.. . Any of them will configure the x-terminal-emulator to its own wrapper.

Peter Berry (pwberry) wrote :

Confirmed in Mint 17 as of now. Steps to reproduce:

1. Right click on the desktop and select "Create Launcher..."
2. Select type "Application in Terminal". Type "bash" in both name and command, then press OK. After the dialogue closes, a launcher icon named bash should appear on the desktop.
3. Double click the launcher.

Expected result: x-terminal-emulator starts, running bash.

Actual result: xterm starts, running bash. You can confirm that it's xterm by running the command "pstree | grep bash".

Raphaël Halimi (raph) wrote :

It's actually a Glib bug, see: https://github.com/mate-desktop/mate-panel/issues/57 (last comment from gpolitis, thanks to him/her for spotting the origin of this).

I opened a bug in the Debian BTS, and submitted a patch: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=773915

I'm attaching the patch here as well.

Regards,

--
Raphaël Halimi

Changed in linuxmint:
status: Confirmed → Fix Released
Oliver Joos (oliver-joos) wrote :

Thank you very much for fixing this long-lasting bug!
I see it fixed in Linux Mint MATE since February 2018.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.