[LMDE] mintupdate-debian and mint-mirrors packages share the same file

Bug #1204649 reported by Vlad Orlov on 2013-07-24
4
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux Mint
Fix Released
Undecided
Unassigned

Bug Description

Hi,

Several users at the forum reported they can't install mint-mirrors package when mintupdate-debian is installed (i.e. always - in LMDE) since they share the same file, /usr/share/python-apt/templates/LinuxMint.mirrors. It would all be good if they've been marked as conflicting with each other, but they aren't, so apt-get doesn't see anything bad, and then dpkg gets unhappy.

I see two options:

1. Add "Conflicts: mint-mirrors" to mintupdate-debian (and vice versa).
2. Remove mint-mirrors from the LMDE repo as it seems it's intended for being installed alongside mintupdate in the main Mint edition. If this option is accepted, I propose also removing the main edition's mintupdate from LMDE repo.

More information and detailed error messages can be found in these threads:

http://forums.linuxmint.com/viewtopic.php?t=113470
http://forums.linuxmint.com/viewtopic.php?t=122688
http://forums.linuxmint.com/viewtopic.php?t=140570

Changed in linuxmint:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers