Greeter application error

Bug #1185540 reported by Mike Hayes on 2013-05-29
76
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Linux Mint
Fix Released
Critical
Clement Lefebvre

Bug Description

On system startup I get an error box stating "the greeter application crashed, trying another".

I can only get past this by rebooting a few times and it eventually starts up fine.
This still occurs when trying other HTML themes besides the default.

Release: Linux Mint 15 "olivia"
Edition: Cinnamon 64-bit

Mike Hayes (mhnj77) wrote :

I have done some more testing and determined that this error only occurs while using a specific video driver.
I have the problem while using nvidia-current (I believe it's 304.88)

I have confirmed that this error does not occur while using the open source nouveua driver or while using nvidia-experimental-310

Nick Payne (nick-payne) wrote :

This error doesn't only happen with the 304 nVidia driver. I'm using the 313.30 driver and the error is happening with that driver as well.

Mike Hayes (mhnj77) wrote :

I've found it does happen with the 310 nvidia driver, it just doesn't occur as often.

Patrick Then (patrickthen) wrote :

I'm affected as well.
Mint 15 Cinnamon 64bit.
Phenom II x4, NVidia GTX 460

So far, I've found no fix.
Different drivers don't help.

The bug seems to have appeared after an update about one week into the RC testing phase, but that might be coincidential.

Patrick Then (patrickthen) wrote :

Here's also a forum thread reporting on the issue:
http://forums.linuxmint.com/viewtopic.php?f=208&t=135417

Rufus (balaenoptera-rufus) wrote :

My computer is also affected by this bug.
It's running Olivia Mate amd64.
The video card is a nVidia GTX 460. (Are other nVidia cards also affected, or only GTX 460?)
I tried several video drivers available in Mints Driver Manager. That didn't solve the problem, unfortunately.

Patrick Then (patrickthen) wrote :

As a (hopefully only temporary) workaround, it seems to help to switch the login window to a GDM theme instead of the newer HTML themes.
We lose out on most of the functionallity of HTML themes, but it doesn't crash (for me at least).

Aloysius (aloysius-w) wrote :

Same here, I tried 304, 310 and 314 driver without any discernible difference.

John R. Boutiette (boutiettej) wrote :

Also Same Here.
Graphics is a Nvidia GTX 660 running 319.23 version. Have that driver running on both of those Versions below. Has been doing it since I did a clean install of Mint 15.

Intermittently does it.
Linux Mint 15 Olivia
Ubuntu 13.04 Cinnamon on separate Partition - Hasn't done it once

Aloysius (aloysius-w) wrote :

Any solution in sight?

kevin flynn (etothex23) wrote :

I am getting this error as well. Mint 15 Cinnamon 64bit. I tried other nvidia drivers to no avail.

Aloysius (aloysius-w) wrote :

@etothex23

Switch to a GDM theme, it appears to be the only solution available at the moment.

kevin flynn (etothex23) wrote :

@Aloysius
I have set it to GDM, but it was at the end of the night last night. I will see how it is running later. I thought this might just be an issue with the nvidia drivers. The install uses a default x driver, I am wondering if that is going to be the fix. I will see how long it lasts just using the GDM.

Aloysius (aloysius-w) wrote :

I don't know what it is, but I've given up trying to fix it.

MDM with a GDM theme hasn't crashed for two months so far.

Thanks, I'll try it.
On Jul 24, 2013 12:26 PM, "Aloysius" <email address hidden> wrote:

> I don't know what it is, but I've given up trying to fix it.
>
> MDM with a GDM theme hasn't crashed for two months so far.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1185540
>
> Title:
> Greeter application error
>
> Status in The Linux Mint Distribution:
> New
>
> Bug description:
> On system startup I get an error box stating "the greeter application
> crashed, trying another".
>
> I can only get past this by rebooting a few times and it eventually
> starts up fine.
> This still occurs when trying other HTML themes besides the default.
>
> Release: Linux Mint 15 "olivia"
> Edition: Cinnamon 64-bit
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/linuxmint/+bug/1185540/+subscriptions
>

Rufus (balaenoptera-rufus) wrote :

I tried a GDM theme, but had the same issue as with HTML themes.

Ricardo Almeida (ric-almeida) wrote :

 It also happens with me on a Nvidia GeForce 8200M (Compaq CQ60). Using a GDM theme seems to work fine...

Matt (mattcbro) wrote :

Yup it's happening to me to with my nvidia gtx 770. My older box also has an nvidia card (280 gtx) and recently it's been having cinnamon just randomly freeze. Are there any linux distros right now that run stabley using nvidia graphics cards? I had a lot of problems with ubuntu prior to switching to mint, which ran flawlessly for months until some very recent updates. Does the mint mate desktop show these problems? Just wondering.

Since Nvidia supports red hat I wonder if centos would be more stable for high performance cuda applications.

kmb42vt (tbeposts) wrote :

It affects me as well using the 304, 310 and 313 driver on a GT 430 media card in my desktop PC although it's an infrequent occurrence now. I should mention though, in my case I'm running the Cinnamon nightly PPA so Cinnamon, MDM, Nemo and all associated libraries and dependencies (including the addition of "cinnamon-session" and "cinnamon-settings-daemon") are updated on a daily basis. That being said, I haven't had enough time to test the new "slimmed down" version of MDM that came out today.

Changed in linuxmint:
assignee: nobody → Clement Lefebvre (clementlefebvre)
importance: Undecided → Critical
status: New → Confirmed

Hi everyone,

Experienced users, please try and upgrade webkit as detailed here and let me know if that fixes the issue for you: http://forums.linuxmint.com/viewtopic.php?uid=2&f=208&t=135417&start=80

It is strongly recommended novice users do not follow these instructions and simply switch to the GTK/GDM greeters for the time being.

Rufus (balaenoptera-rufus) wrote :

Hi Clem,

thank you for digging deep into that unpleasant problem.

I'm afraid I'm not experienced enough to upgrade libwebkitgtk-1.0-0.
But I am happily anticipating the forthcoming release of Linux Mint 16 with the new version of libwebkitgtk-1.0-0.
:-)

Rufus

Mike Hayes (mhnj77) wrote :

So far all looks good. Applied the fix and no errors after 5 restarts.

Thanks Clem!!

Kevlar (kevin-j) wrote :

Using

    apt-add-repository ppa:gnome3-team/gnome3

as recommended in the link posted in item #21 above adds the entry

    http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu olivia main

to my repository list - but that fails because the gnome3 PPA doesn't have a section for 'olivia'. Editing it (or entering it manually in the first place) via Synaptic so that the entry reads

    http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu raring main

then locates the correct repository for my installation which is based on olivia/raring. You may need to use something else.

Then I located the four libwebkit entries (using Synaptic); marked them all for 'upgrade', clicked on 'apply' and the upgrade went without a hitch. It did pull in updates to several other libraries; but all the dependencies were satisfied without any problems.

apt-add-repository is provided by mintsources in /usr/local/bin. Make sure you're not using the Ubuntu version from /usr/bin.

brandy (seppbrandy) wrote :

Hy
I'm still having the occasional greeter crash. Is there an official, novice available, fix or do we have to wait for Mate 16 ?

Brandy

It's probably best to wait for Mint 16 at this stage and use another greeter as a workaround.

Changed in linuxmint:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers