Mint-X theme causes problems with Eclipse

Bug #1168281 reported by Jens Reimann on 2013-04-12
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Linux Mint
Fix Released
Undecided
Unassigned

Bug Description

Using the Mint-X theme and Eclipse causes minor visual corruptions with Eclipse. It seems as if the Toolbar's background is always drawn, although it should be transparent (inherit from parent) sometimes. Switching to the "Adwaita" GTK themes solves the issue, although it does not look as good as the Mint-X theme.

Jens Reimann (ctron) wrote :
Jens Reimann (ctron) wrote :

I just found a setting in the "gtkrc" file of the Adwaita theme that is not in the "Mint-X" theme:

widget "*swt*toolbar*" style "null"

maybe this is the difference?!

Jens Reimann (ctron) wrote :

Ok, so the solution is to add the following content to the file "/usr/share/themes/Mint-X/gtk-2.0/gtkrc":

style "null"
{
        engine "pixmap"
        {
        image
        {
            function = BOX
            file = "Null/null.png"
            stretch = TRUE
        }
        }
}

widget "*swt*toolbar-flat" style "null"

Jens Reimann (ctron) wrote :
Jens Reimann (ctron) wrote :

I also made a pull request on github.

kenden (kenden) wrote :

The fix works on Linux Mint 15 64b, with Eclipse 4.3.1

The merge merge request by Jens on Github is at:
https://github.com/ctron/mint-x-theme/commit/135f78193c17d51386c191f23ff11925b8714a61

kenden (kenden) wrote :

The fix still works on Mint 16 Cinnamon and Eclipse 4.3.2.
See attached screenshots:
Mint_16_Cinnamon_eclipse_4.3.2_bug.png
Mint_16_Cinnamon_eclipse_4.3.2_with_fix.png

kenden (kenden) wrote :
chemicalfan (mike-lumsden) wrote :

What happened to the previous pull request? I think this bug should be re-raised on the Cinnamon bug tracker

Kevin Peters (peterskm) wrote :

It looks like this fix no longer works in Mint 17 Cinnamon. It was working when I first installed Mint 17, but a recent update has prevented this fix from working.

Peter Roos (roospeteristvan) wrote :

@Kevin Peters

I have a fully updated Linux Mint 17 64bit installation. I found this launchpad bug today, as a result of googling about eclipse's ugliness in LM. I applied the fix, and it worked, even after updating my system.
I think that while you updated your system, the gtkrc file was updated to a new version, without this fix. So my recommendation is to re-apply the fix to gtkrc.

Peter Roos (roospeteristvan) wrote :

I do not have any experiences in GTK theming (I tried out a few from noobslab.com, but that's all).
What I see in this case, is that out of the box, Eclipse on Linux Mint 17 is very ugly. Appying the fix from Jens Reimann makes Eclipse look just as good as on any other distributions I have used before.
Based on these information, I concluded that this is a bug in the Mint-X theme. However, I really do not understand, how on earth can it happen, that this solution has been here for more then a year, and not land in Mint's repositories.

Peter Roos (roospeteristvan) wrote :

Hint for Eclipse users: Try out this fix combined with Jeeeyul's Themes 2.1.6 (you can find it in the Eclipse Market Place). Download the current release from GitHub (https://github.com/jeeeyul/eclipse-themes/), which contains theme presets (eclipse-themes / net.jeeeyul.eclipse.themes / presets /). The 'Retro' one makes Eclipse look really professional.

Kevin Peters (peterskm) wrote :

@Peter Roos

I think the issue I am having is due to the fact that I am running Eclipse Kepler. It appears it may be using the GTK3 theming which is css based and not such a simple fix as proposed above. I am also using the Jeeeyul Theme plug in which makes things look better, but I am still stuck with a background color/image/gradient on the toolbar buttons that I can't seem to get rid of.

Peter Roos (roospeteristvan) wrote :

@ Kevin Peters

I tested this workaround with Eclipse Keples and Luna. It worked with both.

Kevin Peters (peterskm) wrote :

@Peter Roos

Thanks for sticking with me. Looks like I missed that last line...

widget "*swt*toolbar-flat" style "null"

Now I'm good. I wish they would just patch this already.

Jens Reimann (ctron) wrote :

I just saw that after the upgrade gtk application complained that the "Null/null.png" could not be found anymore. The new file in Linux Mint 17 seems to be:

file = "images/other/null.png"

It still works, even with the wrong image. However after the upgrade (which is not officially supported by Mint) I also had to re-apply the changes.

I was also annoyed by the dark background of the list boxes. However also this can be changed easily by changing the line (in the top of the same file):

FROM:
    gtk_color_scheme = "bg_color:#d6d6d6\nselected_bg_color:#9ab87c\nbase_color:#F7F7F7" # Background, base.

TO:
   gtk_color_scheme = "bg_color:#d6d6d6\nselected_bg_color:#9ab87c\nbase_color:#FFFFFF"

Peter Roos (roospeteristvan) wrote :

Why is this patch not officially supported by Mint? Does it need comprehensive testing?

Jens Reimann (ctron) wrote :

If you ask me, I have no clue!

Again I've had to spend some time adjusting Scala-IDE tabs and backgrounds, and now my ~/.gtkrc-2.0 looks like this

style "gtkcompact" {
 GtkButton::default_border={0,0,0,0}
 GtkButton::default_outside_border={0,0,0,0}
 GtkButtonBox::child_min_width=0
 GtkButtonBox::child_min_heigth=0
 GtkButtonBox::child_internal_pad_x=0
 GtkButtonBox::child_internal_pad_y=0
 GtkMenu::vertical-padding=1
 GtkMenuBar::internal_padding=0
 GtkMenuItem::horizontal_padding=4
 GtkToolbar::internal-padding=0
 GtkToolbar::space-size=0
 GtkOptionMenu::indicator_size=0
 GtkOptionMenu::indicator_spacing=0
 GtkPaned::handle_size=4
 GtkRange::trough_border=0
 GtkRange::stepper_spacing=0
 GtkScale::value_spacing=0
 GtkScrolledWindow::scrollbar_spacing=0
 GtkTreeView::vertical-separator=0
 GtkTreeView::horizontal-separator=0
 GtkTreeView::fixed-height-mode=TRUE
 GtkWidget::focus_padding=0
}

class "GtkWidget" style "gtkcompact"

style "null"
{
 engine "pixmap"
 {
 image
  {
   function = BOX
   file = "images/other/null.png"
   stretch = TRUE
  }
 }
}

widget "*swt*toolbar-flat" style "null"

Thanks, this was added to the roadmap for Mint 17.1

Fixed in mint-themes 1.3.9.

Changed in linuxmint:
status: New → Fix Released
gumbeto (gumbeto) wrote :

In my case, this fix, improves the situation, but does not fix it completely. My eclipse now looks like the attached image (before, it looked like this: http://postimg.org/image/7wy2s1mff/)

As you can see, however, there is still a strange white surface in many places. It looks like some color definition is missing for some widget or graphical component type. Any ideas how to fix that within the GTK theme?

gumbeto (gumbeto) wrote :

I managed to get something acceptable by installing "Jeeeyul's Themes", as earlier suggested, and tweaking its colors, plus the following .gtkrc-2.0:

style "gtkcompact" {
font_name="Liberation Sans 9"
GtkMenuItem::horizontal-padding=2
}

class "GtkWidget" style "gtkcompact"
style "gtkcompactextra" {
xthickness=2
ythickness=1
}
class "GtkButton" style "gtkcompactextra"
class "GtkToolbar" style "gtkcompactextra"
class "GtkPaned" style "gtkcompactextra"

I would share Jeeeyul's Themes' settings, but don't know how to export them.

Screenshot of the resulting look is attached

Jens Reimann (ctron) wrote :

That's not a bug, that's a feature ;-)

gumbeto (gumbeto) wrote :

You can certainly make that case, after all it is quite hard to argue that using a particular color constitutes a bug. But I still think it looks bad by default - as I said, it looks like missing color definitions - and personally I would like to see a better look by default. In any case, I thought my modifications could be useful to others.

By the way, do you know if this "feature" is particular to mint?

Jens Reimann (ctron) wrote :

Well I guess you can argue a lot about style and Eclipse in general. However this is how Eclipse E4 looks like. As far as I know, this is intended to look like that.

You still have a theme manager in Eclipse, if you are not satisfied with the default (Eclipse) theme. I guess the basic idea is to move away from what the operating system provides, and do it in a "Eclipse style".

Wheter or not you like it (I don't), this is nor an issue of Mint.

You are right, I just searched a few screenshots and the blank elements are
there across OSes, so they are clearly intentional. I thought that look was
particular to Linux Mint. It looks strange enough that I thought there was
a problem. Sorry for the confusion.

On Wed, Nov 12, 2014 at 5:45 PM, Jens Reimann <email address hidden>
wrote:

> Well I guess you can argue a lot about style and Eclipse in general.
> However this is how Eclipse E4 looks like. As far as I know, this is
> intended to look like that.
>
> You still have a theme manager in Eclipse, if you are not satisfied with
> the default (Eclipse) theme. I guess the basic idea is to move away from
> what the operating system provides, and do it in a "Eclipse style".
>
> Wheter or not you like it (I don't), this is nor an issue of Mint.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1168281
>
> Title:
> Mint-X theme causes problems with Eclipse
>
> Status in The Linux Mint Distribution:
> Fix Released
>
> Bug description:
> Using the Mint-X theme and Eclipse causes minor visual corruptions
> with Eclipse. It seems as if the Toolbar's background is always drawn,
> although it should be transparent (inherit from parent) sometimes.
> Switching to the "Adwaita" GTK themes solves the issue, although it
> does not look as good as the Mint-X theme.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/linuxmint/+bug/1168281/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers