[cinnamon] Cinnamon Menu not working properly

Bug #1081842 reported by Cristhian Suematsu on 2012-11-22
152
This bug affects 30 people
Affects Status Importance Assigned to Milestone
Linux Mint
Fix Released
Undecided
Unassigned
Arch Linux
Fix Committed
Undecided
Unassigned
Ubuntu
Undecided
Unassigned

Bug Description

Linux Mint 14 Nadia MATE x64 Edition
Cinnamon 1.6.7 installed from the default repositories

When I start a Cinnamon session (version 1.6.7), the Cinnamon Menu doesn't behave as expected.
- The keyboard shortcut doesn't open it, although I can still open it with mouse clicks.
- Hovering the mouse over the categories doesn't filter the apps. Although I can stil type in the search box to filter them.
- Right-clicking Cinnamon Menu doesn't show the context menu with edit and settings options.

After restarting Cinnamon a couple of times, the menu starts working as expected.

Cristhian Suematsu (suematsu01) wrote :

UPDATE: Tried Linux Mint 14 Nadia Cinnamon x64 Edition. Same issue.

I noticed that in the Live CD Session and right after installing Mint 14 on my laptop, Cinnamon Menu behaves as expected. However, after installing a few apps and then rebooting the machine, the problem appears.

Colin Brace (cbrace) wrote :

I am seeing this as well after a fresh install of Cinnamon x64.

spontex (spontex) wrote :

Same here under Mint 14 Nadia. Perhaps is it due to some config files hidden inside the user profile, which were used under Mint 13 and would be incompatible with Mint 14 ?
I tried to remove ~/.gnome2 and ~÷.gnome2_private but it did not help.
Any idea?

Chris House (chrishouse83) wrote :

I'm experiencing this bug as well. I'm unable to hover over the categories and I'm also unable to type in the search box. I installed Mint 14 x64 Cinnamon Edition a couple weeks ago and this bug only showed itself yesterday. The first few times it went away when I restarted Cinnamon, but would reappear on reboot. But now restarting Cinnamon does nothing. When I run Cinnamon via the terminal I see JS errors whenever I hover over menu items.

Stuart (djflunk) wrote :

I have exactly the same issue. For the first few days using Mint 14 x64 cinnamon edition I was able to log out and restart cinnamon and the menu worked correctly, but this no longer helps.
I can still access 'All Applications' and left/right click still works as expected, but I can not select categories to filter the applications and mouse hovering does not highlight my choice.

Michael Webster (miketwebster) wrote :

Any chance we could get some log output on this?

From terminal:

cinnamon --replace

Then try to do some things in the menu, pastebin the log or paste here

Chris House (chrishouse83) wrote :
Download full text (4.6 KiB)

Sure. This is starting Cinnamon, clicking menu, and hovering over a few icons:

      JS LOG: About to start Cinnamon
Window manager warning: Log level 16: Unable to register authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject
Window manager warning: Log level 16: Error registering polkit authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject (polkit-error-quark 0)
      JS LOG: Cinnamon started at Tue Dec 04 2012 18:36:09 GMT-0600 (CST)
      JS LOG: network applet: Cannot find connection for active (or connection cannot be read)
Window manager warning: Log level 16: STACK_OP_REMOVE: window 0x295 not in stack
      JS LOG: network applet: Found connection for active

(cinnamon:2658): St-WARNING **: Did not find color property '-arrow-border-color'

(cinnamon:2658): St-WARNING **: Did not find color property '-arrow-background-color'

(cinnamon:2658): St-WARNING **: Did not find color property '-gradient-start'

(cinnamon:2658): St-WARNING **: Did not find color property '-gradient-end'
    JS ERROR: !!! Exception was: TypeError: this.selectedAppTitle is undefined
    JS ERROR: !!! message = '"this.selectedAppTitle is undefined"'
    JS ERROR: !!! fileName = '"/<email address hidden>/applet.js"'
    JS ERROR: !!! lineNumber = '1197'
    JS ERROR: !!! stack = '"([object _private_Cinnamon_GenericContainer],[object _private_Clutter_Event])@/<email address hidden>/applet.js:1197
"'
    JS ERROR: !!! Exception was: TypeError: this.selectedAppTitle is undefined
    JS ERROR: !!! message = '"this.selectedAppTitle is undefined"'
    JS ERROR: !!! fileName = '"/<email address hidden>/applet.js"'
    JS ERROR: !!! lineNumber = '1202'
    JS ERROR: !!! stack = '"([object _private_Cinnamon_GenericContainer],[object _private_Clutter_Event])@/<email address hidden>/applet.js:1202
"'
    JS ERROR: !!! Exception was: TypeError: parent._vis_iter is undefined
    JS ERROR: !!! message = '"parent._vis_iter is undefined"'
    JS ERROR: !!! fileName = '"/<email address hidden>/applet.js"'
    JS ERROR: !!! lineNumber = '926'
    JS ERROR: !!! stack = '"([object _private_Cinnamon_GenericContainer],[object _private_Clutter_Event])@/<email address hidden>/applet.js:926
"'
    JS ERROR: !!! Exception was: TypeError: parent._vis_iter is undefined
    JS ERROR: !!! message = '"parent._vis_iter is undefined"'
    JS ERROR: !!! fileName = '"/<email address hidden>/applet.js"'
    JS ERROR: !!! lineNumber = '926'
    JS ERROR: !!! stack = '"([object _private_Cinnamon_GenericContainer],[object _private_Clutter_Event])@/<email address hidden>/applet.js:926
"'
    JS ERROR: !!! Exception was: TypeError: parent._vis_iter is undefined
    JS ERROR: !!! message = '"parent._vis_iter is undefined"'
    JS ERROR: !!! fileName = '"/usr/share/cinnamon/applets/menu@ci...

Read more...

Cristhian Suematsu (suematsu01) wrote :

Same errors reported in comment #7 here.

Also, if pushing the shorcutkey (win/super key) after opening the menu with a mouse click, I get the following:

  JS ERROR: !!! Exception was: TypeError: this.appBoxIter is undefined
    JS ERROR: !!! message = '"this.appBoxIter is undefined"'
    JS ERROR: !!! fileName = '"/<email address hidden>/applet.js"'
    JS ERROR: !!! lineNumber = '851'
    JS ERROR: !!! stack = '"([object _private_St_IMText],[object _private_Clutter_Event])@/<email address hidden>/applet.js:851
"'
    JS ERROR: !!! Exception was: TypeError: this.appBoxIter is undefined
    JS ERROR: !!! message = '"this.appBoxIter is undefined"'
    JS ERROR: !!! fileName = '"/<email address hidden>/applet.js"'
    JS ERROR: !!! lineNumber = '851'
    JS ERROR: !!! stack = '"([object _private_St_IMText],[object _private_Clutter_Event])@/<email address hidden>/applet.js:851
"'
    JS ERROR: !!! Exception was: TypeError: this.appBoxIter is undefined
    JS ERROR: !!! message = '"this.appBoxIter is undefined"'
    JS ERROR: !!! fileName = '"/<email address hidden>/applet.js"'
    JS ERROR: !!! lineNumber = '851'
    JS ERROR: !!! stack = '"([object _private_St_IMText],[object _private_Clutter_Event])@/<email address hidden>/applet.js:851
"'
    JS ERROR: !!! Exception was: TypeError: this.appBoxIter is undefined
    JS ERROR: !!! message = '"this.appBoxIter is undefined"'
    JS ERROR: !!! fileName = '"/<email address hidden>/applet.js"'
    JS ERROR: !!! lineNumber = '851'
    JS ERROR: !!! stack = '"([object _private_St_IMText],[object _private_Clutter_Event])@/<email address hidden>/applet.js:851
"'
    JS ERROR: !!! Exception in callback for signal: open-state-changed
    JS ERROR: !!! message = '"this.selectedAppTitle is undefined"'
    JS ERROR: !!! fileName = '"/<email address hidden>/applet.js"'
    JS ERROR: !!! lineNumber = '820'
    JS ERROR: !!! stack = '"([object Object],false)@/<email address hidden>/applet.js:820
_emit("open-state-changed",false)@/usr/share/gjs-1.0/signals.js:124
(true)@/usr/share/cinnamon/js/ui/popupMenu.js:1246
([object _private_St_Bin],[object _private_Clutter_Event])@/usr/share/cinnamon/js/ui/popupMenu.js:1189

Adding an attachment where I replaced Cinnamon for the second time, the menu started working properly (Pressed the win/super key to open the menu). Got no more errors when hovering the mouse over the apps' subcategories.

Zanahade (zanahade) wrote :

I am also seeing the same issue after migrating from Ubuntu 12.04

spontex (spontex) wrote :

It looks like I could fix this bug by resetting the Cinammon settings. I typed:
gsettings reset-recursively org.cinnamon

spontex (spontex) wrote :

I was wrong: after restarting, the bug is still there. When moving the mouse cursor over the main menu item, they do not highlight. Clicking on the categories does not open them.

spontex (spontex) wrote :

Any ideas about how we could try to solve this menu bug? It still makes Linux Mint 14 / Cinnamon unusable!

Hi,

We can't reproduce this problem. However, I can see there's something funny about the way this is coded. So we'll try a few things and we'll provide you with a build so you can tell us if we managed to get it fixed for you.

Thank you for your patience, feedback and your help.

Michael Webster (miketwebster) wrote :

I've attached a replacement applet file for the menu and would appreciate if those having the problems could give it a test drive.

Simply copy over the file (with sudo of course):

/<email address hidden>/applet.js

Thanks

spontex (spontex) wrote :

Hi,
Thank you for your concern. I tried to use this version of applet.js, without any success.

In order to see the logs, I restarted Cinnamon with cinnamon --replace.
I still have the same logs!

    JS ERROR: !!! Exception was: TypeError: parent._vis_iter is undefined
    JS ERROR: !!! message = '"parent._vis_iter is undefined"'
    JS ERROR: !!! fileName = '"/<email address hidden>/applet.js"'
    JS ERROR: !!! lineNumber = '925'
    JS ERROR: !!! stack = '"([object _private_Cinnamon_GenericContainer],[object _private_Clutter_Event])@/<email address hidden>/applet.js:925
"'
    JS ERROR: !!! Exception was: TypeError: parent._vis_iter is undefined
    JS ERROR: !!! message = '"parent._vis_iter is undefined"'
    JS ERROR: !!! fileName = '"/<email address hidden>/applet.js"'
    JS ERROR: !!! lineNumber = '925'
    JS ERROR: !!! stack = '"([object _private_Cinnamon_GenericContainer],[object _private_Clutter_Event])@/<email address hidden>/applet.js:925
"'
    JS ERROR: !!! Exception was: TypeError: parent._vis_iter is undefined
    JS ERROR: !!! message = '"parent._vis_iter is undefined"'
    JS ERROR: !!! fileName = '"/<email address hidden>/applet.js"'
    JS ERROR: !!! lineNumber = '925'
    JS ERROR: !!! stack = '"([object _private_Cinnamon_GenericContainer],[object _private_Clutter_Event])@/<email address hidden>/applet.js:925

Cinnamon usually works fine after I have restarted it two or three times. Then I can log out and log in and it still works. But everything is lost when I reboot: it still has the same problem, with the main menu items not being highlighted.

Michael Webster (miketwebster) wrote :

Mind trying once more? See attached.

Thanks

spontex (spontex) wrote :

Hi,
I still have the same problem. Attached is the log I got by launching cinnamon using:
cinnamon --replace 2>&1 | tee log_cinnamon.txt

I tried replacing the applet.js file with the latest version in this thread, to no avail. The log I got after replacing cinnamon through the terminal and using the menu is attached.

Strange thing: my hard disk have 2 NTFS partitions. I discovered that I need to mount one of them in Nemo before restarting Cinnamon in order to get the menu working properly. If I restart it without doing the first step, the menu still doesn't work. I Need to redo these steps every time I boot/reboot.

Greg Jones (bapride11) wrote :

Same report in Arch. Mounting a partition before restarting Cinnamon makes menu work properly. The partition need not be on the same physical disk, though. Menu persists working after dismount, but if restarting with it dismounted, the menu reverts to buggy behavior.

Ataul Munim (timberwo7ves) wrote :

+1 to Cristhian's and Greg's situation - I have an NTFS partition which needs mounting before Cinnamon is restarted before it'll behave correctly.
Linux Mint 14 x64, fresh install.

DavidFarmer (davidgsfarmer) wrote :

+1 to Greg and Ataul's NTFS observation. I added a logical NTFS partition which is part of the same extended partition as my /home partition to the fstab such that it mounts on boot. Super_L now opens the menu and the applications sort normally.

If you'd like to use this workaround, you can find out how to correctly edit /etc/fstab here: http://www.tuxfiles.org/linuxhelp/fstab.html

Michael Webster (miketwebster) wrote :

I just want to narrow down things a bit based on what's been learned here - if you can still reproduce this problem, try unchecking "Show bookmarks and places" in Cinnamon Settings -> Menu and restarting Cinnamon, and let me know if the problem persists.

Thanks

Richard Lobb (richard-lobb) wrote :

Yay! That fixes the problem for me. [I unchecked 'Show bookmarks and places' and the menu worked for the first time in months. I then re-checked it -- back to not-working state. Unchecked it again and the menus started working again.] Looking good :)

spontex (spontex) wrote :

Narrowed! After restarting the menu bug is not here anymore :-)
Thanks! I can now switch back from Gnome Classic to Cinnamon.

Ashraf Miah (ashraf-miah) wrote :

I can also confirm that I had the same symptoms as described for this bug report.

I can also confirm that the fix works. I unchecked "Show bookmarks and places" in the Cinnamon Settings; logged out and back in again and the menu is now working as expected.

Thanks to all.

Greg Jones (bapride11) wrote :

Workaround confirmed on Arch Linux running Cinnamon compiled from git repository, source code pulled on 01/14/2013. I no longer have the revision number I pulled, but I doubt this issue has changed much.

Vlatko Basic (vlatko.basic) wrote :

Workaround works on Ubuntu 12.04. However, I have no NTFS partitions, only several Ext4, fuse.extfs and a fuse.javafs mounts.
Other box has similar config, and has "Show bookmarks and places" checked, but this bug not occuring.

MF (mmuruev) wrote :

I have this issue too. --replace for cinnamon helps.

Kosyne (kaosjkm) wrote :

Using Ubuntu 13.04 with Cinnamon. Had the same issue (seemed to crop up after I set an NTFS partition to mount at startup).

Disabling bookmarks and places fixed it for me as well.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Chambead (chambead) wrote :

I have the same issue - 64-bit Nadia 14 with Cinnamon. Same error messages reported on cinnamon --replace. I have a handful of SMB auto-mounts that aren't always available. Going to Cinnamon Settings > Menu > Uncheck Places/Bookmarks fixed the bug for me. Restarted cinnamon once more and it all works again with super hot key and hover-clicks.

bzzt (stavros1) wrote :

Same issue here. Ubuntu 12.04 with Cinnamon.

Russell Smyth (jrussell-smyth) wrote :

+1 Same issue confirmed here, Linux Mint 14 Cinnamon. I do have NFS mounts, same error mesages, and uncheck Places/Bookmarks works around bug.

Michael Webster (miketwebster) wrote :

I've attached a new version of the menu applet's applet.js file - please don't try on less than Cinnamon 1.8.

Hopefully we can get this ironed out before final Mint 15/Cinnamon 1.8.x

Thanks

The attachment "replacement menu applet.js for Cinnamon 1.8+" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
pogo (paul-pogo) wrote :

After unchecking Places/Bookmarks the menu works as expected, but the search field in the menu is still not usable (I cannot type in).

I have a fresh Linux Mint 15 install (yesterday installed, DVD with all current updates applied) but kept the /home partition. Previously installed was Mint 14.

Raulo (raulo-olapodrido) wrote :

running on a fresh Mint 15 install here, albeit with a /home directory from a former LMDE install.

After replacing the file from post #38, categories get highlighted, but no applications show. Search field does not work: I can type, but nothing is found, categories only fade out.

After I renamed all directories ~/.gnome* to ~/.gnome*.bak, some more categories did show.

Output of cinnamon --replace 2>&1 | tee log_cinnamon.txt attached.

alidekker (x-albert) wrote :

Linux 15 with NVIDIA drivers
I was also confronted with the issue of not being able to use the categories.
I restarted Cinnamon to no avail but was then confronted with the shutdown window with the 60 seconds waiting and no other buttons than "Cancel".
It was also strange that Chromium did not want to start up (?!?)
Then went to the applets (rightclick panel), set panel-edit-mode to "on" and restarted Cinnamon and restarted the computer.
Mysteriously the Menu is working again and the Shutdown window is giving me again the options.

I do not want to repeat this becasue all now is working again and I do not want things to mess up.

ermacaz (ermacaz) wrote :

Had the same bug on a dual boot mint15/win7 system. Only occured when win7 was hybernated and partition could not be mounted in mint. Unchecking show bookmarks and places in menu options fixed the issue

Michael Webster (miketwebster) wrote :

Thanks for the info... I've got win7 on another partition, I'll try to reproduce - thus far I've been unable to really get to the bottom of this because I cannot reproduce it.

randomizer (randomizer) wrote :

I've noticed that I can reproduce this (the unresponsive categories, not the inability to filter with the search) by having a bookmark which is a symbolic link to a directory on an unmounted NTFS volume. I am highly unfamiliar with how the menu works, but it looks like it might have trouble with the icon. Commenting out "this.addActor(this.icon)" on line 390 of applet.js (the one currently in the repo build of Cinnamon 1.8) allows it to behave properly, albeit with a little less eye candy.

Roger Lipscombe (8-roger) wrote :

I can reproduce the following symptoms:
- Windows (Super_L) key doesn't bring up the menu.
- Right-clicking on the menu button does nothing.
- Search works, but I can't press Enter to select the result. It does nothing.
- Mouseover the categories does nothing.

Disabling places and bookmarks fixes it.

In my case, I have ~/Music as a symlink to /mounts/md0p1/Music (on an ext4 partition on an mdraid device), which doesn't automatically mount at boot time (and yes, I ought to fix that as well).

Ian Gustafson (iangustafson) wrote :

Also getting symptoms identical to what Roger listed above. My Music folder is also a symlink to a folder on a different partition that is not automatically mounted (and I also ought to fix that).

Changed in linuxmint:
status: New → Fix Committed
Changed in ubuntu:
status: Confirmed → Fix Committed
Changed in archlinux:
status: New → Fix Committed
Gerry Sackett (gerrysackett) wrote :

I had a similar issue with a Win7/Mint 15 Cinnamon 64-bit dual boot with an automounted ntfs partition. I also noticed a slight lag between clicking the menu button and the menu actually loading.

Unchecking "Bookmarks and Places" fixed it.

Did some more investigating and found a few broken links to folders on the automounted ntfs partition that no longer existed. I deleted the broken links from the home folder and re-checked "Bookmarks and Places" under menu settings. That fixed it completely including the slight lag!

My guess is that linking to an unmounted partition or in my case a broken link is the root of the bug.

Jordan Farrell (feralbytes) wrote :

Linux Mint 15 64 bit Dual Boot with lots of extra drives. "I unchecked 'Show bookmarks and places' and the menu worked for the first time in months." also fixed the problem. Seems like show bookmarks plugin is broken and may need to be disabled by default until the fix hits main line.

Changed in linuxmint:
status: Fix Committed → Fix Released
Changed in ubuntu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers