Linux Mint Keyboard Shortcut

Bug #1077930 reported by Colin Mills on 2012-11-12
240
This bug affects 45 people
Affects Status Importance Assigned to Milestone
Linux Mint
Confirmed
Undecided
Unassigned

Bug Description

Lininux Mint 14rc Cinnamon. Unable to set custom shortcuts.

Open Cinnamon Settings -> Keyboard -> Keyboard Shortcuts
Select 'add custom shortcut' and add ad a shortcut (I used xkill), but the bug exists when trying to add any shortcut. Select the shortcut key and restsrt the system.
Try the shortcut keys. and you will find they have no effect.

Please note that this bug only present on custom shortcuts, other shortcuts are fine.

mati (mati-wroc) wrote :

Confirming - tried to bind Alt-a combination to gedit, no effect.

Freshly installed Mint 14 Cinnamon 64-bit, Polish language.

Changed in linuxmint:
status: New → Confirmed
Yota (me-michaschwab) wrote :

cant really do much without shortcuts, come on please!

Ben Lowery (ben-chgtaa3qpp07u) wrote :

Confirmed, attempted multiple shortcut's with multiple applications.

Pretty catastrophic for my workflow as I use synapse for pretty much everything, will have to revert back to XFCE till this one gets fixed :|.

Nathan Bordegaray (nbordega) wrote :

Confirmed as well after attempting multiple custom shortcuts with several applications.

I think that this might be a bug involving upsream issues with Ubuntu's Gnome configurations. I booted a live CD of Cinnarch, and I was able to set custom keyboard shortcuts without a problem.

Colin Mills (cm006a5077) wrote :

I notice that this bug is still labelled 'Undecided' and 'Unassigned'. I hope that this bug will be decided and assigned in the near future as I find this bug a bit of a show stopper.

Chonnawonga (brad-meredith) wrote :

I'm using xbindkeys as a workaround, but it's not a very accessible solution for the average user.

Ben Lowery (ben-chgtaa3qpp07u) wrote :

Thank you for mentioning xbindkeys that may be a workable if not elegant temporary solution for my personal laptop, sticking with 13/XFCE on the work machines for now though.

Colin Mills (cm006a5077) wrote :

Thanks forthe tip about xbindkeys. I was able to install my shortcut keys using this workaround. For any body else interested in using xbindkeys, there is a most informative article here;
http://aplawrence.com/Girish/xbindkeys.html

exleper (exleper) wrote :

its also impossible to unassigned the premade shortcuts, it says unassigned but its still assigned. and i wanna
RE-assign certain shortcuts, thus xbindkeys wont work for me, as it will result in 2 actions - the one i assigned with xbidkeys and the 'hardcoded' one

Yota (me-michaschwab) wrote :

thanks Chonnawonga and Colin Mills!

Larry Bushey (goinglinux) wrote :

Installed Mint 14 Cinnamon after official release. Confirming that this issue is still present.

electrickite (coreyhinshaw) wrote :

Confirmed this bug on a fresh install of Mint 14 Nadia Cinnamon 64bit.

Note: This only occurs when using the Keyboad settings in the Cinnamon Settings application. I added the Keyboard settings panel back to System Settings (GNOME control center) and creating custom key bindings from there works just fine.

Colin Mills (cm006a5077) wrote :

Sounds like a great idea. Could you let me know how to add the Keyboard settings panel back to System Settings? Thanks

habtool (clive-wagenaar) wrote :

This post works for adding keyboard settings back:

http://forums.linuxmint.com/viewtopic.php?f=208&t=117585&start=20#p655476

Michael Webster (miketwebster) wrote :

Fix pending for Cinnamon-settings:

https://github.com/linuxmint/Cinnamon/pull/1405

Though now that Ubuntu and Gnome-C-C are once again on the same page, it may be simpler from a maintenance standpoint to re-add the gnome keyboard module.

Charlie Bruce (cbruce8) wrote :

Habtool's proposed workaround did not work for me on fresh install of Mint 14.0, fyi.

Ryan Jacobs (ryan-mjacobs) wrote :

Confirmed on Linux Mint 14 Cinnamon 64-bit with English.

sofasufi (sofasufi) wrote :

Custom shortcuts not working on my 32bit Mint 13 Cinnamon install - I have backported to receive the Cinnamon updates, but the problem persists. Standard shortcuts are working fine.

Confirming - no custom shortcuts work for me on fresh install of Mint 14.1 64-bit Cinnamon. This is a nasty one, but an otherwise near-perfect user experience.

Confirming - Really bums me out, Trying to use my imgur print screen uploader...

Changed in linuxmint:
status: Confirmed → Fix Committed

Thanks for the update on the 7th of March, Clement, but I feel it best to also Confirm the issue that Custom shortcuts are not working on my 32bit Linux Mint 14 installation (with all possible Update presently installed).

NOTE: With the exception of Ctrl-Alt-t (Launch Terminal) which does work, but comes as a pre-configured, Custom shortcut. No user-defined shortcuts appear to work.

Kyle Hird (k-hird) wrote :

This issue exists in a fresh 64-bit install of Mint 14, as well as with all updates installed.

rabie (jradi88) wrote :

I still have this issue with 64-bit linux mint cinnamon 14. All updates are installed

rabie (jradi88) wrote :

I forgot to mention that my custom shortcuts works if only I press it several times in a row, but if I press it once it doesn't work. As an example I have added the shortcut "super+3" for the command "nemo". I see that the bug has been marked as fixed, so will I just have to be patient and wait for the update to be available in the update manager application?

Ville Ranki (ville-ranki) wrote :

I think this bug still exists in Cinnamon 2.0.6 on Ubuntu Saucy. I'm trying to bind "pause" key to play/pause media playback and it does not work.

immortel (immortel32) wrote :

I got the same problem on Linux Mint 16 cinnamon 64 bits in French.

I tried to set "shutter --select" to Print or to Alt-Print. It does not work.

Peter M. Clausen (pclausen) wrote :

Also confirmed in Cinnamon 2.0.14 (Ubuntu 12.04.3 LTS)

Was trying to set keys for changing Desktop, e.g F8=Desktop 1. Did not work.

Alexey (alexey-egoshin12) wrote :

I got the same problem on Linux Mint 16 cinnamon 64 bits (Russia). Set custom shortcuts for Volume up/down/mute after turn off pulseaudio. After reboot keys don't work.

TraceyC (grrlgeek) wrote :

The problem still exists in Linux Mint 17 (Qiana). I have the 64 bit distribution installed.
This bug is not fixed.

TraceyC (grrlgeek) wrote :

After some troubleshooting, and searching the forums, I discovered that *if I press the custom key combination a few times* then the action will trigger. It never triggers on the first keypress.

TobiasGWV (tobias-verhulst) wrote :

I can confirm TraceyC's finding: hitting the combination twice seems to work.

Matt (mattcbro) wrote :

I'm on linux mint 17 as well, and I've noticed that applications that rely on keyboard commands like gnome-commander or sunflower simply ignore any key typing altogether. I presume this bug is related or should it be in another bug report? This seems to be a new phenomenon.

Confirming this on a fresh install of linux mint 17.

Changing shortcuts from system settings->keyboard->shortcuts does nothing.

Changed in linuxmint:
status: Fix Committed → Confirmed
Mentallurg (mentallurg) wrote :

Mint 17, 64 bit.
Keyboard Layout: German (eliminate dead keys).

1. Fresh install, plus all current updates. Ctrl-Alt-t doesn't work. Ctrl-Alt-t doesn't do any action at all.

2. Press Ctrl-Alt-l. It locks the screen, which is correct.

3. Create custom shortcut via Keyboard -> Keyboard shortcuts -> Custom Shortcuts.
    Create a custom shortcut for gnome-terminal.
    Here occur several problems.
    a) When assigning a shortcut, press Ctrl-Alt-t. The displayed shortcut will be Ctrl-Alt_L. That is wrong.
        When I press Ctrl-Alt-q, or Ctrl-Alt-w, or Ctrl-Alt-q, they assigned shortcut is correctly displayed as Ctrl-Alt-q, Ctrl-Alt-w, or Ctrl-Alt-e. The wrong shortcut is displayed for Ctrl-Alt-t only.

    b) After assigning Ctrl-Alt-t, press Ctrl-Alt-t. This works. gnome-terminal will be started.
        After pressing Ctrl-Alt-l the same action is triggered as Ctrl-Alt-t, and gnome-terminal is launched again.
        Screen lock that was assigned to Ctrl-Alt-l now will not be triggered.

    c) After removing custom shortcut Ctrl-Alt-t from the list both Ctrl-Alt-t and Ctrl-Alt-l will be removed. Ctrl-Alt-t will again don't trigger any action. Ctrl-Alt-l will again trigger Screen Lock.

It seems that when assigning a custom shortcut the Ctrl-Alt-t is somehow interpreted twice: first as Ctrl-Alt-t, then as Ctrl-Alt-l.

Roger Lawhorn (rll-m) wrote :

Linux Mint 17.3 64bit

Custom Shortcut not working.

Test

Keyboard shorcut = date | xsel --clipboard
Purpose = paste current date and time into the clipboard
Works from shell.

Bind to CTRL-ALT-b (CTRL-ALT-t was taken for terminal)

Never works. Binding to any other combo does not work.
Custom shortcuts is broken.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers