Grub 2 update install bug

Bug #1064483 reported by Dr Guy Simmons on 2012-10-09
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux Mint
Invalid
High
Unassigned

Bug Description

During the latest run of updating Xubuntu and Kubuntu, an update for grub 2 is downloaded and I am asked to choose my install location, which in my case is /dev/sda1.

This is listed incorrectly as '-/dev/sda1/' and the install fails.

Kubuntu 12.04
Xubuntu 12.04
---
ApportVersion: 2.0.1-0ubuntu13
Architecture: amd64
DistroRelease: LinuxMint 13
InstallationMedia: Linux Mint 13 "Maya" - Release amd64 (20120520)
Package: grub2 (not installed)
ProcEnviron:
 TERM=xterm
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 3.2.0-31.50-generic 3.2.28
Tags: maya
Uname: Linux 3.2.0-31-generic x86_64
UnreportableReason: This is not an official LinuxMint package. Please remove any third party package and try again.
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Thomas Ward (teward) wrote :

I believe, given the information in the bug, that this is a bug that needs to be filed against `grub2`. I've set that accordingly.

affects: ubuntu → grub2 (Ubuntu)
Dmitry Shachnev (mitya57) wrote :

Thank you for reporting this. Is this happening on a release upgrade or on a precise->precise upgrade? Did you change any hardware configuration before you got this? Also, can you please run "apport-collect 1064483" in the Terminal to get some more information attached here?

Changed in grub2 (Ubuntu):
status: New → Incomplete
importance: Undecided → High
Dr Guy Simmons (guysim) wrote :

Hi,

This has happened on three different PCs on over 12 Ubuntu-based installs (Kubuntu, Xubuntu, and three spins of Mint v13 were involved). There were no changes to the hardware before this. I was just performing a normal software update.

I had been on holiday for 10 days and just returned so updated my Linuxes. The error occurred when the Grub 2 update asked for the original install location. On all my setups it is /dev/sda1 and on no install was this accepted for the reason mentioned.

Please let me know if you still want any further information.

Regards

DrT

Dmitry Shachnev (mitya57) wrote :

It would still be good if you ran "apport-collect 1064483" on one of your machines.

Dr Guy Simmons (guysim) on 2012-10-13
tags: added: apport-collected maya
description: updated
Dr Guy Simmons (guysim) wrote :

I sent the report to developers and I have attached it to this message

Changed in grub2 (Ubuntu):
status: Incomplete → New
C de-Avillez (hggdh2) wrote :

Unfortunately, the data collection failed. I am settting this bug, again, as Incomplete.

@Dr Guy Simmons: please re-run apport-collect from a kubuntu/xubuntu system, instead of Mint. For whatever reason -- I do not run Mint -- Mint considers Grub2 not an official package.

Also: how did you run the upgrades? Where did the updated packages come from?

Changed in grub2 (Ubuntu):
status: New → Incomplete
C de-Avillez (hggdh2) wrote :

Moving to LinuxMint, until proved to occur on Ubuntu.

affects: grub2 (Ubuntu) → linuxmint
chemicalfan (mike-lumsden) wrote :

Does this bug apply to any of the currently supported releases (i.e. Maya, Nadia, Olivia, or Petra)? If not, this bug should be closed.

chemicalfan (mike-lumsden) wrote :

As OP has failed to update this bug, and it doesn't affect anyone else, I am marking as invalid

Changed in linuxmint:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers