Mate desktop breaks vino

Bug #1007910 reported by taylorkh on 2012-06-02
46
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Linux Mint
Undecided
Unassigned

Bug Description

Mint 13 Mate 32 bit

Remote desktop sharing has been enabled using vino-preferences. The desktop cannot be accessed using Remote Desktop Viewer 2.30.2 on Ubuntu 10.04. The message "Connection closed. Connection to host 192.168.0.102 was closed" appears when I attempt to connect to the Mint Mate machine.

n.b. Mint 13 Cinnamon when installed and configured the same way with vino-preferences can be accessed with no problems.

Ubuntu 12.04 with Mate installed on top of Ubuntu can be accessed if running in Ubuntu or Ubuntu 2D session (from the login screen). If the Mate session is selected the machine cannot be accessed.

It appears that the Mate desktop/environment is at fault.

Goran Adevik (gorade) wrote :

Same thing happens to me, only that I didn't try Cinnamon.

Vlado Music (vladoalma) wrote :

Same problem with my machine.

Same here. Cinnamon works ok. Mate worked fine on LM12 before I upgraded.

Jamie Morgan (falsechicken) wrote :

I too am having this issue. I simply cannot connect. I checked the preferences and ran an nmap scan and it appears the server is not even running. Its also checked in my startup applications.

The same problem on Mint 13 64bit MATE...

Dominik (dominalien) wrote :

Same here on MInt 13 32-bit with Mate.

Also, for some reason I get no way to access the vino config from the control center or the menu (no shortcuts). I have to invoke vino-preferences from the terminal. Still doesn't work.

Same here. Running this from the terminal makes vino work for me:

/usr/lib/vino/vino-server --sm-disable

Peter Horsley (peter-g-horsley) wrote :

I can confirm that this issue is still present in Mint 15 with Mate (Mint 15 with Cinnamon works fine). And I can also confirm that the fix / workaround in comment #8 does work, thanks Andy.

vino no longer has "sm-disable" (run: /usr/lib/vino/vino-server --help-all) (at least in my "olivia" installation).
So changing (in control center startup programs) the command line to:
/usr/lib/vino/vino-server --sm-client-disable
might do the trick (in case there are no other problems.
aka if from command line /usr/lib/vino/vino-server --sm-client-disable does not return "critical"'s or "WARNING"'s).

Peter Carless (petercarless) wrote :

Just been trying Mate on Petra (16) and this still appears to be an issue (Cinnamon works ok).
Tried xoristzatziki's suggestion but I can't get it to work.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers