Linux DC++ moves user directories to .dc++/Filelists

Bug #879475 reported by sampattuzzi on 2011-10-21
54
This bug affects 10 people
Affects Status Importance Assigned to Milestone
LinuxDC++
High
Unassigned

Bug Description

I can fully reproduce this bug every time. It started occurring after I did a download to my Music directory directly. I noticed the problem when the Music directory disappeared completely, it wasn't in the deleted files or anywhere to be found. Now the problem repeats itself, if I put anything in the Music directory and LinuxDC++ is running - I haven't yet worked out the trigger but it might be asking LinuxDC++ to download a file - it deletes the contents of the directory. This bug is severe! Fortunately I had backups of my music but others might not be so lucky!

If you can think of any tests I should run then please let me know.

Sergey Basalaev (sbasalaev) wrote :

Oh my! So THAT'S the reason my Music directory disappeared? I'll try to reproduce it now

Steven Sheehy (steven-sheehy) wrote :

What version are you using? Did you recently upgrade versions (either manually or by using a newer OS)?

There are multiple ways to get a download to its intended directory. Did you set the default finished and/or the unfinished downloads folder in the preferences to your music folder? Or did you set a favorite download directory and use that? Or did you manually browse to the music folder when you were downloading?

Please provide your DCPlusPlus.xml preferences file and the <FavoriteDirs> section of your Favorites.xml.

Changed in linuxdcpp:
status: New → Incomplete
Sergey Basalaev (sbasalaev) wrote :

Personally, I've got updated to Oneiric recently so linuxdcpp was the least I suspected because its version stood the same. And I was unable to reproduce this bug. Sam, can you describe step by step what needs to be done for this bug to happen?

plitter (odnehel) wrote :

I have encountered something similar, but it was not deleted. I found my folder(s) in the hidden folder .dc++ where it stores its filelists. Try searching there for your files. In my case it was in $HOME/.dc++/FileLists/bobmarley.K4BIUCR2PSQKDNXUYOYY7WP62UV4JITRTCJRTRA

My settings:
* Finished downloads: /path/to/chosen/directory
* Unfinished downloads: $home/.dc++

I use Arch Linux.

I tried to reproduce, but for me it seems like it happens randomly, I will update if I it happens again and I can narrow it down. It has happened around 5 times I think. So it's an annoying bug

Sergey Basalaev (sbasalaev) wrote :

Thanks, ~odnehel, it is really there.
I have the whole music folder in ~/.dc++/FileLists/sdfghjmk.MTUXC7KKQP47ZW7K6JM43SW4LU752YYSA6YF2KI and there is also a copy of another shared folder (which was not deleted) in /home/sbasalaev/.dc++/FileLists/acidGREEN.S4WA6TEBMJFAG4DJ5BKW37SBLU2YDWXNU7SS67A/
This behaviour is really strange.

My download settings:
- Finished: ~/Downloads
- Unfinished: ~/.dc++/

I'm using linuxdcpp from daily repository

Sergey Basalaev (sbasalaev) wrote :

Correction:
 - Unfinished: ~/.dc++/Incomplete

And another folder was moved there, not copied.

Steven Sheehy (steven-sheehy) wrote :

Please provide the exact output of the following commands:

grep "<Directory " ~/.dc++/Favorites.xml
grep "DownloadDirectory" ~/.dc++/DCPlusPlus.xml

Sergey Basalaev (sbasalaev) wrote :

Favorites (in ~/.dc++/Favorites.xml):
 <FavoriteDirs>
  <Directory Name="Музыка разобрать">/home/sbasalaev/Музыка разобрать/</Directory>
 </FavoriteDirs>

Download directories (in ~/.dc++/DCPlusPlus.xml):
 <DownloadDirectory type="string">/home/sbasalaev/Загрузки/</DownloadDirectory>
 <TempDownloadDirectory type="string">/home/sbasalaev/.dc++/Incomplete/</TempDownloadDirectory>

Shared directories (in ~/.dc++/DCPlusPlus.xml):
 <Share>
  <Directory Virtual="Музыка">/home/sbasalaev/Музыка/</Directory>
  <Directory Virtual="Книги">/home/sbasalaev/Книги/</Directory>
  <Directory Virtual="JRPG">/home/sbasalaev/JRPG/</Directory>
  <Directory Virtual="семестры">/home/sbasalaev/Рабочий стол/семестры/</Directory>
 </Share>

Shared folders that were accidentally moved are "Музыка" and "JRPG".

sampattuzzi (sam-pattuzzi) wrote :

[sam@vimes ~]$ grep "<Directory " ~/.dc++/Favorites.xml
[sam@vimes ~]$ grep "DownloadDirectory" ~/.dc++/DCPlusPlus.xml
  <DownloadDirectory type="string">/media/3479cbb2-d7e5-425d-8e97-714dfc08d084/Camdc/</DownloadDirectory>
  <TempDownloadDirectory type="string">/home/sam/.dc++/Incomplete/</TempDownloadDirectory>

That's all there was for me.

plitter (odnehel) wrote :

 $ grep "<Directory " ~/.dc++/Favorites.xml
 $ grep "DownloadDirectory" ~/.dc++/DCPlusPlus.xml
                <DownloadDirectory type="string">/home/plitter/Share/</DownloadDirectory>
                <TempDownloadDirectory type="string">/home/plitter/.dc++/</TempDownloadDirectory>

This is what was shown for me

Steven Sheehy (steven-sheehy) wrote :

plitter: You shouldn't be using the .dc++ folder for your temp downloads. I recommend switching to a subdir like/home/plitter/.dc++/Incomplete/

sampattuzzi: Are you experiencing the same issue as the others with the shared folder being moved to ~/.dc++/FileLists/<filelist name>/ ?

Steven Sheehy (steven-sheehy) wrote :

This might be due to DC++ bug #551184. Specifically the comment from eMTee which I can confirm can happen:

"Problem is that if the remote path is coincidently exists locally (absolute or relative) it can trigger an unneeded move operation of a complete local folder..."

Can anyone confirm if this occurs when you choose "Browse file list" on the right click menu of a search result? It looks like it attempts to execute the equivalent of:

mv <search result path> ~/.dc++/FileLists/<filelist name>/

The 'search result path' is the value of the 'Path' column in the search window of the selected row. If the 'search result path' happens to match a local dir, it will be moved.

Sergey Basalaev (sbasalaev) wrote :

Cannot reproduce this way. I also searched in ~/.dc++/Logs/system.log in hope there'll be some messages in the moment of move, but I found nothing special and also found that names 'sdfghjmk' and 'acidGREEN' (see my comment #5) never appeared there.

sampattuzzi (sam-pattuzzi) wrote :

steven-sheehy: Yes, I'm experiencing the exact same behaviour with the moving.

Launchpad Janitor (janitor) wrote :

[Expired for LinuxDC++ because there has been no activity for 60 days.]

Changed in linuxdcpp:
status: Incomplete → Expired
Daniel Nägele (naegele) wrote :

Bug still exists in all its severity. The moved folder does not even have to be specified as the download directory, even fully independet directorys get moved. Still no idea what is causing the moving...

Changed in linuxdcpp:
status: Expired → New
Steven Sheehy (steven-sheehy) wrote :

Going to go ahead and confirm this since we have so many people with this issue even though I can't reproduce it. Razzloss, can you give it a try?

Changed in linuxdcpp:
importance: Undecided → High
status: New → Confirmed
summary: - Linux DC++ deletes files
+ Linux DC++ moves user directories to .dc++/Filelists
Thomas Oster (thommy-oster) wrote :

Hi,

I just encountered the very same issue. I was using linuxdcpp-bzr on ArchLinux (not sure which version, but I guess it's about half a year old). I downloaded a whole directory to my Desktop and suddenly my "Videos" folder (unter my HOME) was moved to .dc++/file-lists/SOME_NAME_OF_A_GUY_I_DOWNLOADED_STUFF_FROM

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers