status labels at the bottom of download queue tab

Bug #851064 reported by Sergey Basalaev
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
LinuxDC++
Medium
juha berg

Bug Description

These labels have a fixed length. This means that if in some locale string "Files:" or "Items:" is wider than in default one, these strings may not fit in space granted to them and will be cut with ellipsis. See e.g. attached screenshot with Russian locale.

Tags: ui Edit Tag help
Revision history for this message
Sergey Basalaev (sbasalaev) wrote :
Razzloss (razzloss)
Changed in linuxdcpp:
importance: Undecided → Medium
milestone: none → 1.2.0
status: New → Confirmed
Revision history for this message
Steven Sheehy (steven-sheehy) wrote :

Known limitation with GTK+. I even filed a bug for it in GTK+ earlier this year:

https://bugzilla.gnome.org/show_bug.cgi?id=644007

It seems it is resolved in GTK+ 3, but I am unable to confirm since I'm still on GTK+ 2.x. Can you try with GTK+ 3? It's possible with GTK+ 3 it still may not work since we might have to change it from hardcoded to dynamic to take advantage of the fix.

juha berg (bikikku)
Changed in linuxdcpp:
status: Confirmed → Fix Released
assignee: nobody → juha berg (bikikku)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.