PPA shows prior version in about menu

Bug #655808 reported by coenieolivier on 2010-10-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LinuxDC++
Low
Steven Sheehy

Bug Description

When I try to upgrade from Linux DC++1.0.3 to 1.1.0 It installs, but when looking in the "Help" --> "About" menu is still shows v1.03... I have uninstalled and reinstalled numerous times but same result. PPA is added etc. Synaptic shows that v1.1.0 will be installed, but as soon as I check after install it still shows v1.0.3

Related branches

Razzloss (razzloss) wrote :

About menu shows the version as 1.0.3-bzrXXX until the 1.1.0 is actually released (ok, no idea if the PPA shows the bzr revision, maybe not). As long as the Core version is reported as 0.75 you are using the current development version.

I was going to convert this to a question, but one might consider the version information to be a bug since the package name claims something about 1.1.0... So Steven, should we update the about dialog (or to be more precise the version information)?

--RZ

--RZ

Steven Sheehy (steven-sheehy) wrote :

PPAs do not show the "-bzrXXX" since it runs in Launchpad's virtual build environment and our call to bzrlib fails. I guess we should rename it to 1.1.0 but we need some text appended to it to indicate it's a pre-release build. Something like alpha or prerelease. Got any other suggestions? I also think we should make the version string in the PPA match the version in the about menu (though without the -0ubuntu1).

Changed in linuxdcpp:
importance: Undecided → Low
milestone: none → 1.1.0
status: New → Confirmed
summary: - When installing 1.1.0 it installs 1.0.3 no matter what I do - Maverick
- Meerkat 64-bit
+ Bazaar version not present in PPA
summary: - Bazaar version not present in PPA
+ PPA shows prior version in about menu
tags: added: ppa
Steven Sheehy (steven-sheehy) wrote :

I changed it so that it's "1.1.0~pre1~bzrXXX". The ~ is a Debian thing that will cause 1.1.0 to supersede our pre-release packages.

Changed in linuxdcpp:
assignee: nobody → Steven Sheehy (steven-sheehy)
status: Confirmed → Fix Committed
Changed in linuxdcpp:
status: Fix Committed → Fix Released
tags: added: ui
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers