Finished transfers file size and speed status is <=0

Bug #641298 reported by Razzloss on 2010-09-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LinuxDC++
Low
Razzloss

Bug Description

File sizes/durations aren't added to the totalSize/totalTime variables so the statusbar is never correctly updated (size and time is subtracted when file is removed). So this leads to 0 size and speed statuses.

Related branches

Razzloss (razzloss) on 2010-09-17
tags: added: finished-downloads finished-uploads ui
Razzloss (razzloss) wrote :

I believe the counting is now fixed. Didn't do too much testing on this. but the ones I did seemed like the bytes/speeds were correct.

--RZ

Changed in linuxdcpp:
assignee: nobody → Razzloss (razzloss)
status: Confirmed → Fix Committed
Steven Sheehy (steven-sheehy) wrote :

I think we need to make separate classes for finished uploads and downloads in the future. There's getting to be too much isUpload checks since we made uploads show all segments and downloads only show complete files.

Changed in linuxdcpp:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers