atomic counters implemented

Bug #617988 reported by Gennady Proskurin on 2010-08-14
This bug affects 1 person
Affects Status Importance Assigned to Milestone

Bug Description

Implemented atomic class template, which includes int32_t and uint32_t portable atomic counters from boost.
Using this class in "struct Counts" instead of heavy-weight safeInc/safeDec functions.
Also "operator!=" is removed from struct Counts (it is unused, and it is not safe in multithread)

Related branches

Gennady Proskurin (gpr) wrote :
description: updated
Steven Sheehy (steven-sheehy) wrote :

Marking as fixed in dc++. Let us know if you disagree with the approach taken since it differs from your patch.

Will be included in linuxdcpp once we upgrade the core.

Changed in linuxdcpp:
importance: Undecided → Low
status: New → Confirmed
Changed in dcplusplus:
importance: Undecided → Low
status: New → Fix Committed
poy (poy) wrote :

Fixed in DC++ 0.780.

Changed in dcplusplus:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers