Default download directory missing path separator

Bug #463723 reported by Victor Zamanian on 2009-10-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
DC++
Low
Steven Sheehy
LinuxDC++
Medium
Razzloss

Bug Description

Upon first launching linuxdcpp without any prior settings, linuxdcpp seems to suggest I should save all new downloads into the folder (replace <user> with a user name):

/home/<user>/Downloads/

which would be fine if it weren't for the fact that the default setting for the download directory is missing the slash mark between "<user>" and "Downloads/", thus making the default download directory:

/home/<user>Downloads/

which does not exist (at least there is no such user on my system). If someone does not change their default setting, they might not get anything downloaded, right?

I've attached a screen shot in case the explanation was unclear. (Notice the cursor between "<user>" and "Downloads" -- I didn't accidentally remove the slash mark :) the cursor just happened to be there.)

I already had a directory called Downloads in my home dir, if that might have anything to do with it.

Related branches

Victor Zamanian (victorz) wrote :
Razzloss (razzloss) wrote :

And this is with the bzr trunk and not with the latest release 1.0.3?

Anyway confirmed for bzr trunk. Download path seems to be HOME + Downloads/ and I think in most cases $HOME doesn't include the trailing /.

--RZ

Changed in linuxdcpp:
importance: Undecided → Medium
milestone: none → 1.1.0
status: New → Confirmed
Victor Zamanian (victorz) wrote :

This is in the bzr trunk. Seems like it was such an easy fix even I managed to create a patch.

Yes, HOME environment variable includes no trailing slash mark. Attached patch fixes this for me. I assume this is of course where you've been poking around, too, Razzloss.

Razzloss (razzloss) wrote :

Fix for DC++ attached.

tags: added: core non-win32
Razzloss (razzloss) wrote :

Committed fix for linuxdcpp.

--RZ

Changed in linuxdcpp:
assignee: nobody → Razzloss (razzloss)
status: Confirmed → Fix Committed
summary: - Default download directory missing slash mark.
+ Default download directory missing path separator
tags: added: preferences
removed: directory settings
Changed in dcplusplus:
assignee: nobody → Steven Sheehy (steven-sheehy)
importance: Undecided → Low
status: New → Fix Committed
poy (poy) wrote :

Fixed in version 0.760.

Changed in dcplusplus:
status: Fix Committed → Fix Released
Changed in linuxdcpp:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers