Increase Max filelist size limit

Bug #430275 reported by stoft on 2009-09-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LinuxDC++
Low
Steven Sheehy

Bug Description

The GUI sets a cap at 100 for MaxFilelistSize. This is insufficient for really large filelists: When browsing really large filelists the message "Greater than maximum filelist size" is returned and no files are displayed.

A workaround is to manually change this value to >100 in DCPlusPlus.xml.

Version: latest from launchpad (afaik)
OS: ubuntu 9.04

Related branches

Razzloss (razzloss) wrote :

True, the default is 100MiB. The limit is there for a reason.

However there's an option in Preferences -> Advanced -> Experts only for controlling the maximum (unpacked) filelist size.

So what's the point of this bug report? You want the limit increased or removed?

--RZ

Changed in linuxdcpp:
status: New → Incomplete
stoft (rasmus-larsson) wrote :

That there is a limit is perfectly understandable. I would say raise the limit to 200-300 (but leave default val at 100), it should stay current for a while (hopefully).

Razzloss (razzloss) wrote :

Ah, yeah. Sorry I misunderstood the bug report at first. I thought that you weren't aware of the setting in dialog and wanted the filelist size limit removed/increased in the core, but apparently it was the dialog spinbox that was capped...

The spinbox limit could be increased to 2000 and still be safe from overflows in the client code.
The default value of 100 will be left as it is. (there isn't much we can do about it anyway since the client related defaults come from the core, and these should be changed in the windows client first)

--RZ

Changed in linuxdcpp:
importance: Undecided → Low
status: Incomplete → Confirmed
Razzloss (razzloss) on 2009-09-16
tags: added: ui
Steven Sheehy (steven-sheehy) wrote :

I increased it to 1 GB.

summary: - MaxFilelistSize cap in GUI
+ Increase Max filelist size limit
tags: added: preferences
Changed in linuxdcpp:
assignee: nobody → Steven Sheehy (steven-sheehy)
milestone: none → 1.1.0
status: Confirmed → Fix Committed
Changed in linuxdcpp:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers