Show IP address in hub user list

Bug #385284 reported by mark on 2009-06-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LinuxDC++
Wishlist
Steven Sheehy

Bug Description

Please add the IP address to the columns of the nicklist (where nick, shared, description, tag, connection, email can be enabled/disabled). The only way to see the IP is to get one user's file list or download a file from him.
Should be easy to implement, but I did not find the code for those columns.

Related branches

Razzloss (razzloss) wrote :

Code for the columns is in the linux/hub.cc (creation around the line 60 in current trunk, filling the data in Hub::getParams_client).

Though you probably still have to download something from the user as I don't think DC++ knows the users IP otherwise. (I don't see any reason why it should)

I don't really think that this would be useful and would only clutter the UI even more (specially if most of the entries are empty, because the IP isn't known).

--RZ

Changed in linuxdcpp:
importance: Undecided → Wishlist
status: New → Confirmed
mark (mark-tvk) wrote :

I remember that valknut showed the IP, but I don't know the dc protocol or valknut's internals to be able to tell more.
Maybe there is a workaround to get that information.

In my case the nick, shared and IP fields are the only useful fields and since every field can be disabled, one additional column should not bloat the GUI too much.

Steven Sheehy (steven-sheehy) wrote :

There is an easy way to get the IP from a user in the nick list using the DC++ API. However, it apparently doesn't work most of the time because it usually returns an empty string. In fact, Windows DC++ has an IP column in its nick list but is usually empty for me. Does DC++ show an IP for you? If it's empty most of the time, that probably means its not generally possible to retrieve an user's IP unless you initiate some transfer like Razzloss mentioned. In that case, we will not be adding an IP column that is for the most part empty.

endator (endator) wrote :

For most hubsofts you(or the other user) must initiate some kind of communication between the two of you for the IP to be known by the client, This is the design ot the protocol.

A hub can distribute this information to users after login but its not very common to do so (except to ops/admins in the hub)

mark (mark-tvk) wrote :

I've downloaded DC++ 0.75 and launched it with wine, then connected to the hub. The IP field from DC++ contains every IP from everyone in the hub, so it works.
btw: the hubsoftware is verlihub 0.9.8e-r2

mark (mark-tvk) wrote :

I fixed this bug for the cvs version, see the appended patch. The best part was: linuxdcpp already had the getIP() functions included (because of the dc++ core), so I just had to extend the GUI.
By default the IP field is visible and can be disabled with a right click like the other columns.

Steven Sheehy (steven-sheehy) wrote :

Thanks for the patch. Can you please create the patch using the latest bzr trunk instead of cvs?

MikeJJ (mrmikejj) wrote :

I'm sure the IP in nicklist, on dc++ depends on $Userlist2 support from hub. So while it'll normally give it for OP's, it's pretty much devoid for users. It gets filled out for all active users in adc hubs though. :)

MikeJJ (mrmikejj) wrote :

$USERIP2 i meant :)

mark (mark-tvk) wrote :

yes, here it is. Tested again, works.

Steven Sheehy (steven-sheehy) wrote :

Thanks

Changed in linuxdcpp:
assignee: nobody → Steven Sheehy (steven-sheehy)
milestone: none → 1.1.0
status: Confirmed → Fix Committed
summary: - show ip address in nicklist
+ Show IP address in hub user list
tags: added: hub ui
Changed in linuxdcpp:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers