CTRL+F4 to close tab

Bug #355167 reported by qwertitis on 2009-04-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LinuxDC++
Wishlist
Windkracht8

Bug Description

Keyboard shortcuts (CTRL+W to close tab, CTRL+N to quick connect, etc) should be user configurable.

Related branches

Razzloss (razzloss) on 2009-04-04
description: updated
summary: - CTRL+F4 to close tab
+ Configurable keyboard shortcuts
Changed in linuxdcpp:
importance: Undecided → Wishlist
Steven Sheehy (steven-sheehy) wrote :

Configurable shortcuts seems overkill, but ctrl+F4 in addition to ctrl+w to close tab seems reasonable.

summary: - Configurable keyboard shortcuts
+ CTRL+F4 to close tab
Changed in linuxdcpp:
status: New → Confirmed
Windkracht8 (windkracht8) wrote :

Questions, comments?

Steven Sheehy (steven-sheehy) wrote :

Hey David, can you remove the duplication of code by calling onCloseClicked_gui instead?

Steven Sheehy (steven-sheehy) wrote :

Sorry meant Bart, was thinking of David since he opened the bug.

Steven Sheehy (steven-sheehy) wrote :

You need to add the ctrl modifier as well.

Windkracht8 (windkracht8) wrote :

So the solution was easier then I thought!
This code is within a CTRL mask. There is a 'if (event->state & GDK_CONTROL_MASK)' on line 872. (not visible in patch, but it's there)

Steven Sheehy (steven-sheehy) wrote :

Ah, that's what I get for reviewing patches on my cellphone. Thanks for the patch.

Changed in linuxdcpp:
assignee: nobody → Windkracht8 (windkracht8)
milestone: none → 1.1.0
status: Confirmed → Fix Committed
Changed in linuxdcpp:
status: Fix Committed → Fix Released
tags: added: main-window ui
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions