Partially downloaded files removed from download queue adds to finished in 0.7091

Bug #337576 reported by nucleo on 2009-03-04
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
LinuxDC++
Low
Windkracht8

Bug Description

Detailed description of the issue
If I remove from download queue partially downloaded file it appears in finished downloads in linuxdcpp 0.7091.

Expected results
It should not appear in finished downloads.

Related branches

Razzloss (razzloss) wrote :

True. Finished dls currently show each downloaded chunk individually and as long as one segment has downloaded before the file is removed it will show up in finished lists (though only showing the size of actually transferred).

Someone hopefully decides to rewrite the finished transfers...

--RZ

Changed in linuxdcpp:
importance: Undecided → Low
status: New → Confirmed
Nenadsuperzmaj (nenadsuperzmaj) wrote :

Confirmed here also. Really confusing bug. Hope it's sorted soon.

Windkracht8 (windkracht8) wrote :

This is a possible fix, ignore all updates from the FinishedManagerListener until the complete file is downloaded.
Is this the expected behaviour?

Steven Sheehy (steven-sheehy) wrote :

Looks pretty good and seems to work. Since finished items only shows completed items again, we probably need to rename "Transferred" column to "Size" and "Speed" to "Average Speed". You need to also make similar changes for the grouped by users tab to only show finished. Actually, if you're willing I'd prefer the grouped by users tab completely removed since it's not really useful information, but I'd accept either way.

Changed in linuxdcpp:
assignee: nobody → Windkracht8 (bartv-windkracht8)
milestone: none → 1.1.0
tags: added: downloads finished regression ui
Steven Sheehy (steven-sheehy) wrote :

Also, I didn't check but how does this affect finished uploads?

Windkracht8 (windkracht8) wrote :

Same as last but with group by user.

Upload works the same as download. If you want partial upload just change if(!item->isFull()) to if(!upload && !item->isFull())

Windkracht8 (windkracht8) wrote :

With this patch the group by user tab is removed.
Are you sure you want this removed? I assume it was added for some reason.

If this is the way to go, I'll do another check of finishedtransfer. There might be some traces left of the user tab.

Razzloss (razzloss) wrote :

It was added because win dc++ had it. I would have preferred the 'old' way, without any groupings and one (complete) download/line, but couldn't figure out how to do that with that particular core. So I gave up and implemented that monster.

--RZ

Steven Sheehy (steven-sheehy) wrote :

Ok, so we're in agreement that grouped by users should be removed and that downloads should show completed files. Should we make the partial vs full be a checkbox option at the bottom like DC++ does? Or is it not worth the effort to implement a tree model filter for this? I can't really understand why people would want partial files to be in finished downloads (they can see this info already in transfers and download queue). In finished uploads showing only 100% would cause problems for files that people are downloading from you and other people simultaneously.

Steven Sheehy (steven-sheehy) wrote :

Since it seems no one has an opinion about the checkbox option, I went ahead and committed Windkracht8's fix. Thanks for the patch and keep up the good work. :)

Changed in linuxdcpp:
status: Confirmed → Fix Committed
tags: added: finished-downloads
removed: downloads finished
Changed in linuxdcpp:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers