Download User name disappear in 0.7091

Bug #337480 reported by nucleo on 2009-03-03
2
Affects Status Importance Assigned to Milestone
LinuxDC++
Medium
Razzloss

Bug Description

When downloads starts from search results window User and Hub name are not shown in linuxdcpp 0.7091.
http://pic.ipicture.ru/uploads/090304/SpuTt4kH1S.png
http://pic.ipicture.ru/uploads/090304/x6vGs7mQDw.png

Related branches

nucleo (nucleo) on 2009-03-03
description: updated
nucleo (nucleo) on 2009-03-03
description: updated
Razzloss (razzloss) wrote :

It doesn't seem to matter where it's started.

--RZ

Changed in linuxdcpp:
status: New → Confirmed
Razzloss (razzloss) wrote :

Quick fix committed.

ConnectionManager behaviour seems to have changed between 0.707 and 0.7091, which caused this. Anyway transferview needs some fixing.

--RZ

Changed in linuxdcpp:
importance: Undecided → Medium
status: Confirmed → Fix Committed
nucleo (nucleo) wrote :

Quick fix for user/hub not showing in transferview.
User/Hub name showed when downloading with this fix, but disappears immediately after downloading finished, but still in transfer window.

Razzloss (razzloss) wrote :

You mean that the nick and hub disappear from the view when the transfer is done? Or that the whole transfer disappears after the download is finished? The latter one is the behaviour that I'm seeing and I'd guess that the core nowadays sends remove immediately after the file is complete.

--RZ

nucleo (nucleo) wrote :

I mean that nick and hub names disappears when the transfer is done but connection not closed and that's why whole transfer still in transfer window but without names.

nucleo (nucleo) wrote :

Closing connection immediately after transfer is done is not good idea because sometimes it is necessary to wait long time when download slots appears, but when connection not closed I can download next file immediately after previous download finished.

Razzloss (razzloss) wrote :

This isn't behaving as it should. TransferView rewrite in progress...

--RZ

Changed in linuxdcpp:
assignee: nobody → razzloss
status: Fix Committed → In Progress
nucleo (nucleo) wrote :

This bug also I see in core version: 0.707.

Razzloss (razzloss) on 2009-03-29
Changed in linuxdcpp:
milestone: none → 1.1.0
Razzloss (razzloss) on 2009-05-08
Changed in linuxdcpp:
status: In Progress → Fix Committed
Steven Sheehy (steven-sheehy) wrote :

nucleo, if you could help to retest this fix and let us know your results it would be greatly appreciated.

E_zombie (lv77) wrote :

rev 308

nucleo (nucleo) wrote :

I downloaded both at one and at several users.
I did not see problems, with disappearance of nicknames similar to the E_zombie screenshot.

Changed in linuxdcpp:
status: Fix Committed → Fix Released
tags: added: transfers ui
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers