Downloading TTH group downloads file multiple times

Bug #308683 reported by Gandalf on 2008-12-16
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
LinuxDC++
Low
Steven Sheehy
Declined for 1.0 by Steven Sheehy
1.1
Low
Steven Sheehy

Bug Description

I'm using experimental 0707-core and i was trying to download a file with an unique TTH from multiple users where this file had several different filenames.
The client only checked if the filename was unique and not tth code so I was ending up downloading this file as many times as there were different filenames, instead of just once.

Steps to reproduce: Search a file, group the results based on tth and choose one with many users (and different filenames).

Expected results: Just downloading one file using all as sources.

Actual results: Downloaded all files with unique filenames.

Version: 0707-core

OS: Gentoo-linux-2.6.25

If I'm not suppose to report any bugs based on experimental code just delete this report.

/Gandalf

Related branches

Razzloss (razzloss) wrote :

This probably happens with the main trunk also.

But I don't know if I agree on the expected results. There's an option "Don't download files already queued" which, when enabled should prevent multiple downloads. When that option is enabled atleast 707-core doesn't add users with different filenames automatically as sources. Which would make sense to me (should probably be fixed in dcpp/). So you would need to click download and after that "download to" or match queue on the top-level item to add all the sources.

But anyway, does anyone else have an opinion how this should work?

--RZ

Gandalf (gandalf-vebbe) wrote :

My former client was StrongDC++ on my win computer and the difference it does compared to linuxdcpp is that when grouping files by tth it shows one of the filenames found at the top row, instead of the tth code that linuxdcpp does.

With your answer and this difference I threw away the files in question and redownloaded the same file, with the difference that I clicked on one of the files that were grouped instead of the top line (tth code). This gave me the desired behaviour, which works for me so you can close this bug if you want.

/Gandalf

Knuckles (knuckster) wrote :

I agree with Gandalf, strongdc++ (and its relatives) group search results by tth and display one of the file names (the first one maybe) as group name. When you select the whole group to download (thi is still one file, but with different names), the client downloads this one file and uses the group name as the destination name. If one wants to use another file name instead of those used for the group (for example, if it's misspelled or something), he can open the group and select the item with desirable name. This is a very natural and intuitive behavior. In all these cases the client should use all available sources for downloading. I suppose it will be good to implement the same in linuxdcpp.

Steven Sheehy (steven-sheehy) wrote :

I agree, it would be nice to be able to add multiple sources when downloading files grouped by TTH. Last I checked though, the core didn't seem to support it, if I recall correctly.

Changed in linuxdcpp:
importance: Undecided → Low
status: New → Confirmed
Razzloss (razzloss) on 2009-08-25
summary: - Segmented downloads all files with same tth as unique files
+ Downloading TTH group downloads file multiple times
Razzloss (razzloss) wrote :

With "Don't download already queued" set 0.761 core seems to do the sensible thing and adds the new source to existing item with single QueueManager::add -call. So I'd say this will be fixed when the core is upgraded to something later than 0.75.

--RZ

Steven Sheehy (steven-sheehy) wrote :

Found this to be pretty annoying, so I fixed it. :)

Changed in linuxdcpp:
assignee: nobody → Steven Sheehy (steven-sheehy)
milestone: none → 1.1.0
status: Confirmed → Fix Committed
tags: added: filename search ui
Changed in linuxdcpp:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers