CPU fan runs very very fast ubuntu 11.10 dell xpsl702x

Reported by Amit Rana on 2011-08-29
78
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Linux
Invalid
Unknown
linux (Ubuntu)
Undecided
Unassigned

Bug Description

1. Till login screen fan speed is ok
2. Soon after login fan starts running like crazy. The air coming out becomes hot after sometime.
3. Fan works quite normally in windows 7
4. I booted from ubuntu 11.04 live cd (and did some work) fan was fine
5. I booted and worked using Open Suse 11.04 , fan was fine.

I initially had 11.04 but don't remember if fan was ok with it. This is a new laptop. 1 day after I installed 11.04 I upgraded to 11.10. I will try to downgrade (if possible, someone on irc told me cant downgrade) and report.

This is critical as I may end up not using ubuntu. I am sure if its a bug it will affect hardware finally?

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: linux-image-3.0.0-9-generic 3.0.0-9.14
ProcVersionSignature: Ubuntu 3.0.0-9.14-generic 3.0.3
Uname: Linux 3.0.0-9-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC665 Analog [ALC665 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: amit 1983 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xf3c00000 irq 55'
   Mixer name : 'Intel CougarPoint HDMI'
   Components : 'HDA:10ec0665,102804b8,00100003 HDA:80862805,80860101,00100000'
   Controls : 27
   Simple ctrls : 13
Date: Mon Aug 29 13:04:43 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
MachineType: Dell Inc. Dell System XPS L702X
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-9-generic root=UUID=15e9167d-7089-4aee-8b48-e15f6bfad633 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-9-generic N/A
 linux-backports-modules-3.0.0-9-generic N/A
 linux-firmware 1.60
SourcePackage: linux
StagingDrivers: mei
UpgradeStatus: Upgraded to oneiric on 2011-08-27 (2 days ago)
dmi.bios.date: 06/01/2011
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A11
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 0XN71K
dmi.board.vendor: Dell Inc.
dmi.board.version: FAB1
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnDellInc.:bvrA11:bd06/01/2011:svnDellInc.:pnDellSystemXPSL702X:pvr:rvnDellInc.:rn0XN71K:rvrFAB1:cvnDellInc.:ct8:cvr0.1:
dmi.product.name: Dell System XPS L702X
dmi.sys.vendor: Dell Inc.

Amit Rana (amit-rana) wrote :
Brad Figg (brad-figg) on 2011-08-29
Changed in linux (Ubuntu):
status: New → Confirmed

Hi Amit,

It'll be helpful if you could help us narrow down between which two kernels this regression was introduced. You commented, Natty was ok. Which specific Natty kernel version were you using (look at the output of `uname -a` from a Terminal)? I'd then suggest trying some kernels in between the Natty kernel you were using and the current 3.0.0-9.14 Oneiric kernel. I've pasted some links below for reference to some of the earlier Oneiric kernels for you to try. If the issue exists in the earliest 3.0-1.0 Oneiric kernel, you won't need to test any further as that indicates it's a regression between the latest Natty Kernel and the earliest Oneiric kernel and we'll have to bisect with the mainline builds. But try testing out the following and let us know your results:

(3.0-0.1 was rebased on upstream v3.0-rc1)
https://launchpad.net/ubuntu/oneiric/amd64/linux-headers-3.0-0-generic/3.0-0.1
https://launchpad.net/ubuntu/oneiric/amd64/linux-image-3.0-0-generic/3.0-0.1

(3.0-1.2 was rebased on upstream v3.0-r3)
https://launchpad.net/ubuntu/oneiric/amd64/linux-headers-3.0-1-generic/3.0-1.2
https://launchpad.net/ubuntu/oneiric/amd64/linux-image-3.0-1-generic/3.0-1.2

(3.0-2.3 was rebased on upstream v3.0-rc4)
https://launchpad.net/ubuntu/oneiric/amd64/linux-headers-3.0-2-generic/3.0-2.3
https://launchpad.net/ubuntu/oneiric/amd64/linux-image-3.0-2-generic/3.0-2.3

(3.0-3.4 was rebased on upstream v3.0-rc5)
https://launchpad.net/ubuntu/oneiric/amd64/linux-headers-3.0-3-generic/3.0-3.4
https://launchpad.net/ubuntu/oneiric/amd64/linux-image-3.0-3-generic/3.0-3.4

(3.0.0-5.6 was rebased on upstream v3.0-rc7)
https://launchpad.net/ubuntu/oneiric/amd64/linux-headers-3.0.0-5-generic/3.0.0-5.6
https://launchpad.net/ubuntu/oneiric/amd64/linux-image-3.0.0-5-generic/3.0.0-5.6

(3.0.0-7.8 was rebased on upstream v3.0 final)
https://launchpad.net/ubuntu/oneiric/amd64/linux-headers-3.0.0-7-generic/3.0.0-7.8
https://launchpad.net/ubuntu/oneiric/amd64/linux-image-3.0.0-7-generic/3.0.0-7.8

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Amit Rana (amit-rana) wrote :

Hi, Thanks for responding.

I tried on 2.6.38-11 and it seem to work fine.

Now I want to try with 3.0-0.1, can you please guide me how to install this? Currently I trying following

sudo dpkg -i linux-headers-3.0-0-generic_3.0-0.1_amd64.deb
Selecting previously deselected package linux-headers-3.0-0-generic.
(Reading database ... 207245 files and directories currently installed.)
Unpacking linux-headers-3.0-0-generic (from linux-headers-3.0-0-generic_3.0-0.1_amd64.deb) ...
dpkg: dependency problems prevent configuration of linux-headers-3.0-0-generic:
 linux-headers-3.0-0-generic depends on linux-headers-3.0-0; however:
  Package linux-headers-3.0-0 is not installed.
dpkg: error processing linux-headers-3.0-0-generic (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 linux-headers-3.0-0-generic

Do I need to do something else also here? Shall I remove the old 3.0.0-9 that I have currently?

Kindly guide.

Amit Rana (amit-rana) on 2011-09-06
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Amit Rana (amit-rana) wrote :

Confirmed. works perfect with 2.6.38-11

Even tried 3.0.0-11, that also has problem.

Not able to test/install older kernels, need help.

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel currently in the release pocket than the one you tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-11.18
Amit Rana (amit-rana) wrote :

Already tried this morning. Problem is still there in 3.0.0.11

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Brad Figg (brad-figg) wrote :

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel currently in the release pocket than the one you tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Brad Figg (brad-figg) wrote :

Please ignore the last message from the bot.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-12.19

Were can we find the kernel 3.0.0-12-19 deb binary? The oneiric repos still got the 3.0.0-11.18

Upgraded the kernel to 3.0.0-12.19 and still the same problem with my AMD Phenom II P940 Quad-Core Processor, fan speed is really high and CPU temperature is around 73C.

Rune (rune-bak) wrote :

Just upgraded to 11.10 and cpu fan goes crazy here as well after logging in.
I'm on Samsung Series 9.

Well, Bug is still with latest kernel but I think is a mesa problem. I own 2 GPUs, ATI discrete and dedicated GPU, Till today I was using the free driver and fan was crazy, CPU was over 70C, today I installed the fglrx drivers, fan is ok and CPU is around 58C.

Josh Simmons (simmons-44) wrote :

I can confirm with the latest kernel, and it seems to be an issue with the free radeon driver as when switching to fglrx there are no issues.

Note it's the CPU fan not the GPU fan that's running hot.

Graphics card is RadeonHD 6970
kernel is Linux Prime 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:56:25 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Alexandr (olexandr-dmitriev) wrote :

Hi, I have the same problem.

Linux adwork 3.0.0-12-generic-pae #20-Ubuntu SMP Fri Oct 7 16:37:17 UTC 2011 i686 i686 i386 GNU/Linux
GPU Intel HD Graphics 3000

No CPU load, just fan.

Amit Rana (amit-rana) wrote :

I will stay with 11.04 until this is resolved. Staying away from 11.10

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for someone having this issue to test the latest upstream kernel? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the release candidate kernel versus the daily build. Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-12.20
Henrik Sölver (henrik-solver) wrote :

Tried mainline kernel "linux-image-3.1.0-999-generic_3.1.0-999.201110040905_amd64.deb". Still the same problem.
CPU: Intel i5 2500K (Intel HD Graphics 3000)

Shyam (shyam.s) wrote :

Yeah. Even I have this problem, cpu load is fine but the fan.
usiing linux-image 3.0.0.12-20 (amd64)

Henrik Sölver (henrik-solver) wrote :

I made a fresh install of 11.10 since I had all kinds of problems since the upgrade. But the fan issue still existed, I tried the "3.1.0-0301rc9-generic" kernel and the fan runs as normal again. I also found out that it is not sufficient to just reboot from 3.0.0 to 3.1.0 to calm down the fan, a power cycle seems to be needed.

tags: removed: needs-upstream-testing
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
status: Confirmed → Triaged
tags: added: regression-release
bkrish (baalaji) wrote :

Hi , I have recently upgraded to 11.10 version, and im facing similar issues with CPU fan noise and heat.
I didnt face this issue in any previous versions of ubuntu. I have tried a fresh installation of 11.10 , still the same.
anyone advise me how to resolve this ?

i use toshiba M200 laptop.

Download full text (3.9 KiB)

2011/10/17 Joseph Salisbury <email address hidden>

> This issue appears to be an upstream bug, since you tested the latest
> upstream kernel. Would it be possible for you to open an upstream bug
> report at bugzilla.kernel.org? That will allow the upstream Developers
> to examine the issue, and may provide a quicker resolution to the bug.
>
> If you are comfortable with opening a bug upstream, It would be great if
> you can report back the upstream bug number in this bug report. That
> will allow us to link this bug to the upstream report.
>
>
I can do that, but I want to try out 3.0.4-generic first. Hopefully I will
be able to do that tonight (CET).

>
> ** Changed in: linux (Ubuntu)
> Status: Incomplete => Confirmed
>
> ** Changed in: linux (Ubuntu)
> Status: Confirmed => Triaged
>
> ** Tags added: regression-release
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/836480
>
> Title:
> CPU fan runs very very fast ubuntu 11.10 dell xpsl702x
>
> Status in “linux” package in Ubuntu:
> Triaged
>
> Bug description:
> 1. Till login screen fan speed is ok
> 2. Soon after login fan starts running like crazy. The air coming out
> becomes hot after sometime.
> 3. Fan works quite normally in windows 7
> 4. I booted from ubuntu 11.04 live cd (and did some work) fan was fine
> 5. I booted and worked using Open Suse 11.04 , fan was fine.
>
> I initially had 11.04 but don't remember if fan was ok with it. This
> is a new laptop. 1 day after I installed 11.04 I upgraded to 11.10. I
> will try to downgrade (if possible, someone on irc told me cant
> downgrade) and report.
>
> This is critical as I may end up not using ubuntu. I am sure if its a
> bug it will affect hardware finally?
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.10
> Package: linux-image-3.0.0-9-generic 3.0.0-9.14
> ProcVersionSignature: Ubuntu 3.0.0-9.14-generic 3.0.3
> Uname: Linux 3.0.0-9-generic x86_64
> AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
> Architecture: amd64
> ArecordDevices:
> **** List of CAPTURE Hardware Devices ****
> card 0: PCH [HDA Intel PCH], device 0: ALC665 Analog [ALC665 Analog]
> Subdevices: 1/1
> Subdevice #0: subdevice #0
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: amit 1983 F.... pulseaudio
> CRDA: Error: [Errno 2] No such file or directory
> Card0.Amixer.info:
> Card hw:0 'PCH'/'HDA Intel PCH at 0xf3c00000 irq 55'
> Mixer name : 'Intel CougarPoint HDMI'
> Components : 'HDA:10ec0665,102804b8,00100003 HDA:80862805,80860101
> ,00100000'
> Controls : 27
> Simple ctrls : 13
> Date: Mon Aug 29 13:04:43 2011
> EcryptfsInUse: Yes
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64
> (20110427.1)
> MachineType: Dell Inc. Dell System XPS L702X
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-9-generic
> root=UUID=15e9167d-7089-4aee-8b48-e15f6bfad633 ro quiet splash vt.handoff=7
> RelatedPackageVersions:
> linux-restricted-modules-3.0.0-9-generic N/A
> linux-backports-modules-3.0.0-9-generic N/A
> linux-firmwa...

Read more...

Alex.Hahn (powerhan96) wrote :

HI, I'm facing a same problem on my HP 5310m laptop.
When I was using 11.04, I had no problem.

Problem wont happen all the time, but it seem like after a long term(over half a day) suspend, it mostly happens.
Resumeing from hibernate mode instead of suspend mode, problem doesn't seem to show up.

> uname -a
> Linux angel-pn03 3.0.0-13-generic #21-Ubuntu SMP Mon Oct 17 20:18:51 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Some news about bug fixing?

Kind Regards
Vincenzo

Rune (rune-bak) wrote :

Thinking this must have been fixed, I just upgraded to 11.10, but now
then fan is spinning like crazy. (Still Samsung Series 9 here)

Anybody working on this?

Best regards
Rune

On Wed, Dec 7, 2011 at 1:31 AM, Vincenzo Mazzotta
<email address hidden> wrote:
> Some news about bug fixing?
>
> Kind Regards
> Vincenzo
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/836480
>
> Title:
>  CPU fan runs very very fast ubuntu 11.10 dell xpsl702x
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/836480/+subscriptions

Henrik Sölver (henrik-solver) wrote :

I updated the BIOS yesterday, it solved this problem for me.

Amit Rana (amit-rana) wrote :

BIOS update did not fix it for me. Dell XPSL720X. Fan is still running on steroids.

Amit Rana (amit-rana) wrote :

Added a new bug at bugzilla.kernel.org as per #22

https://bugzilla.kernel.org/show_bug.cgi?id=42605

Amit Rana (amit-rana) wrote :

Yesterday I was trying to solve some other problem, following steps given on this page http://www.ivegotavirus.com/blog/2011/11/06/how-to-get-optimus-working-on-ubuntu-11-10-oneiric/

Soon after step 3) sudo apt-get install bumblebee, fan started working fine.

Is this related? Now fan works fine. I haven't finished the steps mentioned on the page. Just installed bumblebee, now fan is working normally.

I also keep ubuntu uptodate so not sure if that is also related. I am using 3.0.0-16-generic x86_64

helam (wb4helam) wrote :

This issue,CPU Fan non-stopping revolving with maximum speed affected:
Debian 6 with / without GUI.
Ubuntu 11.10/04 Live/Installed.

Laptop is Dell Inspiron 1318.

Certainly, on Windows 7 32/64 bit editions (Ultimate) CPU Fan works as should be - in silence, and only sometime blows hot air.
So,no issue at all on windows 7 and yes exists on all Debian/Ubuntu platforms.

Would be great if Ubuntu team explain what's wrong with intercation to ACPI in Ubuntu and how to do at least workaround in theMarch 2012, because this issue is hardware meaning I can not use at all Ubuntu/Debian etc... in no time.

Right now as all others I forced to use Windows 7, Because I don't have a huge box of CPU fans ,procs etc parts...:-)

This still happens in Ubuntu 12.04 Beta 2

Radeon HD 4200/5650 with the mesa drivers.

Don't happen with proprietary drivers.

My PC is dying, the CPU and GPU temperature is over 88ºC all the time.

I'm using windows 7 now more than ever.

Maarten Bezemer (veger) wrote :

Thanks for taking the time to report this bug in the upstream bug tracking system this is a tremendous help. Launchpad has the ability to watch lots of upstream bug trackers and this can be done by following the procedure documented at https://wiki.ubuntu.com/Bugs/Watches. I've added the bug watch for this bug report.

Changed in linux:
status: Unknown → Incomplete
Amit Rana (amit-rana) wrote :

Why has this become 'incomplete'?

Changed in linux:
status: Incomplete → In Progress
Changed in linux:
status: In Progress → Incomplete
Changed in linux:
status: Incomplete → Invalid

Amit Rana, this bug report is being closed due to your last comment https://bugzilla.kernel.org/show_bug.cgi?id=42605#c10 regarding this being fixed by reinstalling the Bumblebee PPA. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

tags: added: bios-outdated-a19 bot-stop-nagging needs-upstream-testing
removed: kernel-request-3.0.0-11.18 kernel-request-3.0.0-12.19 kernel-request-3.0.0-12.20
Changed in linux (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.