spurious 8259 interrupt disabled IRQ

Bug #75626 reported by drunken-wallaby on 2006-12-13
8
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Unknown
linux (Ubuntu)
Undecided
Colin Ian King
linux-source-2.6.20 (Ubuntu)
Undecided
Kyle McMartin

Bug Description

on a hp pavilion dv9043ea.

it seems that there is a irq problem. in /var/log/kern.log is a line "spurious 8259A interrupt: irq 7". after a while of using the desktop irq 7 is disabled (the usb2 port). i have to manually remove ehci_hcd to get usb working again (at 1.1 speed).

the same problem is persisting in dapper and edgy as well.

drunken-wallaby (berndl81) wrote :

in addition: the error persists even when trying some kernel options (acpi=off noapic nolapic irqpoll routeirq,....)

Ben Collins (ben-collins) wrote :

Please retest against 2.6.20-2 when it is available in the feisty archive.

Changed in linux-source-2.6.19:
status: Unconfirmed → Needs Info
description: updated
drunken-wallaby (berndl81) wrote :

Hi Ben.

I upgraded to 2.6.20-2 and still have the same problem (tried several kernel boot options as well). I don't know which output could be helpful for you.

Additionally, i get a lot of ata: timeout errors now. Should I file this as a seperate bug?

Changed in linux-source-2.6.20:
importance: Undecided → High
status: Needs Info → Confirmed
Kyle McMartin (kyle) wrote :

Could you please attach a dmesg that includes everything including irq7 being disabled. Also please attach the output of "cat /proc/interrupts", "lspci -vv", "lspci -vvn", and "dmidecode" to this bug report to help us try and track down what's going wrong.

Changed in linux-source-2.6.20:
importance: High → Undecided
status: Confirmed → Needs Info
Changed in linux:
status: Unknown → In Progress
Ben Collins (ben-collins) wrote :

No response to queries in over a month. Probably just reject it.

Changed in linux-source-2.6.20:
assignee: nobody → kyle
Changed in linux:
status: In Progress → Needs Info
drunken-wallaby (berndl81) wrote :

Sorry for not replying earlier. The bug persisted till 2.6.20-8 or so and then I switched to archlinux where everything works fine with their stock kernel.

Question: Would it be helpful if I generate the requested outputs from an ubuntu live-cd or do I have to do this inside an installed ubuntu?

Changed in linux:
status: Needs Info → Confirmed
Bryan Donlan (bdonlan) wrote :

This bug also occurs on the Compaq Presario V6000z laptop. Booting with 'noirqdebug' prevents the USB driver from failing entirely, but the CPU (one of them anyway) spends a lot of time on hi%, wasting cpu time, power, and producing a lot of heat.

I'm currently booted in noirqdebug; I'll attach lspci -vvnx, dmidecode, dmesg etc now. I'll get dmesg etc for without noirqdebug tomorrow.
Note that I'm also booted with noapic to prevent a hard lockup (#89746)

Bryan Donlan (bdonlan) wrote :
Bryan Donlan (bdonlan) wrote :
Changed in linux:
status: Confirmed → Rejected
Changed in linux:
status: Invalid → Fix Released
Bryan Donlan (bdonlan) wrote :

What information is needed for the bug to be removed from the 'incomplete' status?

jeromio (ubuntu-jeromio) wrote :

I have a Presario V6000 and I am also seeing this problem. Fan is on almost constantly and the machine becomes unusably slow. Is there a work-around? It looks like the boot options Brian has tried have either not cured this IRQ issue, or have resulted in worse issues. I can't use this PC as it is now, so I'm looking for any kind of fix. Thanks.
Presario V6000Z, AMD64 dualcore 1.7Ghz, 1.5Meg, NVidia GeForce and Nforce. Tried Feisty (7.04) and Gutsy (7.10) in both Kubuntu and Ubuntu flavors (I'm going to wear out the hd re-installing linux on this machine).

jeromio (ubuntu-jeromio) wrote :

Attached is the output of all the requested cmds (from Kyle's post above). My dmesg is a bit clouded with BCM43xx info - still having troubles getting that sorted.

Here is how it boots:

title Ubuntu, kernel 2.6.20-16-generic
root (hd0,0)
kernel /boot/vmlinuz-2.6.20-16-generic root=UUID=80655b06-2397-47aa-8568-6bff4f8a5321 ro quiet splash noapic
initrd /boot/initrd.img-2.6.20-16-generic

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Colin Ian King (colin-king) wrote :

This bug report is being closed because we received no response to the previous inquiry for information. Please reopen if this is still an issue in the current Ubuntu release, Jaunty Jackalope 9.04 - http://www.ubuntu.com/getubuntu/download. If the issue remains in Jaunty, please test the latest upstream kernel build - https://wiki.ubuntu.com/KernelMainlineBuilds . To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

Changed in linux (Ubuntu):
assignee: nobody → Colin King (colin-king)
status: Incomplete → Won't Fix
DiagonalArg (diagonalarg) wrote :

My dmesg is also showing the line "spurious 8259A interrupt: IQ7".

I am on a Tyan S3970 with 2 CPU's (8 cores), a TARO card & 20G memory.

Colin Ian King (colin-king) wrote :

DiagonalArg, please file a new bug as you have different hardware and kernel, thanks

DiagonalArg (diagonalarg) wrote :

@Colin.

I am having a couple of other issues on this machine, whose details are located at the one bug that seems specific to it, which is here:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1217229

Perhaps I should keep the system data there, rather than repeating it? Please let me know.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.