[MAVERICK] [THINKPAD EDGE14] System does not completely wake from suspend using lid

Bug #702434 reported by Manoj Iyer on 2011-01-13
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Linux
In Progress
Undecided
Manoj Iyer
linux (Ubuntu)
Medium
Manoj Iyer
Maverick
Medium
Manoj Iyer

Bug Description

mage: 10.10 DVD
BIOS Version: 82ET16WW
Platform: Thinkpad Edge 14" Rev: SKU:
CPU: AMD Turion
GPU: ATI

Summary:
When suspended using the lid switch, the system does not full wake once lid is opened. The disk spins up but the LCD never powers.

Steps to reproduce:
1) Close lid
2) Open lid

Expected result:
System suspends and then wakes without error

Actual result:
System suspends but then hangs on wake

ProblemType: Bug
BiosVersion: 82ET16WW (1.02 )
CheckboxDescription: 1. Does closing your laptop lid cause your computer to suspend?
CheckboxTest: power-management/lid
Date: Fri Nov 12 16:40:07 2010
Manufacturer: LENOVO
Model: 019923U

Manoj Iyer (manjo) wrote :

The kernel in http://kernel.ubuntu.com/~manjo/maverick/lp674710/ fixes suspend resume on this system.

Changed in launchpad:
assignee: nobody → Manoj Iyer (manjo)
status: New → Incomplete
affects: launchpad → linux
Manoj Iyer (manjo) wrote :

SRU JUSTIFICATION
==================
AMD based ThinkPad Edge 11, 13, 14 and 15 do not suspend from resume unless acpi_skip_timer_override is set to force ignoring BIOS IRQ0 pin2 override.

SRU TESTING
============
This patch was tested on ThinkPad Edge 11 and 14. and a test kernel is available at http://kernel.ubuntu.com/~manjo/maverick/lp674710/

Chris Van Hoof (vanhoof) on 2011-01-19
tags: added: hwe-blocker

Accepted linux into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Brad Figg (brad-figg) on 2011-02-02
tags: added: verification-done
Brad Figg (brad-figg) on 2011-02-02
tags: added: verification-needed
removed: verification-done
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

greyor (greyor) wrote :

I can confirm that this fixes my suspend problems on an AMD64 Edge 14"! Thanks so much for the patch.

Brian Murray (brian-murray) wrote :

I've changed the tag from verification-needed to verification-done based off comment #5.

tags: added: verification-done
removed: verification-needed
Jeremy Foshee (jeremyfoshee) wrote :

Hi Manoj,

Please be sure to confirm this issue exists with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/daily/current/ . However, note you can only test Suspend, not Hibernate, when using a LiveCD. If the issue remains, run the following command from a Terminal (Applications->Accessories->Terminal) it will automatically gather and attach updated debug information to this report.

apport-collect -p linux 702434

Also, please be sure to take a look at https://wiki.ubuntu.com/DebuggingKernelSuspendHibernateResume . If you can provide any additional information outlined there it would be much appreciated.

Additionally, if you could try to reproduce this with the upstream mainline kernel that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kernel-suspend
tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Chris Van Hoof (vanhoof) on 2011-02-03
Changed in linux (Ubuntu Maverick):
status: New → Fix Committed
Changed in linux (Ubuntu):
status: Incomplete → In Progress
assignee: nobody → Manoj Iyer (manjo)
Changed in linux (Ubuntu Maverick):
assignee: nobody → Manoj Iyer (manjo)
Changed in linux (Ubuntu):
importance: Undecided → Medium
Changed in linux (Ubuntu Maverick):
importance: Undecided → Medium
Brad Figg (brad-figg) on 2011-02-05
tags: added: verification-done-maverick
removed: verification-done

Accepted linux into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Thomas Schwinge (tschwinge) wrote :

In my case (my girlfriend's, actually), a follow-up patching as discussed in <https://lists.ubuntu.com/archives/kernel-team/2011-February/014500.html> was needed.

Chris Van Hoof (vanhoof) on 2011-02-15
Changed in linux:
status: Incomplete → In Progress
Narek M.B. (narekm) wrote :

I would like to confirm that the problem described by Thomas is (apparently) present on my machine 0203A16 (judging from the model number and the link it is a very similar machine). I am currently struggling to try to port Thomas's fix for my system.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.38-4.31

---------------
linux (2.6.38-4.31) natty; urgency=low

  [ Andy Whitcroft ]

  * add in bugs closed by upstream patches pulled in by rebases
  * rebase to 795abaf1e4e188c4171e3cd3dbb11a9fcacaf505
  * [Config] enable CONFIG_VSX to allow use of vector instuctions
  * resync with maverick 98defa1c5773a3d7e4c524967eb01d5bae035816
  * rebase to mainline v2.6.38-rc5
  * SAUCE: ecryptfs: read on a directory should return EISDIR if not
    supported
    - LP: #719691

  [ Colin Ian King ]

  * SAUCE: Dell All-In-One: Remove need for Dell module alias

  [ Manoj Iyer ]

  * SAUCE: (drop after 2.6.38) add ricoh 0xe823 pci id.
    - LP: #717435

  [ Tim Gardner ]

  * [Config] CONFIG_CRYPTO_CRC32C_INTEL=y

  [ Upstream Kernel Changes ]

  * Quirk to fix suspend/resume on Lenovo Edge 11,13,14,15
    - LP: #702434
  * vfs: fix BUG_ON() in fs/namei.c:1461

  [ Vladislav P ]

  * SAUCE: Release BTM while sleeping to avoid deadlock.
    - LP: #713837

  [ Major Kernel Changes ]

  * rebase from v2.6.38-rc4 to v2.6.38-rc5
    - LP: #579276
    - LP: #715877
    - LP: #713769
  * resync with Maverick Ubuntu-2.6.35-27.47
 -- Andy Whitcroft <email address hidden> Fri, 11 Feb 2011 17:24:09 +0000

Changed in linux (Ubuntu):
status: In Progress → Fix Released
Narek M.B. (narekm) wrote :

I just compiled and tested a kernel with the patch from Thomas for my machine (0203A16 as mentioned above, Think Pad Edge 15") and I can confirm that it solved the problem. I hope this model number can be included.

Launchpad Janitor (janitor) wrote :
Download full text (12.1 KiB)

This bug was fixed in the package linux - 2.6.35-27.48

---------------
linux (2.6.35-27.48) maverick-proposed; urgency=low

  [ Steve Conklin ]

  * Release Tracking Bug
    - LP: #723335

  [ Upstream Kernel Changes ]

  * thinkpad-acpi: avoid keymap pitfall
    - LP: #722747

linux (2.6.35-27.47) maverick-proposed; urgency=low

  [ Brad Figg ]

  * Release Tracking Bug
    - LP: #716532

  [ Upstream Kernel Changes ]

  * Revert "USB: gadget: Allow function access to device ID data during
    bind()"
    - LP: #714732
  * net: fix rds_iovec page count overflow, CVE-2010-3865
    - LP: #709153
    - CVE-2010-3865
  * Input: fix typo in keycode validation supporting large scancodes
    - LP: #658198
  * net: ax25: fix information leak to userland, CVE-2010-3875
    - LP: #710714
    - CVE-2010-3875
  * net: ax25: fix information leak to userland harder, CVE-2010-3875
    - LP: #710714
    - CVE-2010-3875
  * net: packet: fix information leak to userland, CVE-2010-3876
    - LP: #710714
    - CVE-2010-3876
  * net: tipc: fix information leak to userland, CVE-2010-3877
    - LP: #711291
    - CVE-2010-3877
  * posix-cpu-timers: workaround to suppress the problems with mt exec,
    CVE-2010-4248
    - LP: #712609
    - CVE-2010-4248
  * sys_semctl: fix kernel stack leakage, CVE-2010-4083
    - LP: #712749
    - CVE-2010-4083
  * thinkpad-acpi: lock down size of hotkey keymap
    - LP: #712174
  * thinkpad-acpi: add support for model-specific keymaps
    - LP: #712174
  * thinkpad-acpi: Add KEY_CAMERA (Fn-F6) for Lenovo keyboards
    - LP: #712174
  * x86, hotplug: Use mwait to offline a processor, fix the legacy case
    - LP: #714732
  * fuse: verify ioctl retries
    - LP: #714732
  * fuse: fix ioctl when server is 32bit
    - LP: #714732
  * ALSA: hda: Use position_fix=1 for Acer Aspire 5538 to enable capture on
    internal mic
    - LP: #685161, #714732
  * ALSA: hda: Use model=lg quirk for LG P1 Express to enable playback and
    capture
    - LP: #595482, #714732
  * drm/radeon/kms: don't apply 7xx HDP flush workaround on AGP
    - LP: #714732
  * drm/kms: remove spaces from connector names (v2)
    - LP: #714732
  * drm/radeon/kms: fix vram base calculation on rs780/rs880
    - LP: #714732
  * nohz: Fix printk_needs_cpu() return value on offline cpus
    - LP: #714732
  * nohz: Fix get_next_timer_interrupt() vs cpu hotplug
    - LP: #714732
  * nfsd: Fix possible BUG_ON firing in set_change_info
    - LP: #714732
  * NFS: Fix fcntl F_GETLK not reporting some conflicts
    - LP: #714732
  * sunrpc: prevent use-after-free on clearing XPT_BUSY
    - LP: #714732
  * hwmon: (adm1026) Allow 1 as a valid divider value
    - LP: #714732
  * hwmon: (adm1026) Fix setting fan_div
    - LP: #714732
  * EDAC: Fix workqueue-related crashes
    - LP: #714732
  * amd64_edac: Fix interleaving check
    - LP: #714732
  * ASoC: Fix swap of left and right channels for WM8993/4 speaker boost
    gain
    - LP: #714732
  * ASoC: Fix off by one error in WM8994 EQ register bank size
    - LP: #714732
  * ASoC: WM8580: Fix R8 initial value
    - LP: #714732
  * ASoC: fix deemphasis control in wm8904/55/60 codecs
    - LP: #714732
  * bootmem: Add alloc_bootmem_...

Changed in linux (Ubuntu Maverick):
status: Fix Committed → Fix Released
Andy Whitcroft (apw) wrote :

@Narek, @Tomas -- if you still need an additional patch after the above released versions are installed could you file another bug listing the specific hardware affected, and include a pointer to the patch. Please add a link there to that bug so we can find it. Thanks.

Narek M.B. (narekm) wrote :

@Andy, sorry for a late response. No the version does not work for me and neither does the latest upstream kernel. I had to add the patch again and recompile.

I have filed a new bug under
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/758195

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers