[arrandale] Samsung QX310/QX410/QX510/SF310/SF410/SF510/NF210/RF410/RF510/RF511/RF710 trackpad/touchpad not recognized

Reported by Tristan Davies on 2010-11-26
548
This bug affects 101 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
xf86-video-intel
New
Undecided
Unassigned
linux (Ubuntu)
Medium
Guilherme Grunewald
Oneiric
Medium
Seth Forshee
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

Ubuntu 10.10, Samsung NP-QX410. Trackpad settings not available. Can use trackpad, can use left and right click, but no options available to adjust settings. Personally having issue of rubbing trackpad while I type and it is very annoying.

The trackpad is recognized as a "PS/2 Logitech Wheel Mouse". No side scrolling, no disabling tap-to-click (annoying!) and no other trackpad settings available.

How to reproduce:
1) install ubuntu on a samsung qx410
2) try, try, try and fail to make the touchpad work properly
---
Architecture: amd64
DRM.card0.DisplayPort.1:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
DRM.card0.HDMI_Type_A.1:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1366x768
 edid-base64: AP///////wBMo1AyAAAAAAAUAQOAHxF4Cgnll1dUiiciUFQAAAABAQEBAQEBAQEBAQEBAQEBhBtWeFAAFjAwICUANa4QAAAZAAAADwAAAAAAAAAAAB60AnQAAAAA/gBTQU1TVU5HCiAgICAgAAAA/gBMVE4xNDBBVDE3ODAxANw=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
DistroRelease: Ubuntu 10.10
DkmsStatus:

InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
MachineType: SAMSUNG ELECTRONICS CO., LTD. QX310/QX410/QX510/SF310/SF410/SF510
Package: xorg 1:7.5+6ubuntu3
PackageArchitecture: amd64
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-23-generic root=UUID=75a97d0d-7483-4000-8519-03687885d9ea ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.35-23.40-generic 2.6.35.7
Tags: maverick maverick
Uname: Linux 2.6.35-23-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 09/14/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 02MX.M003.20100914.SCY
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: QX310/QX410/QX510/SF310/SF410/SF510
dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.board.version: 02MX
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 9
dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr02MX.M003.20100914.SCY:bd09/14/2010:svnSAMSUNGELECTRONICSCO.,LTD.:pnQX310/QX410/QX510/SF310/SF410/SF510:pvr02MX:rvnSAMSUNGELECTRONICSCO.,LTD.:rnQX310/QX410/QX510/SF310/SF410/SF510:rvr02MX:cvnSAMSUNGELECTRONICSCO.,LTD.:ct9:cvrN/A:
dmi.product.name: QX310/QX410/QX510/SF310/SF410/SF510
dmi.product.version: 02MX
dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: maverick
 architecture: x86_64
 kernel: 2.6.35-23-generic

[lspci]
00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (prog-if 00 [VGA controller])
     Subsystem: Samsung Electronics Co Ltd Device [144d:c08b]

Bryce Harrington (bryce) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command in a terminal after reproducing the issue, and it it will automatically gather debugging information needed for this bug:

  apport-collect 681904

Changed in xorg (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

bugbot (bugbot) on 2010-11-27
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
bugbot (bugbot) on 2010-11-27
tags: added: maverick

This bug is marked incomplete. Does that mean that I didn't provide enough information?

nascirek (slawomir-czyz) on 2010-12-04
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Confirmed
Daniel Manrique (roadmr) wrote :

I have been tinkering with the drivers for this hardware and I believe this bug should be moved to kernel, as per https://wiki.ubuntu.com/DebuggingTouchpadDetection.

The Samsung QX410 uses an Elantech trackpad. The psmouse driver includes support for some Elantech pads, but this particular one isn't recognized because it returns a different result when queried via the "magic knock" (function elantech_detect in elantech.c). This happens before the force_elantech module parameter comes into effect (which forces use of elantech when the firmware version is not recognized, but AFTER the magic knock has returned the expected result).

I forced the elantech driver to continue initializing the pad despite the unexpected reply to magic knock, and this is what I got (dmesg output):

[ 9721.216300] elantech: unexpected magic knock result 0x3c, 0x03, 0x00.
[ 9721.250065] elantech: Elantech version query result 0x85, 0x1b, 0x00.
[ 9721.284321] elantech: assuming hardware version 2, firmware version 133.27.0
[ 9721.318037] elantech: Synaptics capabilities query result 0x19, 0x14, 0x0c.
[ 9721.578902] elantech: retrying ps2 command 0xe6 (2).
[ 9722.094936] elantech: retrying ps2 command 0xf8 (2).
[ 9722.797061] elantech: retrying ps2 command 0xf8 (1).

If the system is rebooted with the modified psmouse driver, the device gets properly reported as a touchpad and all the relevant controls appear in the mouse control panel. However since data received from the pad is apparently not decoded properly by the psmouse driver (different encoding schema maybe), nothing really works: there's no pointer movement and the only thing that generates events (as read by evtest) are the left and right buttons (and then, not consistently).

I'm attaching output from evtest (keep in mind I was sliding my finger across the pad and clicking buttons, all that registers are the button clicks) and from dmesg, showing loss of sync and subsequent reconnection from the driver.

I hope this helps with this bug, I guess a lot of newer computers will start using these newer Elantech pads and it'd be great to have support out of the box.

Daniel Manrique (roadmr) wrote :

The modified psmouse driver gives the following output in /proc/bus/input/devices (only the section relevant to the touchpad):

I: Bus=0011 Vendor=0002 Product=000e Version=0000
N: Name="ETPS/2 Elantech Touchpad"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input23
U: Uniq=
H: Handlers=mouse0 event8
B: EV=b
B: KEY=6420 30000 0 0 0 0
B: ABS=f0003

Do keep in mind that, though with this little hack I managed to get the touchpad recognized, it's not functioning at all (no pointer functionality).

Stanislav (shisoik) on 2011-01-02
summary: - Samsung QX410 trackpad not recognized
+ Samsung QX310/QX410/QX510/SF310/SF410/SF510 trackpad/touchpad not
+ recognized

I believe this bug also affects the new Samsung NF210. Should I dump the apport-collect output here, or open a new bug?

Stanislav (shisoik) wrote :

I don't think you need to do the whole apport-collect. Just attach a file with dmesg output.

tags: added: kernel-input
EricDP (eric-arcticbears) wrote :

/var/log/dmesg from Samsung NF210

Please update the summary to include the Samsung RF710 as well. (17inch model)

Stanislav (shisoik) on 2011-01-06
summary: - Samsung QX310/QX410/QX510/SF310/SF410/SF510 trackpad/touchpad not
- recognized
+ Samsung QX310/QX410/QX510/SF310/SF410/SF510/NF210/RF510/RF710
+ trackpad/touchpad not recognized

Since this is a hardware detection issue, shouldn't it be reassigned to kernel so that the right people see it? Who can do that? It doesn't seem to me that this has anything to do with xorg-video-intel.

tags: added: kj-triage
EricDP (eric-arcticbears) wrote :

For my NF210, I also tested against Fedora kernel to determine if this was an Ubuntu thing or a more general kernel problem. Same issue. So I reported to bugzilla.kernel.org. Feel free to add comments to that bug if you have the same problem.

https://bugzilla.kernel.org/show_bug.cgi?id=27442

s0ullight (s0ullight) wrote :

I too have a samsung nf-210 and am also affected by this bug. This is indeed a kernel bug and not related to xserver-xorg-video-intel :)
Most likely the new protocol has to be reversed so a new patch for the psmouse driver can be written. Is there actually anyone working on this bug atm?

marth3r (marth3r) wrote :

I have a rf710, too, and recently filed a bug because of the touchpad not working...

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/683092

Changed in linux:
status: Unknown → Confirmed
guillermo (omempoderoso) wrote :

the same stuff happens in a rf410 14 inch model

Sascha Morr (saschamorr) wrote :

The same problem here at my samsung NF210 HZ1 :-(

Changed in linux:
importance: Unknown → Medium
Piotr Sokół (psokol) wrote :

I got the same with samsung rf510

On Wed, March 2, 2011 1:07 pm, Piotr Sokół wrote:
> I got the same with samsung rf510

This is now assigned to kernel, so I suspect it will get more attention if
the comments also go into the linked kernel bug. Nobody seems to be
looking here any more.

https://bugzilla.kernel.org/show_bug.cgi?id=27442

Changed in linux (Ubuntu):
assignee: nobody → Maria Sophie (thomas-garcia789)
summary: - Samsung QX310/QX410/QX510/SF310/SF410/SF510/NF210/RF510/RF710
+ Samsung QX310/QX410/QX510/SF310/SF410/SF510/NF210/RF410/RF510/RF710
trackpad/touchpad not recognized
chin (kheong2) on 2011-04-10
Changed in xserver-xorg-video-intel (Ubuntu):
assignee: nobody → chin (kheong2)
chin (kheong2) on 2011-04-11
Changed in xserver-xorg-video-intel (Ubuntu):
assignee: chin (kheong2) → nobody
bugbot (bugbot) on 2011-04-27
description: updated
bugbot (bugbot) on 2011-04-27
Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → New
status: New → Incomplete
bugbot (bugbot) on 2011-04-28
summary: - Samsung QX310/QX410/QX510/SF310/SF410/SF510/NF210/RF410/RF510/RF710
+ [arrandale] Samsung
+ QX310/QX410/QX510/SF310/SF410/SF510/NF210/RF410/RF510/RF710
trackpad/touchpad not recognized
Daniel Manrique (roadmr) on 2011-04-28
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Invalid
Bryce Harrington (bryce) on 2011-04-28
Changed in linux (Ubuntu):
importance: Undecided → Medium
milestone: none → natty-updates
status: New → Triaged
malko (jgotti) on 2011-06-06
tags: added: natty staging
summary: [arrandale] Samsung
- QX310/QX410/QX510/SF310/SF410/SF510/NF210/RF410/RF510/RF710
+ QX310/QX410/QX510/SF310/SF410/SF510/NF210/RF410/RF510/RF511/RF710
trackpad/touchpad not recognized
Seth Forshee (sforshee) on 2011-08-10
Changed in linux (Ubuntu):
assignee: Maria Sophie (thomas-garcia789) → Seth Forshee (sforshee)
status: Triaged → Incomplete
77 comments hidden view all 157 comments
Tory (tory-andrew-law) wrote :

#113 just worked for me on a Samsung NF210 =) thank you very much, this wasn't for me, it was for my younger sister. She will be happy. =)

LifeBringer (ra-thesungod) wrote :

I have the issue on the Acer 7560, will try comment 64 patch and report back.

LifeBringer (ra-thesungod) wrote :

Tried patch 64 on my 2.6.38-10-generic, worked beautiful. Shame that there aren't any 3-button, rotation, pinch gestures as of yet.

Chromos (sf12) wrote :

Patch 59 seems working perfect on my Asus K43SV Natty 2.6.38-10-generic :)
Thx

Nick Leytem (nicholas-leytem) wrote :

Tried patch from #113 on 2.6.38.11-generic on my Samsung RC512 and it gives me two-finger scrolling (finally!), a two-finger tap anywhere on touchpad will bring up the right-click menu, and double-tap-and-drag. As noted above, there is a bit of wobble. If there is middle-click emulation in this patch, I'm not able to do it.

Seth Forshee (sforshee) wrote :

I've posted an update to the driver, this time just as a dkms package. It's avaiable at

http://people.canonical.com/~sforshee/lp681904/psmouse-elantech-dkms/v0.1/psmouse-elantech-dkms_0.1_all.deb

Please test and let me know how it works. Thanks!

Daniel Manrique (roadmr) wrote :

Hi Seth,

Thanks so much for the deb for the dkms driver. Super-easy to install:

wget -c http://people.canonical.com/~sforshee/lp681904/psmouse-elantech-dkms/v0.1/psmouse-elantech-dkms_0.1_all.deb

sudo dpkg --install psmouse-elantech-dkms_0.1_all.deb

I simply rmmoded the old psmouse driver, then modprobed the old one on the fly and things started working. . Mouse pointer functionality, two finger scroll and double-tap-for-right-click are what I tested, all seem to work just as with the previous patch (I was using the dkms version of the elantech-v6 patch).

This is on Natty with a just-installed 2.6.38-11 kernel, running on a Samsung QX410.

My dmesg reads:

[ 148.846439] elantech: assuming hardware version 3, firmware version 133.27.0
[ 148.880705] elantech: Synaptics capabilities query result 0x19, 0x14, 0x0c.
[ 148.956447] elantech: x_max = 2934, y_max = 1630
[ 148.972206] input: ETPS/2 Elantech Touchpad as /devices/platform/i8042/serio1/input/input13

Let me know if you need more information.

Thanks again!

Nick Leytem (nicholas-leytem) wrote :
Download full text (4.5 KiB)

The update works great on my Samsung RC512 running Linux 2.6.38.11-generic.
Wobble is essentially gone.
Here is some of the output of dmesg:

[ 9620.220811] elantech: assuming hardware version 3, firmware version
69.15.0
[ 9620.256879] elantech: Synaptics capabilities query result 0x08, 0x15,
0x0c.
[ 9620.336893] elantech: x_max = 2508, y_max = 1320
[ 9620.352890] input: ETPS/2 Elantech Touchpad as
/devices/platform/i8042/serio1/input/input11

On Tue, Aug 23, 2011 at 8:57 AM, Seth Forshee <email address hidden>wrote:

> I've posted an update to the driver, this time just as a dkms package.
> It's avaiable at
>
> http://people.canonical.com/~sforshee/lp681904/psmouse-elantech-
> dkms/v0.1/psmouse-elantech-dkms_0.1_all.deb
>
> Please test and let me know how it works. Thanks!
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/681904
>
> Title:
> [arrandale] Samsung
> QX310/QX410/QX510/SF310/SF410/SF510/NF210/RF410/RF510/RF511/RF710
> trackpad/touchpad not recognized
>
> Status in The Linux Kernel:
> Confirmed
> Status in X.org xf86-video-intel:
> New
> Status in “linux” package in Ubuntu:
> Incomplete
> Status in “xserver-xorg-video-intel” package in Ubuntu:
> Invalid
>
> Bug description:
> Ubuntu 10.10, Samsung NP-QX410. Trackpad settings not available. Can
> use trackpad, can use left and right click, but no options available
> to adjust settings. Personally having issue of rubbing trackpad while
> I type and it is very annoying.
>
> The trackpad is recognized as a "PS/2 Logitech Wheel Mouse". No side
> scrolling, no disabling tap-to-click (annoying!) and no other trackpad
> settings available.
>
> How to reproduce:
> 1) install ubuntu on a samsung qx410
> 2) try, try, try and fail to make the touchpad work properly
> ---
> Architecture: amd64
> DRM.card0.DisplayPort.1:
> status: disconnected
> enabled: disabled
> dpms: On
> modes:
> edid-base64:
> DRM.card0.HDMI_Type_A.1:
> status: disconnected
> enabled: disabled
> dpms: On
> modes:
> edid-base64:
> DRM.card0.LVDS.1:
> status: connected
> enabled: enabled
> dpms: On
> modes: 1366x768
> edid-base64:
> AP///////wBMo1AyAAAAAAAUAQOAHxF4Cgnll1dUiiciUFQAAAABAQEBAQEBAQEBAQEBAQEBhBtWeFAAFjAwICUANa4QAAAZAAAADwAAAAAAAAAAAB60AnQAAAAA/gBTQU1TVU5HCiAgICAgAAAA/gBMVE4xNDBBVDE3ODAxANw=
> DRM.card0.VGA.1:
> status: disconnected
> enabled: disabled
> dpms: On
> modes:
> edid-base64:
> DistroRelease: Ubuntu 10.10
> DkmsStatus:
>
> InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64
> (20101007)
> MachineType: SAMSUNG ELECTRONICS CO., LTD.
> QX310/QX410/QX510/SF310/SF410/SF510
> Package: xorg 1:7.5+6ubuntu3
> PackageArchitecture: amd64
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-23-generic
> root=UUID=75a97d0d-7483-4000-8519-03687885d9ea ro quiet splash
> ProcEnviron:
> PATH=(custom, user)
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.35-23.40-generic 2.6.35.7
> Tags: maverick maverick
> Uname: Linux 2.6.35-23-generic x86_64
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
> dmi.bios.date...

Read more...

himegoto (larcsoul) wrote :

I just installed http://people.canonical.com/~sforshee/lp681904/psmouse-elantech-dkms/v0.1/psmouse-elantech-dkms_0.1_all.deb (#123)
On my Samsung netbook NF210.

It didn't work for me and now trackpad is not responding. I am new to Linux may it be some missing settings?
I just used Package installer on it and then restarted.

Thanks.

Zaki Manian (zmanian) wrote :

After install the .deb package from Seth,

sudo rmmod psmouse
sudo modprobe -a psmouse

you should get the following in dmesg

dmesg | grep elantech
[ 442.325784] elantech: assuming hardware version 3, firmware version
21.11.0
[ 442.365853] elantech: Synaptics capabilities query result 0x78, 0x14,
0x0a.
[ 442.452551] elantech: x_max = 1944, y_max = 864

On Tue, Aug 23, 2011 at 6:02 PM, himegoto <email address hidden> wrote:

> I just installed
> http://people.canonical.com/~sforshee/lp681904/psmouse-elantech-dkms/v0.1/psmouse-elantech-dkms_0.1_all.deb(#123)
> On my Samsung netbook NF210.
>
> It didn't work for me and now trackpad is not responding. I am new to Linux
> may it be some missing settings?
> I just used Package installer on it and then restarted.
>
> Thanks.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/681904
>
> Title:
> [arrandale] Samsung
> QX310/QX410/QX510/SF310/SF410/SF510/NF210/RF410/RF510/RF511/RF710
> trackpad/touchpad not recognized
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/linux/+bug/681904/+subscriptions
>

himegoto (larcsoul) wrote :

Thanks Zaki.
However after
sudo rmmod psmouse

It gave me an error. Module psmouse does not exist in /proc/modules

I understand this isn't a board for me to raise more questions but I could really use some help on this, since my pad isn't working now.
Thanks a lot.

EricDP (eric-arcticbears) wrote :

I just tried the DKMS in post 123 on an nf210

uname -a yields...

Linux elara 2.6.38-10-generic #46-Ubuntu SMP Tue Jun 28 15:05:41 UTC 2011 i686 i686 i386 GNU/Linux

The module won't load. modprobe gives...

FATAL: Error inserting psmouse (/lib/modules/2.6.38-10-generic/updates/dkms/psmouse.ko): Unknown symbol in module, or unknown parameter (see dmesg)

bottom lines of dmesg are...

[92650.108872] psmouse: Unknown symbol hgpk_module_init (err 0)
[92650.111041] psmouse: Unknown symbol hgpk_init (err 0)
[92650.115138] psmouse: Unknown symbol hgpk_detect (err 0)

himegoto (larcsoul) wrote :

Thanks Eric.

Could you please post how to revert back so I could use the trackpad again haha

I just saw there's a release that works with nf210 hopefully in post #113 but couldn't get it started either. Looks like I need to fix the trackpad first.

Thanks in advance.

Seth Forshee (sforshee) wrote :

himegoto: First, please run 'sudo modprobe psmouse' (which I'm expecting will fail), then 'dmesg > dmesg-psmouse-elantech-dkms.txt'. Please provide the output from modprobe and the dmesg-psmouse-elantech-dkms.txt file here. After that you can remove the package by running 'sudo dpkg -r psmouse-elantech-dkms'. Then running 'sudo modprobe psmouse' should get your touchpad working again.

EricDP: Your problem is due to configuration differences between i386 and amd64 kernels in conjunction with how I created the dkms package. I've uploaded a new package which should fix this. Please give it a try.

http://people.canonical.com/~sforshee/lp681904/psmouse-elantech-dkms/v0.2/psmouse-elantech-dkms_0.2_all.deb

Seth Forshee (sforshee) on 2011-08-25
Changed in linux (Ubuntu):
status: Incomplete → In Progress
f_padia (f-padia) wrote :

Hi Seth, thanks for your support with this. I have a Samsung SF310 and am running ubuntu natty (whatever the default kernel is). I have installed your patch from post #123. Most things work but I cant click and drag with 2 fingers (i.e. click left mouse button and drag with the other finger). is this a known issue or is it supposed to work? It was working fine with the patch from post #63 but its no longer working correctly. Can you advise on what I need to do?

p.s. I did sudo rmmod psmouse
sudo modprobe -a psmouse

after installing the package if that makes any difference.

Thanks

himegoto (larcsoul) wrote :

Seth, many thanks I could use the pad again.
However I couldn't find the txt.
I saved all the commands from "dmesg", will that be useful to you? It's huge lines of commands.

Thanks.

Seth Forshee (sforshee) on 2011-08-26
Changed in linux (Ubuntu Oneiric):
status: In Progress → Fix Committed
EricDP (eric-arcticbears) wrote :

v0.2 seems to be working on my nf210 with the 32-bit fix. I didn't test everything, but being able to disable tap-to-click and have two-finger scroll working is good enough for me. And having a DKMS package so I'm not building from scratch is a definite bonus. Thanks!

himegoto (larcsoul) wrote :

Seth,
I tried the 0.2 you gave in #132
The side scrolls now works but 2 finger scroll didn't.

[ 1724.624233] psmouse serio1: ID: 10 00 64
[ 1724.732160] elantech: assuming hardware version 3, firmware version 21.11.0
[ 1724.772190] elantech: Synaptics capabilities query result 0x78, 0x14, 0x0a.
[ 1724.859403] elantech: x_max = 1944, y_max = 864
[ 1724.876776] input: ETPS/2 Elantech Touchpad as /devices/platform/i8042/serio1/input/input14

If this'll be useful to you :)
Thanks.

Nick Leytem (nicholas-leytem) wrote :

The 0.2 from #132 now allows me to scroll horizontally but I can't disable tap-to-click (Samsung RC512).
Output from dmesg:
[ 7166.521312] elantech: assuming hardware version 3, firmware version 69.15.0
[ 7166.557507] elantech: Synaptics capabilities query result 0x08, 0x15, 0x0c.
[ 7166.643090] elantech: x_max = 2508, y_max = 1320
[ 7166.659434] input: ETPS/2 Elantech Touchpad as /devices/platform/i8042/serio1/input/input14

LD (ldwatson) wrote :

I applied the patch at comment 64 to my Samsung NC210 netbook running 64 bit Ubuntu 11.04 (kernel 2.6.38.11) and after a reboot the touchpad is recognised (previously it had been detected as a psmouse. Mouse preferences now has a touchpad tab which allows me to turn off mouse-clicks on the touchpad, and activate two finger scrolling. This is fine for me.

Benji (benjim) wrote :

@Seth: Patch from #132 working fine for me.
running Xubuntu 11.04 with 2.6.38-11-generic on a Samsung RC710.

For drag-and-drop, two finger right click, and three finger center click I had to set Synaptics Tap Action to 0, 0, 1, 1, 1, 3, 2.

(If somebody is looking for it:
xinput list
Should show you a device ETPS/2 Elantech Touchpad. Look for its ID. Then set
xinput set-int-prop <ID> 292 8 0 0 1 1 1 3 2

You can take a look at the properties with xinput list-props <ID> if the Property ID changes (in this case the 292). )

Launchpad Janitor (janitor) wrote :
Download full text (4.9 KiB)

This bug was fixed in the package linux - 3.0.0-10.16

---------------
linux (3.0.0-10.16) oneiric; urgency=low

  [ Andy Whitcroft ]

  * Revert "ubuntu: compcache -- follow changes to bd_claim/bd_release"
    - LP: #832694
  * Revert "ubuntu: compcache -- version 0.5.3"
    - LP: #832694
  * [Config] dropping compcache configuration options

  [ David Henningsson ]

  * SAUCE: ALSA: HDA: hdmi: Emit pcm device index for jack input devices

  [ Kees Cook ]

  * [Config] enable and enforce SECCOMP_FILTER on x86

  [ Leann Ogasawara ]

  * [Config] Update CONFIG_EFI_VARS enforcer check
  * [Config] Enable CONFIG_ECHO=m on powerpc
  * [Config] Enable CONFIG_ET131X=m on powerpc
  * [Config] Set CONFIG_FB_MATROX=m
  * [Config] Enable CONFIG_FB_UDL=m on powerpc
  * [Config] Set CONFIG_FB_VIRTUAL=n
  * [Config] Enable CONFIG_FB_VGA16=m on powerpc
  * [Config] Enable CONFIG_GPIO_MAX732X=m on arm
  * [Config] Enable CONFIG_GPIO_PCF857X=m on arm
  * [Config] Set CONFIG_HOTPLUG_PCI_FAKE=m
  * [Config] Enable CONFIG_HOTPLUG_PCI=y on powerpc
  * [Config] Enable CONFIG_HOTPLUG_PCI_CPCI=y on powerpc
  * [Config] Enable CONFIG_HP_ILO=m on powerpc-smp
  * [Config] Enable CONFIG_I2C_PASEMI=m on powerpc
  * [Config] Enable CONFIG_IBM_BSR=m on powerpc
  * [Config] Enable CONFIG_IBMVETH=m on powerpc
  * [Config] Enable CONFIG_IDE_PHISON=m on powerpc
  * [Config] Enable CONFIG_IGB=m on powerpc
  * [Config] Enable CONFIG_IIO=m on powerpc
  * [Config] Enable CONFIG_INFINIBAND_NES=m
  * [Config] Enable CONFIG_IPMI_HANDLER=m on arm
  * [Config] Enable CONFIG_IWL3945=m on powerpc
  * [Config] Disable CONFIG_KVM_BOOK3S_64
  * [Config] Enable CONFIG_LAPBETHER=m on arm
  * [Config] Enable CONFIG_LEDS_GPIO=m on powerpc
  * [Config] Enable CONFIG_LEDS_CLEVO_MAIL=m all arch's
  * [Config] Enable CONFIG_LEDS_PCA9532=m on powerpc
  * [Config] Enable CONFIG_LEDS_PCA955X=m on powerpc
  * [Config] Enable CONFIG_LEDS_TRIGGER_DEFAULT_ON=m on powerpc
  * [Config] Set CONFIG_LEDS_TRIGGER_HEARTBEAT=m on arm and powerpc
  * [Config] Set CONFIG_LEDS_TRIGGER_TIMER=m on powerpc
  * [Config] Enable CONFIG_LINE6_USB=m on arm and powerpc
  * [Config] Enable CONFIG_MEMSTICK=m on arm
  * [Config] Enable CONFIG_MTD_AFS_PARTS=m on arm
  * [Config] Enable CONFIG_MTD_ALAUDA=m on arm
  * [Config] Enable CONFIG_MTD_AR7_PARTS=m on arm
  * [Config] Enable CONFIG_MTD_ARM_INTEGRATOR=m on arm
  * [Config] Enable CONFIG_MOXA_SMARTIO=m on powerpc
  * [Config] Enable CONFIG_MTD_DATAFLASH=m on arm
  * [Config] Enable CONFIG_MTD_GPIO_ADDR=m on arm
  * [Config] Enable CONFIG_MTD_IMPA7=m on arm
  * [Config] Enable CONFIG_MTD_NAND_GPIO=m on arm
  * [Config] Enable CONFIG_MTD_NAND_NANDSIM=m on arm
  * [Config] Enable CONFIG_MTD_NAND_PASEMI=m on powerpc
  * [Config] Enable CONFIG_MTD_NAND_PLATFORM=m on arm
  * [Config] Enable CONFIG_MTD_NAND_TMIO=m on arm
  * [Config] Enable CONFIG_MTD_SST25L=m on arm
  * [Config] Enable CONFIG_NET_CLS_CGROUP=y on arm
  * [Config] Enable CONFIG_NET_CLS_FLOW=m on arm
  * [Config] Enable CONFIG_NET_CLS_U32=m on arm
  * [Config] Enable CONFIG_NET_DCCPPROBE=m on arm
  * [Config] Enable CONFIG_NET_SCH_INGRESS=m on arm
  * [Config] Enable CONFIG_NET_TCPPROBE=m on arm
  * [Config] Enable...

Read more...

Changed in linux (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Nick Leytem (nicholas-leytem) wrote :

After installing Linux Kernel 3.0.4, the wobble has returned and I still can't enable middle click, disable tapping, or disable touchpad while typing.

Nate Cox (akujin) wrote :

Patch on post 132 worked perfectly for me. Trackpad, two-finger touch for right click and two-finger scroll function as they should.

It'd be nice to see some support from elantech on this, though, to get the full range of features working properly. It really is a cool trackpad... even though I'd kill for a regular synaptics after this enormous hassle getting it working.

Craig (cslush) wrote :

I have just upgraded to oneiric and I am still unable to properly use my trackpad. Here are some details:

Samsung QX410-J01

$ uname -a
Linux craig-laptop 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:56:25 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

$ lspci
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 02)
00:01.0 PCI bridge: Intel Corporation Core Processor PCI Express x16 Root Port (rev 02)
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:1a.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 05)
00:1c.3 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 4 (rev 05)
00:1d.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a5)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 05)
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 05)
01:00.0 3D controller: nVidia Corporation GT218 [GeForce 310M] (rev a2)
02:00.0 Network controller: Intel Corporation Centrino Advanced-N + WiMAX 6250 (rev 5f)
03:00.0 Ethernet controller: Marvell Technology Group Ltd. Yukon Optima 88E8059 [PCIe Gigabit Ethernet Controller with AVB] (rev 11)
3f:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
3f:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
3f:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
3f:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 02)
3f:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
3f:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 02)

$ dmesg | grep PS/2
[ 1.030925] i8042: PNP: PS/2 Controller [PNP0303:PS2K,PNP0f13:PSM1] at 0x60,0x64 irq 1,12
[ 1.033970] mousedev: PS/2 mouse device common for all mice
[ 10.299246] input: PS/2 Generic Mouse as /devices/platform/i8042/serio1/input/input7

$ dmesg | grep elantech
$

Are there any other details I can provide? Thanks, I'd love to be able to take advantage of these features!

Seth Forshee (sforshee) wrote :

On Sat, Oct 15, 2011 at 12:51:08AM -0000, Craig wrote:
> I have just upgraded to oneiric and I am still unable to properly use my
> trackpad. Here are some details:
>
> Samsung QX410-J01

Craig: We have some successful testing with the QX410, but it appears
that there may be more than one variant of this model. Please open a new
bug for your issue by running 'ubuntu-bug linux' in a terminal. Thanks!

Craig (cslush) wrote :

Thanks Seth. Created related bug #875154 for this issue.

f_padia (f-padia) wrote :

upgraded to oneiric but I still cant click and drag with 2 fingers?? anyone else have this? or is just me? everything else seems to work

Samsung SF310 by the way

nascirek (slawomir-czyz) wrote :

I noticed that touchpad features like two finger right click, two finger scrolling work fine on QX510 after fresh install of Oneric.

I've noticed very similar symptoms on a Samsung 700Z laptop with an elantech touchpad. I think it might be a newer model number than is found in this driver? I created a bug #894515 to track this.

LaM (l.a.m.) wrote :

Hi all,

I'm on Ubuntu 10.10 with custom compiled kernel (Linux Menetius 3.1.4 #1 SMP PREEMPT Fri Dec 9 18:09:45 CET 2011 x86_64 GNU/Linux)

I'm quite a newbie so plz don't shoot me asking this question: how can I apply this kernel patch?

I mean...I've downloaded kernel 3.1 from kernel.org...then? before compiling how can I apply it?

Thx in advance to whoever will reply!!

CDR Services (cdr-) wrote :

I have a QX 410 running ubuntu 11.04 and the trackpad issue is as follows. The Elantec Trackpad or "Magicpad" is misdetected as a generic ps2 mouse so scroll functions aer not available also Trackpad doesn't disable while typing! I hav also tried installing the new Ubuntu 11.10 and the problem is worse in 11.10 the left and right trackpad button both do a left click so context menus and right click options don't work either!

Seth Forshee (sforshee) wrote :

On Sun, Jan 01, 2012 at 03:47:40PM -0000, CDR Services wrote:
> I have a QX 410 running ubuntu 11.04 and the trackpad issue is as
> follows. The Elantec Trackpad or "Magicpad" is misdetected as a generic
> ps2 mouse so scroll functions aer not available also Trackpad doesn't
> disable while typing! I hav also tried installing the new Ubuntu 11.10
> and the problem is worse in 11.10 the left and right trackpad button
> both do a left click so context menus and right click options don't work
> either!

Please file a new bug for your issue by running 'ubuntu-bug linux' in a
terminal. Thanks!

Kmassada (kmassada-gmail) wrote :
Download full text (3.3 KiB)

thanks for helping me detect my mouse.
Here are my xinput, lspci, dmesg, here is what i'm now unsure of, how do I get the touchpad window under mouse options so I can set two finger scrolling or other multitouch functions. when I try synclient, I get the following error.

makezan@700Z3A:~$ synclient
Couldn't find synaptics properties. No synaptics driver loaded?

makezan@700Z3A:~$ xinput list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ PS/2 Elantech Touchpad id=12 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Video Bus id=8 [slave keyboard (3)]
    ↳ Power Button id=9 [slave keyboard (3)]
    ↳ WebCam SC-13HDL11431N id=10 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=11 [slave keyboard (3)]

makezan@700Z3A:~$ lspci
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB Controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b4)
00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 (rev b4)
00:1d.0 USB Controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset Family LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 04)
01:00.0 VGA compatible controller: ATI Technologies Inc NI Seymour [AMD Radeon HD 6470M]
02:00.0 Network controller: Intel Corporation Centrino Advanced-N 6230 (rev 34)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)
04:00.0 USB Controller: ASMedia Technology Inc. ASM1042 SuperSpeed USB Host Controller

makezan@700Z3A:~$ dmesg | grep PS/2
[ 1.111094] i8042: PNP: PS/2 Controller [PNP0303:PS2K,PNP0f13:EPAD] at 0x60,0x64 irq 1,12
[ 1.11456...

Read more...

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu laptop testing tracker.

A list of all reports related to this bug can be found here:
http://laptop.qa.ubuntu.com/qatracker/reports/bugs/681904

tags: added: laptop-testing
Changed in linux:
status: Confirmed → Fix Released
nik.martin (nik-martin) wrote :

This driver is broken on official kernel 3.8. In linux/drivers/input/mouse/input-mt.c:
function input_mt_init_slots now requires 3 args, with the new arg being flags. I set flags to 0 in synaptics.c:699 in this patch and it re-compiled fine. I have no clue as to what that will break, but I saw in the mainline kernel synaptics.c that's what it was set to.

/**
 * input_mt_init_slots() - initialize MT input slots
 * @dev: input device supporting MT events and finger tracking
 * @num_slots: number of slots used by the device
 * @flags: mt tasks to handle in core
 *
 * This function allocates all necessary memory for MT slot handling
 * in the input device, prepares the ABS_MT_SLOT and
 * ABS_MT_TRACKING_ID events for use and sets up appropriate buffers.
 * Depending on the flags set, it also performs pointer emulation and
 * frame synchronization.
 *
 * May be called repeatedly. Returns -EINVAL if attempting to
 * reinitialize with a different number of slots.
 */
int input_mt_init_slots(struct input_dev *dev, unsigned int num_slots,
                        unsigned int flags)

avb (avbweb) wrote :

My specs are: Samsung Series 7 Ultrabook 730U3E, Ubuntu Raring Ringtail 13.04 (development branch), Kernel 3.8.0-15.

I can confirm this bug in raring. Synclient can't find synaptics properties and there is no touchpad-tab in mouse settings gui.

Two-finger-scrolling, edge-scrolling and multi-touch stuff is not working. Left and right buttons are working, though.

---

synclient
Couldn't find synaptics properties. No synaptics driver loaded?

---

xinput -list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ Logitech USB Receiver id=10 [slave pointer (2)]
⎜ ↳ Logitech USB Receiver id=11 [slave pointer (2)]
⎜ ↳ PS/2 Elantech Touchpad id=14 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Video Bus id=8 [slave keyboard (3)]
    ↳ Power Button id=9 [slave keyboard (3)]
    ↳ WebCam SC-10HDP12631N id=12 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=13 [slave keyboard (3)]

---

lspci
00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.3 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 4 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM76 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
01:00.0 Display controller: Advanced Micro Devices [AMD] nee ATI Mars [Radeon HD 8500/8700M Series]
02:00.0 Network controller: Intel Corporation Centrino Advanced-N 6235 (rev 24)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller (rev 06)

avb (avbweb) wrote :

Xorg.log:

[ 740.486] (II) config/udev: Adding input device PS/2 Elantech Touchpad (/dev/input/event12)
[ 740.486] (**) PS/2 Elantech Touchpad: Applying InputClass "evdev pointer catchall"
[ 740.486] (II) Using input driver 'evdev' for 'PS/2 Elantech Touchpad'
[ 740.486] (**) PS/2 Elantech Touchpad: always reports core events
[ 740.486] (**) evdev: PS/2 Elantech Touchpad: Device: "/dev/input/event12"
[ 740.486] (--) evdev: PS/2 Elantech Touchpad: Vendor 0x2 Product 0x1
[ 740.487] (--) evdev: PS/2 Elantech Touchpad: Found 3 mouse buttons
[ 740.487] (--) evdev: PS/2 Elantech Touchpad: Found relative axes
[ 740.487] (--) evdev: PS/2 Elantech Touchpad: Found x and y relative axes
[ 740.487] (II) evdev: PS/2 Elantech Touchpad: Configuring as mouse
[ 740.487] (**) evdev: PS/2 Elantech Touchpad: YAxisMapping: buttons 4 and 5
[ 740.487] (**) evdev: PS/2 Elantech Touchpad: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[ 740.487] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input12/event12"
[ 740.487] (II) XINPUT: Adding extended input device "PS/2 Elantech Touchpad" (type: MOUSE, id 14)
[ 740.487] (II) evdev: PS/2 Elantech Touchpad: initialized for relative axes.
[ 740.487] (**) PS/2 Elantech Touchpad: (accel) keeping acceleration scheme 1
[ 740.487] (**) PS/2 Elantech Touchpad: (accel) acceleration profile 0
[ 740.487] (**) PS/2 Elantech Touchpad: (accel) acceleration factor: 2.000
[ 740.487] (**) PS/2 Elantech Touchpad: (accel) acceleration threshold: 4
[ 740.487] (II) config/udev: Adding input device PS/2 Elantech Touchpad (/dev/input/mouse1)
[ 740.487] (II) No input driver specified, ignoring this device.
[ 740.487] (II) This device may have been added with another device file.

avb (avbweb) on 2013-03-31
Changed in xserver-xorg-video-intel (Ubuntu Oneiric):
status: Invalid → Confirmed
status: Confirmed → Invalid
clemmy (luca-clem) wrote :

I'm very interested in comment #154 by nik.martin. I've understood that I should assign a 0 as the missing arg, but I'm not sure about how to do it in practice.

Line 699 looks like this now:
  input_mt_init_slots(dev, 2);
Should I change it to something like the following?
  input_mt_init_slots(dev, 2, 0);

Thanks a lot for any help

Changed in linux (Ubuntu):
assignee: Seth Forshee (sforshee) → Guilherme Grunewald (pinoya)
Displaying first 40 and last 40 comments. View all 157 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.