"lo: Disabled Privacy Extensions" keeps showing up in the system log

Bug #590537 reported by LGB [Gábor Lénárt] on 2010-06-06
160
This bug affects 29 people
Affects Status Importance Assigned to Milestone
Linux
New
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
linux-2.6 (Debian)
Fix Released
Unknown
vsftpd (Debian)
Fix Released
Unknown
vsftpd (Ubuntu)
Medium
Unassigned

Bug Description

 Recently (I hadn't got this before) I see more and more message of this in kernel log:

lo: Disabled Privacy Extensions

I am wondering what it means and what cause this, can I do something to avoid this issue, if it's that at all? Since the message does not tell too much if it's a problem or not, or what it is exactly at least ...

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-22-generic 2.6.32-22.36
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.32-22.35-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic i686
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC2: lgb 2380 F.... pulseaudio
 /dev/snd/controlC1: lgb 2380 F.... pulseaudio
 /dev/snd/controlC0: lgb 2380 F.... pulseaudio
 /dev/snd/pcmC0D0p: lgb 2380 F...m pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Live'/'SB Live! Value [CT4832] (rev.8, serial:0x80271102) at 0xa000, irq 17'
   Mixer name : 'TriTech TR28602'
   Components : 'AC97a:54524123'
   Controls : 216
   Simple ctrls : 38
Card1.Amixer.info:
 Card hw:1 'SAA7134'/'saa7134[0] at 0xd0000000 irq 18'
   Mixer name : 'SAA7134 Mixer'
   Components : ''
   Controls : 6
   Simple ctrls : 3
Card2.Amixer.info:
 Card hw:2 'U0x46d0x8da'/'USB Device 0x46d:0x8da at usb-0000:00:02.0-1, full speed'
   Mixer name : 'USB Mixer'
   Components : 'USB046d:08da'
   Controls : 3
   Simple ctrls : 2
Date: Mon Jun 7 00:29:56 2010
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=c1f97893-2241-4284-90e9-0d792217d9a7
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.

 vboxnet0 no wireless extensions.
Lsusb:
 Bus 002 Device 004: ID 04d9:1503 Holtek Semiconductor, Inc. Shortboard Lefty
 Bus 002 Device 003: ID 045e:0039 Microsoft Corp. IntelliMouse Optical
 Bus 002 Device 002: ID 046d:08da Logitech, Inc. QuickCam Messanger
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: System manufacturer System Product Name
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-22-generic root=UUID=a5601479-5c0c-426e-931b-fe8ab0d82b50 ro splash quiet
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.34
RfKill:

SourcePackage: linux
UserAsoundrc:
 # ALSA library configuration file

 # Include settings that are under the control of asoundconf(1).
 # (To disable these settings, comment out this line.)
 </home/lgb/.asoundrc.asoundconf>
WpaSupplicantLog:

dmi.bios.date: 06/08/2005
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: ASUS A8N-E ACPI BIOS Revision 1005
dmi.board.name: A8N-E
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: 2.XX
dmi.chassis.asset.tag: 123456789000
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvrASUSA8N-EACPIBIOSRevision1005:bd06/08/2005:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnA8N-E:rvr2.XX:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

LGB [Gábor Lénárt] (lgb) wrote :
Jeremy Foshee (jeremyfoshee) wrote :

Hi LGB,

If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
cnom (cnom) wrote :

Still under 32bit 9.10 (2.6.31-22-generic) but maybe helpful to get an idea where to look: I get these messages every time I connect to my local vsftpd, even before auth.

I just noticed this problem on Epia Kernel. Like with Conrad, it seems associated with accessing the VSFTP deamon.

Hello,
I have the same Problem with vsftpd on ubuntu 10.04 Server.
Kernel 2.6.32-23-server x86_64.
Every time a user connects to the ftp service we see such a warning message in the logs.
I run a public ftp/http mirror server and get 40000 warnings every hour.
After shutting down the vsftpd everything looks ok and the warnings dissapear.

Today i tested against Kernel 2.6.32-02063216-generic from http://kernel.ubuntu.com/~kernel-ppa/mainline
and still see the warning lo: Disabled Privacy Extensions

tags: removed: needs-upstream-testing

tested against 2.6.35-020635rc1-generic and bug still exists

Colan Schwartz (colan) wrote :

I'm not running anything even close to VSFTPd, but I'm getting these anyway.

I did, however, see this in the logs a few hours before I started getting these errors:
"NetworkManager: <info> DHCP: device eth0 state changed bound -> renew"

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
summary: - lo: Disabled Privacy Extensions
+ "lo: Disabled Privacy Extensions" keeps showing up in the system log
Andika Triwidada (andika) wrote :

Info here might be still relevant http://www.mentby.com/tom-h/lo-disabled-privacy-extensions.html although it was for KK

Changed in debian:
status: Unknown → New

Hello. I have the same problem "lo: Disabled Privacy Extensions" and I've noticed that it happens when I activate my pppoe connection.

Stefano Rivera (stefanor) wrote :

I can confirm Christian's observation that stopping vsftpd stops these messages.

affects: debian → linux-2.6 (Debian)
Changed in vsftpd (Debian):
status: Unknown → New
Mathias Gug (mathiaz) on 2010-11-16
Changed in vsftpd (Ubuntu):
importance: Undecided → Medium
darthanubis (darthanubis) wrote :

vsftpd is not installed and I still get these errors.

Linux ganesa 2.6.35-23-generic #41-Ubuntu SMP Wed Nov 24 11:55:36 UTC 2010 x86_64 GNU/Linux
10.10

Sébastien CANCHON (scanchon) wrote :

Try to disable ipv6 (if you don't use it) at kernel boot: ipv6.disable=1.
Dirty, but it works (no messages after).

Jonathan Davies (jpds) wrote :

Some people in this bug report (myself included) are actively using IPv6 and vsftpd on production systems, so disabling IPv6 is not an option.

Tom-H4 writes for ubuntu-users mailing list
http://old.nabble.com/lo:-Disabled-Privacy-Extensions-td26630008.html

---------- snip ---------

It is a kernel config - IPV6_PRIVACY - and it is set to "y" in KK so
you would have to recompile your kernel in order to set it to "n" or
"m".

The corresponding proc entry is
/proc/sys/net/ipv6/conf/lo/use_tempaddr

and when I "sysctl" or "cat" mine, it returns "-1". (And it is 0 for wlan0.)

You could sysctl yours to "-1" if it isn't and it might stop the
"Privacy" messages. (And if it isn't set to "-1" for KK server
edition, you might want to file a bug report.)

The values that use_tempaddr can take are

<= 0 disable Privacy Extensions

== 1 enable Privacy Extensions, but prefer public addresses over
temporary addresses

> 1 enable Privacy Extensions and prefer temporary addresses over public addresses

Default 0 (for most devices)

Default -1 (for point-to-point devices and loopback devices)

tags: added: regression-release
removed: regression-potential
yamo (stephane-gregoire) wrote :

Hi,
I have this error since I've installed vsftpd 2.3.0~pre2-4ubuntu2 on Ubuntu 10.10.

Changed in linux-2.6 (Debian):
status: New → Fix Released

Hi,

Bug Watch Updater a tapoté, le 10/01/2011 19:58:
> ** Changed in: linux-2.6 (Debian)
> Status: New => Fix Released
>
The bug is not resolved but archived!

Ben Hutchings didn't said what was the configuration error.

--
Stéphane

<http://pasdenom.info/fortune/>

Une femme fidèle rend un seul homme malheureux.
 -+- Alfred Capus (1858-1922) -+-

libbi (libbi) on 2011-01-20
Changed in linux (Ubuntu):
assignee: nobody → libbi (libbi)
assignee: libbi (libbi) → nobody
Cristiano Nunes (cfgnunes) wrote :

This message apears every time when open Chromium.

Changed in linux-2.6 (Debian):
status: Fix Released → New
Chuck Short (zulcss) on 2011-03-07
Changed in vsftpd (Ubuntu):
status: New → Confirmed
Changed in linux-2.6 (Debian):
status: New → Fix Released
Max (maxmax) wrote :

The message: "lo: Disabled Privacy Extensions"

Is also logged when starting google "Chromium 10.0.648.127 (Developer Build 76697) Ubuntu 10.04" on a system patched upto "2.6.32-29-generic #58-Ubuntu SMP".

Steve Roberts (drgrumpy) wrote :

I also just saw it for the first time when starting chromium, kernel 2.6.35-280generic 64bit.

Lealcy B. Junior (lealcy) wrote :

Happens to me every time I open Chromium.

Linux lealcy 2.6.35-28-generic #49-Ubuntu SMP Tue Mar 1 14:39:03 UTC 2011 x86_64 GNU/Linux

Najzlijiji (najzlijiji) wrote :

stopping vsftpd removes the error... it is not solution to problem tho.. but it can suspend those ugly messages

description: updated
Paolo Pelloni (briga) wrote :

It happens here on a server 10.04.02 64bit every 300.?????? ticks or five minutes

Kernel is: 2.6.32-31-server #61-Ubuntu SMP Fri Apr 8 19:44:42

/proc/sys/net/ipv6/conf/lo/use_tempaddr
is set to -1

I have stopped vsftpd and the log entries stopped too.
I have restarted vsftpd and they came back but not just after the start ... few minutes after. Exactly at the same time when the nagios daemon checked the FTP service. So I believe the login is the trigger:

May 19 10:40:06 rf-s02 kernel: [677765.815457] lo: Disabled Privacy Extensions
Thu May 19 10:40:06 2011 [pid 2] CONNECT: Client "192.168.1.190"

Stefano Rivera (stefanor) wrote :

This appears to be have been resolved in a lucid kernel update in the last couple of months. Haven't dug to find which one, though.

Stefano Rivera (stefanor) wrote :

For the record, the upstream commit was 2fdc1c8093255f9da877d7b9ce3f46c2098377dc

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Stefano Rivera (stefanor) wrote :

Given that this is fixed in the kernel, marking the vstftpd task wontfix.

Changed in vsftpd (Ubuntu):
status: Confirmed → Won't Fix
Changed in vsftpd (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.