Amilo 1520 sleep doesn't resume touchpad from suspend on ram

Reported by stefab on 2006-07-14
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Wishlist
Unassigned

Bug Description

Sleep mode work fine on Fujitsu-Siemens amilo si 1520 but doesn't resume on wakeup touchpad doesn't work anymore.

Richard Hughes (richard-hughes) wrote :

I think you want to file this against acpi-support (although when ubuntu gets pm-utils the problem should be sorted)

stefab (bluefuture) wrote :

Probably is involved acpi-support but i dosen't know if there are also some bugs in the DSDT (Differentiated System Description Table) of this laptop bios

stefab (bluefuture) wrote :

Data sheet is here:
http://server-uk.imrworldwide.com/cgi-bin/b?cg=COM-complete&ci=siemensfujitsu&tu=http://www.fujitsu-siemens.com/Resources/173/1127099518.pdf

With this bios option workaround resuming from sleep to ram works fine:
http://ubuntuforums.org/showthread.php?t=252011

but still there are some acpi problem about temperatures levels and fan.. its become more and more hot with ubuntu that running Windows.
I send an attachment of the DSDT error and warning hope that Ubuntu could try to make a little bit of pressure on fujtsu-simens for the next bios releases or Ubuntu will workaround DSDT problem with one of this techniques:

http://gentoo-wiki.com/HOWTO_Fix_Common_ACPI_Problems

Matthew Garrett (mjg59) wrote :

Can you attach dmesg for boots with the two different BIOS options?

It's normal that Linux will cause the machine to run hotter than Windows. Our run-time power management support is much worse.

stefab (bluefuture) wrote :

I send the two dmesg log.
But what package ubuntu suggest for run-time power management (powernowd?).
I think that this DSDT windows only compatibile (because compiled with microsoft compiler) can be a problem for right
power management on linux or is this false?

stefab (bluefuture) wrote :
Matthew Garrett (mjg59) wrote :

No, the DSDT should be fine. Linux just needs to be better at power management of individual devices.

stefab (bluefuture) wrote :

Please see also this[1]
As suggested by fellow user skipper (who I thank very much) there is a way to make the touchpad work after a suspend/resume.

The solution is a downgrade of the BIOS of the laptop to version 1.10. The problem, in fact, seems to be related to the two latest versions of the BIOS (v1.19 and v1.20). Anyone who does not necessarily need one of these two later BIOS versions, should downgrade to v1.10 to make suspend work.

If your SI1520 does not mount an Intel Core Duo (Yonah) D0 stepping processor (which means mainly those CPUs coded T2x00) you can downgrade to version 1.10. Otherwise you'll have to stick with a BIOS version >= 1.17 and with no touchpad after resume. :-(

[1] http://si1520.blogspot.com/2007/04/touchpad-finally-working-again-after.html

stefab (bluefuture) on 2007-05-01
Changed in linux-source-2.6.17:
status: Unconfirmed → Confirmed
stefab (bluefuture) wrote :

So acutally on .20 .22 kernels resume but touchpad doesn't work anymore.

Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-acpi
Thomas Krause (krause) wrote :

I can confirm the issue with the touchpad (my amilo si 1520 has been repaired and they were upgrading the bios) and that downgrading helps.

Is there anything Ubuntu can do that the newer BIOS-versions will work?

Additionally the wireless card (intel pro/wireless 3945ABG) will sometimes not re-appear after standby (using the old BIOS-version)

Henrik Nilsen Omma (henrik) wrote :

Marking this as a wishlist item, as it would require a workaround for broken BIOS. The best would probably be for Siemens to fix their BIOS.

Changed in linux-source-2.6.22:
importance: Undecided → Wishlist
Svein Tore Seljebotn (sveint) wrote :

I can confirm the touchpad not working after resume bug. Really strange problem...

stefab (bluefuture) wrote :

Actually the resume problem is about touchpad as upstram

description: updated
Changed in linux:
status: Unknown → Confirmed
Changed in linux:
status: Confirmed → Incomplete
Changed in linux:
status: Incomplete → In Progress
Changed in linux:
status: In Progress → Incomplete
Changed in linux:
status: Incomplete → In Progress

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

stefab (bluefuture) on 2008-08-14
Changed in linux:
status: Incomplete → New

This bug a while ago and there hasn't been any activity in it recently. Would anyone be willing confirm if this is still an issue with the latest Alpha for the upcoming Intrepid Ibex 8.10. You should be able to test via a LiveCD - http://www.ubuntu.com/testing. Please let us know your results. Thanks.

Changed in linux:
status: New → Incomplete
stefab (bluefuture) wrote :

I have tested with the last version of intepid and the bug still here.
Please check the upstream status.

Changed in linux:
status: Incomplete → Confirmed

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

stefab (bluefuture) wrote :

Yes i confirm that with the last packages the problem is still here. I think that you need to coordinate with the upstream bug to solve this problem.

hawkes (hawkes) wrote :

I can confirm the problem is still present even after Intrepid was released.

Changed in linux:
status: In Progress → Confirmed
Lmt (lasse-maatta) wrote :

I can (also) confirm that this bug still exists with the latest 64-bit Ubuntu 9.04 beta and kernel 2.6.28-11-generic.

Bornakke (bornakke) wrote :

Also got this problem. Has been with me from 8.04 to 9.04

FraGe (fragebuntu) wrote :

Ahhhh, I don't use resume normally, but had to set up the same machine for a friend, so there came up this problem with Karmic x64

I didn't try to downgrade the BIOS yet. Hope, there is another solution!

Short: This is still a problem with 9.10!

stefab (bluefuture) wrote :

Adding Grub parameter atkbd.reset worked. Set GRUB_CMDLINE_LINUX_DEFAULT="quiet splash atkbd.reset" in /etc/default/grub, run 'sudo update-grub' and reboot.

Hi stefab,

Tried your fix on 10.04 LTS, 2.6.32-22-generic (added atkdb.reset in /etc/default/grub) and it works for me!
Thanks!

Changed in linux:
status: Confirmed → In Progress
Changed in linux:
importance: Unknown → Medium
Brad Figg (brad-figg) wrote :

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in supported series, please file a new bug.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
Curtis Hovey (sinzui) on 2012-04-09
Changed in linux-source-2.6.22 (Ubuntu):
assignee: Registry Administrators (registry) → nobody
Changed in linux:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.